Using our own vertical data for mission planning?

Sounds weird, but can we bring in our own DEM for elevation data when using terrain following? Next week I have some pretty mountainous terrain to map lidar. I’ll need to fly a max altitude of 50 meters. Combining SRTM grid spacing with large trees and it could be an issue (crashing lol). But if I could fly photogrammetry at 100 meters and create a dem in Pix4d I would have an accurate altitude profile. Any way this would work?

1 Like

I have asked the same and this was the reply:

Supposedly if you place a geotiff in the srtm directory Mission Planner will use it.
This was a solution from Michael Oborne.
Apparently Mission Planner uses geotiff format for elevation data.

Example here

all the video is really doing is

  1. load elevation data in globalmapper
  2. check projection is wgs84
  3. export elevation data as 16/32bit geotiff
  4. place geotiff in srtm folder.
  5. test that the data is loading from the geotiff.
    Apparently it uses WGS84

Can you let me know if this works.

Make sure you have the latest Mission Planner.


I’ve uploaded custom GEOTIFF elevation data and flew auto missions at a constant altitude above the imported elevation data. Worked really well.

X1 Aero,

Not sure where you are. If the leaves are off the tree photogrammetry will likely lead to a good terrain model. Otherwise, you’ll get a lot of data from the canopy.

Thanks guys! I would have never thought I could use a goetiff. As for canopy, it’s all fir and pine. Modelling the canopy will be perfect, as I don’t want to run into a tree or the ground lol!

Does mission planner ignore the SRTM then?

My understanding is that it will.
But I have only the recipe I found for a client who wants to do the same thing.
I have not tried this personally.


You may find this thread useful.


in newer MP versions you can see where the altitude data is coming from by looking at

Wow, that’s pretty cool. Is there anything MP can’t do : ) Need to try this out tomorrow. Thanks for all the help!

I have developed a GeoTiff grid file. But my Mission Planner program folder does not contain a folder called ‘srtm’.
I tried creating a strm folder and placing my GeoTiff file within (WGS84 Lon Lat format) the folder, but I cannot get my survey mission to use the vertical data from the GeoTiff. Our mine has very different vertical data used by Google Earth.
Any help?

please look in
C:\ProgramData\Mission Planner

Hi Michael,

I had this working previously, but can’t get it working now. I doesn’t seem like Mission planner is recognizing the GEOTIFF in the SRTM folder.

Any help is appreciated.


please see my previous comment.

recent MP versions moved the folder. to make it windows store compatible.

Thank for the reply. I had to reinstall mission planner from the App Store. After I did that it worked well.



How can one test if the Custom GeoTiff is loaded within MP?

I’ve re-installed MP, now with an existing srtm folder.
I created a GeoTiff file for our mine site in WGS84 (Long, Lat) projection, and placed it in the srtm folder.
I moved all other files originally within the srtm folder to another folder location.
i.e. the only file within the srtm folder is the custom GeoTiff of the deep open pit.
However when I view the Flight Plan page in MP, using the ‘Custom’ pull-down map option,
the cursor pointer displays the same elevation as would when using Google Earth Satellite (i.e. the incorrect elevation data), and not vertical data from the custom GeoTiff.

How would I differently test if MP is using the custom GeoTiff?

I notice some users can view a black&white text window.
If this is a method, I’ve been unable to view it. How can I gain access to this text window?

I notice some users can view a black&white text window.
If this is a method, I’ve been unable to view it. How can I gain access to this text window?

I think you are referring to the debug console. Under the help tab check the box next to show console. Once you get this opened two screens should appear when you start mission planner. In the debug console you should see your file loaded.

Also, wondering how you created your GEOTiff?


the srtm folder has been moved in newer MP versions.
C:\ProgramData\Mission Planner\srtm

try there.

Alright an update on my progress. So it appears this isn’t working the way I previously communicated. My custom imagery is working great for mission planning. I can see the image with great resolution and have high fidelity elevation data. I plan the route with my custom imagery, select terrain and upload load my mission to the flight controller (Copter 3.4.4 on a Pixhawk). Instead of loading my GEOTIFF, Mission Planner loads SRTM data (which is insufficient for my application). I removed the SD card, loaded my GEOTIFF and deleted SRTM data. And I set terrain_spacing to 0, thinking this might inhibit SRTM data loading. Went through the process again, it it uploaded SRTM data to the flight controller and seemingly ignores my GEOTIFF.

To put it succintly, Mission Planner recognizes and uses the GEOTIFF; However, the flight controller doesn’t.

Anyone have any luck getting this to work?




Thanks for your reply advice.

My Mission Planner (MP) was automatically installed under a different
directory (not C:\ProgramData\Mission Planner).
No ‘ProgramData’ folder is found on my C drive.

My Mission Planner was automatically installed using the following

C:\Program Files (x86)\Mission Planner. This installed on corporate
work computer, using Windows 7.

Under my MP directory, no srtm folder was created. (see image capture of my
MP Directory).

If you kindly send a web address for a trusted MP download, I will
reinstall a clean copy.

Given Google Earth (GE) vertical data is very different (as much as 100m
above developing open pit elevations), and also given variations in slope
direction are also very different to GE. Also, given terrain slope is very
steep 30 - 40 degrees, terrain hugging is highly advantageous for

As for MP using custom vertical data (GeoTiff), we in the mining world
deeply desire this capacity for our drones to hug custom mine terrain.

As for MP development, It shines above all others. Well Done!

Alan (Jonty) Seymour


I uninstalled MP, and then reinstalled a new copy via

In looking in the new MP folder 'C:\Program Files (x86)\Mission Planner’
I see that no srtm folder was created.

To also confirm, a folder ‘C:\ProgramData\Mission Planner’ does not exist
on my C drive.

Do I need to force installation of MP into a newly created folder ‘