Unable to flash/update my new Cube Orange

I’ve read several posts now about folks with nearly the same problem, let me be direct:

  1. I think this problem is because the “factory” is not installing any firmware at all on anything. This sucks.
  2. Legacy firmware install within Mission Planner (v 1.3.76) works fine with my older Cube Black, I can flash and connect and upgrade the bootloader on it.
  3. I have uninstalled/reinstalled/repaired/driver wiped/manually wiped ALL mission planner installs and drivers. I was unable to uninstall any Microsoft HEX drivers, it gave errors I’ve never seen before so I’m not breaking my Windows 10 operating system over this so I stopped trying.
  4. New drivers are installed, they installed via the latest Mission Planner installer.
  5. If I hook up the USB cable to the Cube Orange (installed in my airframe already) and then hit Plane V4.1.6 OFFICIAL under the SETUP tab/Install Firmware option it gives this after saying “are you sure you want to”:

  1. I’ve reported the error, but who cares.
  2. My COM3 is selected because it says “CubeOrangeRevB-BL” speed is set at 57000, 115200 also does not work.
  3. AUTO select for COM port also does not work.
  4. Force Bootloader times out and reports that it was not able to send commands
  5. Bootloader Update also times out and reports Failed to find device on mavlink

10.5 Trying to Load Custom Firmware (.hex file pulled from official library for either copter or plane) gives this error:

  1. I have an updated version of Windows 10
  2. I had an older Cube Orange that did not survive a crash which I was able to connect and update on multiple occasions.
  3. This Cube Orange is NEW OUT OF THE BOX. It is also the SECOND one that I have this same issue with, I do not know the manufacturers of either nor do I care.
  4. I do see this information displayed after some kind of connecting attempt (lower left corner):

  1. I looked into DFU mode and no way am I taking this thing apart as it ruins the integrity of the flight controller (I use drones in very public places at times).
  2. Beta Flight Configurator, STM32 Cube Programmer and one other program that was on the documents page for first time firmware flashes but none of them worked either. They do mention DFU mode but again, no one should be expected to do this stuff.
  3. I’ve been using Pixhawk and Cubes since APM 2.0, I can’t figure this out.
  4. Connecting both the USB and a power supply (battery) to the Cube Orange does not change anything.
  5. Updating to Beta Mission Planner a repeating above steps does not work.
  6. I will not try to do Beta Firmwares uploading as it should have nothing to do with this problem.
  7. There is no option within Device Manager that helps this situation, but here is a pic anyways:

Any help would be appreciated greatly!

Howdy!

First off I know how frustrating it is to not be able to get the drivers installed correctly and upload the firmware.
I had that happen to me a number of times the first time I got started with ArduPilot over a year ago.

I do want to mention the CubePilot has a set of forums and they are the experts on their hardware and setup. Link

Your drivers look to not be installed properly. You should see something like this when you plug in your orange.

There is a discussion here about your driver situation: https://docs.cubepilot.org/user-guides/autopilot/the-cube-series-firmware-and-connection-troubleshooting

Thank you for the look bud. I was already using the bottom link and its solutions offered no joy. After uninstalling/reinstalling/rebooting Mission Planner no longer sees the autopilot at all. CubeOrangeREVB-BL now shows up only in the Universal Serial Bus devices within Device Manager. I broke something somewhere.

I looked to see if drivers are getting uninstalled and I don’t think they are, here is what I see under Features and Apps:

Here is my Device Manager:

Here is what I get when I try to uninstall one at a time certain drivers:

Messed with it some more and now Device Manager is showing this:

.

If I then try to install bootloader or firmware it tells me that it has failed to detect the board ID.

New drivers have been installed/uninstalled/installed again

New installs of Mission Planner has happened 3 times now.

No joy.

I tried to flash the autopilot on my field laptop as it has not been updated to the latest version of mission planner nor have the drivers been messed with ever. That laptop is strictly for flying the drone.

  1. I plugged in the usb cable
  2. Loaded Mission Planner, I noticed it had the same “New driver required” in Device Manager
  3. I tried to flash it, it says board ID not found (or some such, but same error as before) tried 57 and the 115 speeds
  4. Pushed the ARM button which went to solid red, tried again, failed with same error, tried 57 and the 115 speeds
  5. Pushed the ARM button again, it goes back to blinking 3 times, tried again, failed, tried 57 and the 115 speeds
  6. Tried again, and it worked with the 115200 baud rate speed.

After it flashed the ArduPlane firmware I unplugged the autopilot USB cable, shut down Mission Planner, restarted Mission Planner, plugged the autopilot back in and was able to Upgrade the bootloader.

I restarted everything including the laptop and was able to connect to the autopilot.

I wish I understood this but I do not.

I do NOT want to go through this again and if I have to update in a place that is anywhere else on the planet but my own home I think I’d rather throw it off a cliff instead. This is ridiculous.

These autopilots need to come from the factory installed with some (which is better than none) firmware onboard and ready to be updated.

I understand how you feel! Up till the start of arducopter 4.0.0 I had no problem updating firmware with Mission Planner. Then I went through the same process you are doing. As there was never any mention on the forums about the problem I assumed it was how my computer was set up. Then I tried Qgroundcontrol. Now whenever I need an update I just do it with Qgroundcontrol. For about the last 6 firmware updates worked first time everytime. I did try Mission Planner after each update but still no connection.
Mission Planner works fine with everything else.using latest beta and Windows 11 with updates.

It looks to me like there is no bootloader installed, which may require DFU mode to fix. I have never seen a Cube show up in the device manager the way yours does (without MAVLink and SLCAN labels).

I agree that disassembling the Cube is not a viable fix, and there is no other method of which I’m aware to enter DFU mode.

I also agree that QGroundControl is worth a try, but I would not expect different results in this case.

I think your best recourse is to contact the manufacturer for a properly flashed replacement.

AWWW MAN!! I so don’t want to learn another ground control software…I’m very comfy with Mission Planner…

You only have to learn how to flash Ardupilot. Once that’s done, assuming QGC does it, you can go back to MP.
Vehicle Setup>Firmware then plug in your board. Select Ardupilot/Chibios and the specific board and flash it.

Yuri, are these supposed to come flashed? When my flash finally took it was not the bootloader update it was with the normal arduplane firmware which implies that the bootloader was indeed already there.

I’m also thinking maybe one of those previous tries could have kicked the bootloader into some sort of brick me mode?? I really don’t know.

I will 100% keep that trick up my sleeve…I have another one of these for work that was giving me the same problems so I’ll try it there when everyone gets UN COVID’d up there.

They should come with a bootloader that is compatible with USB uploading of firmware. I don’t know all the gory details, but I’m almost certain that if no bootloader is present, you cannot flash without setting DFU mode first.

Did you achieve success?

So of course I fiddled some more with this. I’m not sure what else to try or document but just in case a dev sees this post I’ll document this.

It turns out my laptop (the computer that got it to flash after 5-6 tries) is running windows 11 and NOT windows 10.

Since my autopilot was successfully flashed I then took it back to my desktop and tried to change the firmware from cube orange dshot to the normal cube orange firmware (dshot was a mistake to load on my part).

The COM port that Mission Planner is reporting is now COM 7 and COM 8 both are labeled USB Serial
Device. I still can not flash with my desktop BUT I can connect to the autopilot via COM7 (have not tried COM 8) at either 57 or 115 speeds.

I’m certain now that this has to do with code within Mission Planner, specifically how it interacts with the “updated” UAV Drivers. I say that because Windows 11 begrudgingly worked, the COM ports are all over the place (in my case) and the consistent error messages I am getting (which I don’t understand because I don’t code).

Regardless, since I know this stuff has gone from hard to do to hard to improve I am grateful that these things are available to us in the civilian world. I do get frustrated with them and even heartbroken but I do manage to keep reengaging. Cheers.

FWIW, I am successfully running Mission Planner (latest beta) on Win11 with zero problems. I have flashed Cubes with countless firmware since the Win11 install without issue.

It was a complete fresh install of Win11 and fresh install of MP. I did nothing special with the drivers.

Had a similar connection problem. Somehow shocking how nasty it is to get the cube orange connected to mission planner. You would hope it to be plug and play! Here is our issue:

We have windows 10 pro. We finally removed our mission planner and installed the latest Stable mission planner, Run it as admin, then opened Contr+ F screen to Clean Drivers

Downloaded driver.msi files as prescribed

Then reboot Mission Planner, connected the Cube orange and found this:

Com4 ProfiCNC CUBE – New c, in the box of port options, but not the necessary one for the cube orange…

In device management same issue under port:

ProfiCNC CUBE - New driver required (COM4)

We followed instructions on this page and yet do not succeed…

This still appears to be a driver issue. Try installing QGroundControl and see if the drivers from there work.

Also, please stop repeatedly posting the same question.

This looks like a manned quadcopter. ArduPilot does not allow usage of the firmware on manned copters. The developers do not want to be responsible for any lives. I simply do not want you using the code I wrote, it might endanger the life of the pilot.

The purpose of this one is a freight carrier: it will only carry 50 kg of freight and only on experimental basis. Hope this is clear. BTW good to know you as a writer of the code: we acknowledge the enormous effort that went into the arducopter firmware! Cheers Winfried

PS I can insert an explanation on the drone picture…

SOLVED CONNECTING MISSION PLANNER TO CUBE. BTW we studied the recommended suggestions again carefully and noted that at first when doing steps 1 and 2 (removing existing mission planner, and downloading mission planner latest or stable version and next the driver.sm), we saw after a reboot the com4 port with the notion of ProfiCNC - CUBE new c and not the desired one. We also checked on the port in Device Manager that the port was described as ProfiCNC CUBE new driver required. So not the required result! But we then tried to dowwnload beta or custom firmware (not pressing the connection button, but making connection with Cube). That opened the road to ardupilot download centre, where we selected arducopter (the last stable version, then the cube orange and next the arducopter.apj version. This only opened the process. The white bar filled green! Then all things started to move: when having moved arducopter into the cube, we could select frame type etc… Also the connection to the cube then changed to the desired 2 options noted in the right connection box. This process should be clearly described by the CUBE PILOT, as this part is not clearly explained and gives many people headache! Cheers Winfried

PS One comment The new version of ardupilot is much improved! Also to include eg prop size related parameters!