Cube Orange copter 4.1.4

Hello everyone, i have a problem. After updating firmware copter hexa 4.1.4 from 4.1.3 on cube orange MP wont detect the autopilot. I tried reinstalling it and firmware wont even begin to install. Tried to install older firmwares but the installation process wont even start uploading it on cube. Someone knows whats the problem?

Likely not a problem with the 4.1.4 build, but rather a corrupt install.

QGroundControl was helpful in solving the issue for another user:

Thanks for the reply, my problem is slightly different, i can see cube orange mavlink in the device manager but with little triangle on it. Cube bootloader is showing too without problems, and when i connect with usb cube orange on my windows laptop, i can see “com 8 cube orange bootloader” but i cant see mavlink so i can connect it. I tried reinstalling MP with new drivers as the cube manual suggest, but the problem is still the same. How i can try to solve it with QGS? I dont know that metod. I dont know how to solve it becuase firmware wont upload to cube but bootloader is visible…

Is there any chance that while firmware was uploading it didnt finish it 100%? If thats the case how to solve this…

I know the problem isn’t completely identical, but QGC has a slightly different board programmer that may solve it in the same way. You just install QGC and use it to flash the board with ArduCopter.

1 Like

Just try this:

Pick Chibios, the Flight Controller and current Stable and flash it.

Thanks, i will try tomorrow to flash it with QGC, i was looking for tutorial since i didnt use that program, and i found this:

QGC upgrade firmware is this ok?

I cant see in this tutorial option to chose Chibios… i will chose ardupilot stack and mark stable version as i can see, then we will see what happens, i will post tomorrow answer.

Like a lot of Youtube videos, that’s old but the gist of it’s right. You don’t need a tutorial it’s pretty simple. You don’t want PX4 you want Arducopter.


I did it, everything is working fine now. Thanks for the help guys, now i can get back to my hexa rotor drone. Now i have to see what parameters i have to change and adapt so my drone can fly good, because i had problems in Loiter mode, the drone cannot retain position. In stabilize and alt hold mode it can fly with my contstant interaction, but in loiter it starts to lose stability and i must put him on the ground otherwise it would crash for sure. I will try to calibrate compass again.

Start a new discussion for the tuning issues, and paste in a link to the .bin log file
Describe all the components to: motors, props, ESCs and so on