Unable to calibrate RC radio [solved]

Hi everyone
I am having this strange issue where i am unable to calibrate my radio.
I was previously using AC 4.0.7 on my Holybro pixhawk 4 mini and did many successful flights.
I planned to update my firmware to AC 4.1.1, i was successfully able to complete all the mandatory setup instead of calibrate radio.
When i am on that page even if i move my sticks i cannot see any movement in the bar, the sticks are stuck at the default position. The RX and TX are bound so thats not the issue.
I tried this with previous version of Ardupilot and rover and the issue still existed, surprisingly it still existed in AC 4.0.7 which worked perfectly few days back.
But when I flashed AC 4.1.4 I was able to do radio calibration.
What am i missing here am i doing something wrong?

My setup
FC: Holybro pixhawk 4 mini
FW: currently on AC V 4.1.4
TX: Hitec Aurora 9x
RX: Hitec optima 8 SL

Thanks & Regards,
Mohammed Naveed

AC ver 4.1.4 is what you should use, there would be no point jumping from 4.0.7 to 4.1.1 instead of just going straight to 4.1.4
There has been some work to SBUS protocol recently too.

Check the release notes:

WIll stick to V4.1.4, Thanks!!