TXMOD v2.0 868/900 new software update (3.54)

Hello!
I am using the TXMOD v2.0 + RFD 868x kit. It worked very well on the RFD SiK 3.38 software version. I noticed that the new RFD SiK 3.54 software for these modules has been available on the manufacturer’s website for about a month, so I decided to install it. After installing the appropriate firmware file and spiffs components, TXMOD is unable to read parameters from the built-in RFD 868x and not able bind to the receiver.

What’s worse, after uploading the old files back I am still not able to connect to the drone.



I will be grateful for your help.

@Seppo or anyone from RFD

I also am in the same boat, as a matter of fact I got shipped a completely non-connecting pair of radios (TXMOD v2.0 and RFD900x v2.) The latest for the 900x and ux is 3.57 but when you look at the firmware for the TXMOD and look at the change log it says everything must be on 3.52 to work. Okay that is all and well but RFD does not provide that firmware anywhere on their page, their documentation is pretty much worthless when things don’t match and the firmware they tell you to use is non-existant! It is very frustrating when you purchase a product from what you thought was a reputable company only to find out they do not care about their customer after they have gotten your money. Weeks have gone by with zero response from rfd support.

Can anyone share their experience or possibly help getting these pretty paper weights to work properly. Please see attached photos for of RFD’s firmware page and the txmod v2 change log


Everything is already working very well for me. The range is almost infinite.

My problem was that after updating the firmware to TXMOD, the transmit frequency changed from 868MHz to 900MHz. I sent back under warranty, got a new one.

Remember to have the software loaded Edge TX on the radio, for me RFD did not work with Open TX.

To update the firmware on TXMOD it is best to remove the RFD from inside and update it via FTDI cable.

@ZDRONA

care to share what versions you are running. @Seppo do you care to support your devices at all? I for one think we should remove vendors that do not support customers and think that rfd should 100% be removed from hardware category. if they are not going to support customers then why have a section for them when there are way more active radios out there the ardu does not have hardware section for. these radios and the TXMOD in their current documentation and support are 100% non-working and need to be removed. RFD will gladly take your money and provide zero support. please rfd clean up your garbage documentation! @TRIDGE I had read you had something to do with helping develop RFD radio firmware, do you care to elaborate on their lack of any documentation are they even a reputable company anymore given their complete lack of engagement in any of the ardu community as of recently.

I understand your frustration, and I’ve sent links to your posts to @Seppo
The old RFD900 firmware was based on SiK firmware which I developed, but the RFD900x (and now v2 firmware) is quite different and I can’t help support it.

Hi guys,
apologies for the confusion. It seems like only spiffs V3.56 is available for TXMOD V2.0 on the website. Will get that updated but in the mean time you can use spiffs V3.56 for TXMOVD v2.0 and it will run with V3.57 firmware on the RFD900x V2.0 modem. (if I understood correctly you have V2.0 TxMod and V2.0 modem?)
Here is the V2.0 Tx modem firmware:
http://files.rfdesign.com.au/Files/firmware/RFDTxMod-V1.48.4m.bin
and the spiffs file to load V3.56 on to the modem:
http://files.rfdesign.com.au/Files/firmware/RFDTxMod-v1_spiffs356.bin
and here is the binary to load onto the V2.0 RFD900x V2 modem:
http://files.rfdesign.com.au/Files/firmware/RFDSiK%20V3.57%20rfd900x2.gbl

Please note that the V2.0 TxMod contains a V1.4 RFD900x modem
and the V2.1 TxMod contains a V2.0 RFD900x modem. (an unfortunate version overlap on 2 separate hardware’s that are not actually the same)
But they will work with either type of modem.

I will get someone to upload a new spiffs V3.57 for TxMod V2.0 but the source did not change between V3.56 and V3.57 for the V1.4 modems so it is safe to use V3.56 on the V1.4 modem inside the TxMod V2.0 and use an RFD900x V2.0 modem running V3.57 firmware in the UAV.

Hope this helps

Welcome to the forum Kent always great to get info from the source!

Just to add a little bit more to the confusion.

I have a TXMOD v2 which came with the v1.4 modems. I checked with Thomas and he sent me a link to the spiffs (same as you have listed) because as @fuego said the online documentation states 3.52 should be used.

Next flashed the firmware over wifi but that failed. A manual update to v3.57 went ok. Had telemetry connection between modems but I didn’t check the SBUS connection. Only checked that RC flight mode showed the change on Yaapu. That was with an Orange Cube.

Thinking all was well, I flashed a firmware update 3.57 to v1.1 RFD900x modem. Powered up the Black Cube. Had full telemetry connection using Yaapu. Moved onto arming the drone. Works great.

Went back the Orange Cube – full telemetry but it would not arm. Finally figured out it was not getting a SBUS signal on the v1.4 that came with the TXMOD v2.

In the end I have the TXMOD v2 with v1.4 inside running on a Taranis X9D plus with EdgeTX 2.7.1 and Yaapu 1.9.6 dev. And two v1.1 RFD900x modems working but a v1.3 RFD900x AU and the v1.4 that came with the TXMOD all pair and share telemetry but no SBUS output
Forgot to add that the v1.4 modem with firmware v3.16 worked no problem. Only had the problems with v3.57

Hi,
Yes that is a little confusing since we don’t allow SBUS to be setup on the TxMod? It can be done manually but the default setting and the wizard will setup RC/PPM on both ends.
You will have to manually set channels on the TxMod end if you are using an AU locked modem on the remote end since it’s radio settings cannot be altered.
Can you clarify where you are using SBUS? i.e from transmitter or are you changing the remote end to output SBUS? It can be PPM on transmitter and SBUS on UAV if set up manually this way.

1 Like

Hi Kent,
That’s an interesting comment about not setting SBUS on the TXMOD? These are my settings which are both the same default settings apart from Net ID and the RC/PPM - SBUS settings. Only difference is the modem version. Both v1.1 fully work with these settings but v1.4 doesn’t but it did when using 3.16 firmware. I probably got the settings mixed up when I changed the modems to the AU settings ie. 23 channels etc.
At present I have SBUS set on the external mode of the Taranis with the v1.1 modems working.


Problem solved all modems working!
Even though I had written and saved multiple times the commands where not always being correctly saved.

Hi,
Yes you can do it manually using RFDtools from the Air modem, or from the modem page on the TxMod but the default wizard on TxMod does not support setting up SBUS.
It does work though. FYI we do recommend setting the air rate to 125K when using SBUS or PPM, and also check that you are not sending too many SBUS packets on your transmitter by setting the rate down to 50 Hz (20mS). 64K air rate will work but it will be a bit less responsive on the controls, and limit telemetry throughput.

I’m having a problem with sbus output, I have a tx16s with edge tx. Txmod v2. Telemetry and Sbus are working , but after a few minutes the values for random channels start jumping around on the radio calibration screen. So much so that i would be afraid to try and fly with it. I’ve followed every instruction I could find but can’t figure this out. Anyone else come across this problem?

@rderks Have you tried following Kent’s suggestion of 125 Air Speed and setting SBUS packets to 50 HZ? @xfacta has many useful suggestions in various post also which I have now used. What a difference!! Using 115200 Baud, 200 Air Speed and 80 Max Windows I can now download log files without using cables! The twitching I had similar to what you describe has gone also connecting to Mission Planner UDP takes seconds compared to minutes using the standard setting 57600.
If you decide to change the baudrate don’t forget to use the Web Interface/General Settings to change the Baudrate. I had changed the Baudrate in RFD900Tools thinking that was where to do it but there are two places.I had communication between modems but no telemetry. Using the Web Interface/General Settings is the other one to change.

Thanks for the reply Lincoln, I’ve tried those settings for Sbus previously and the channels still twitch like crazy and sometimes stop going to there end points. Telemetry has always been working well with no issues. The solution I found (though not perfect) was to set the txmod to ppm and the air radio to sbus as the radio can convert internally. Now there is no glitching and can use the normal failsafe method. The only thing I can think of is maybe there is a problem with my tx16 or possibly Edgetx or maybe the fact I’m using an old 3dr pixhawk1. I have found posts with other people using the same setup with no problems. I have a couple more radios to install in some aircraft running Cube Orange so will see if those will work as expected.

Cheers

Have you tried to change the SBUS refresh cycle at the TX side? try 20ms instead of the default 7ms.

I don’t think I tried that, will give it a shot.

So, at first it looked promising, but after letting it sit for a few minutes and toggling some switches and moving the sticks around the problem returned. I’m stumped on this one. Have read every post and googled hours away trying different solutions. Only one that worked is ppm in on the txmod and sbus out on the airside.