TXMOD + Radiomaster twitching SBUS but not PPM

I’ve read through all the forum post on TXMOD, SBUS, and Yappu and that’s been super helpful and great stuff. But I have a problem i haven’t seen before and could use some input from the group.

When I have SBUS configured my servos are twitching in my plane. I can see the twitching on the channel monitors on Mission planner, but not on the monitors on the Radiomaster. When I turn off the radio/ txmod the twitching stops. When I switch to PPM it stops.

I put some chokes on the servo wires and rfd wires.
I changed the RFDUX (airunit)
I moved the antennas away from servos
I turned the power way down
Checked firmware
Checked settings- works on another plane my friend has with the same parameters

I’m thinking its some grounding issue or weird interference I don’t under stand. I’m hoping is some dumb issue right in front of my face that someone can point me to

Maybe something is bad in the Rx itself? Might be worth trying a different type of Rx.

Hi. I have same problem. my setup is TX16s->TXMOD—>rfd868x–> Cube Orange+ RC IN. Usually problem starts in few minutes after reboot TX16s, this is how RC channels looks for FC(I am not moving gimbals)

Also I tried exclude RFD modems from signal path by direct connection(wired) TX16s SBUS and GND pins to Cube Orange RC IN. In this scenario everything working perfectly:

@maxtubman do you use rfd868x or rfd900x?

I am using 900mhz version. I ended up setting up PPM just so I could go fly, I will eventually go back and figure out why SBUS if giving problems but PPM is not. I can’t confirm at the moment but I am pretty sure the problem would stop when I turned the Radio master off. Which doesn’t narrow it down much but does narrow it down a little.

I got it working fine with SBUS:

Some more details:

@amilcarlucas Thanks, I read this before and I have the same configuration, just running latest firmwares(txmod 1.4.8, rfd 3.57). In my case SBUS works in general, the problem is random spikes in channels. Have you faced with this problem in your setup? I also tried PPM and it works perfectly.

@maxtubman could you explain what do you mean? Do you mean turning off radiomaster tx16s or Radio master is some configuration option?

I also found this topic RFD900 / TXMOD and SBUS with same problem and tried to play with SBUS refresh rate on tx16s, it hasn’t change anything for me.

Maybe it depends on the OpenTX firmware on the transmitter? My test was with OTX 2.3.15 and changing the refresh rate fixed the problem in my case.

We can gladly compare the whole configuration, but I won’t have the equipment available again for a few days.

I made few tests with different refresh rates and looks like it doen’t affect anything. I turning on Tx16s and after 30s-5min I starting to see spikes.

9.5ms refresh rate:

10ms refresh rate:




I am changing refresh rate there:

may be only difference - how fast spikes will appear after radio turning on, but I am not sure there is correlation

Looks like same issue:

do you mean you have the same issue as I did? did you start a new thread?

1 Like

https://discuss.ardupilot.org/t/txmod-v2-0-868-900-new-software-update-3-54/84293 I had a slight delay and twitching with using SBUS on Taranis x9d plus. Taking Kent’s advice at the post using Air Speed 125 instead of the default 64 solved my delay/twitching. Works like a dream now!

1 Like

I use
Baud 115
Air Speed 200
Max Window (ms) 80

Works OK on Taranis and TX16S.
Also good for RFD’s without using a TXMOD, no problems downloading logs
I cant say how the increased rates affect range because I cant get the damned things to go out of range :grin:


I have been traveling for work so haven’t had a chance to try these suggestions. I will try adjusting the airspeed and report back.

I am having the same problems with sbus with almost identical setup. Interested to see if a fix can be found.

@rderks what edgetx version you running? I am on 2.7.1

I have same configuration, also I tried to set max window to 40, as RFD FAQ(http://files.rfdesign.com.au/Files/documents/Modem%20Support%20FAQs%20V1.2.pdf) recommends:

How can I improve the performance of my R/C signal pass through?
Due to the nature of the RFD modem communications, there may be a noticeable jumpynature to servo movement and a perceivable latency in the R/C signal. Depending on the telemetry data requirements you can help to reduce these issues
somewhat by reducing the MAX_WINDOW parameter from the default of 131 to as lowas40 depending on the air rate. This can reduce the data throughput somewhat so theuser
may have to experiment to find the settings that best fit their use case.

I’m on the same firmware 2.7.1