Tiltrotor support for plane #2

I finally was able to mount my Feiyu Tech G3 Ultra gimbal to the FireFLY6 DIY15 and add an analog air speed sensor. The AS sensor really helps the transitions into wind and when flying in CRUISE or LOITER modes. The original FF6 series didn’t use AS sensors but now that it is running on APM Plane, the sensor really helps the VTOL performance. As usual, the first flight was for calibration only and then I enabled it. It works great!

Just found this topic. But I’m working for a long time with this:




Log: https://drive.google.com/open?id=1SrzyvTSncMg1pmISFn7eCASiXTMenBEn
Params: https://drive.google.com/open?id=1TM6nxKrnoL4Ei9M-AWqB2T9NKFy7T0h4

Test 46: https://youtu.be/R_R8dkj_Qws

Test 47: https://youtu.be/CGYzC9v1_TY

Test 48: https://youtu.be/HINcB43YoW8

If this topic is still activ, I can post more experiences.

Hi lorbass,

Very interesting! Thanks for posting.

On your Test 40, you have discovered what happens when you try to hover a wing in some wind. It becomes a sail as soon as you stop pointing the nose into the wind. These type of designs are really meant for short term hovering and mostly flying.

Also, next time try using the QSTABILIZE mode instead of QHOVER. The throttle response would have been much greater on the roof and perhaps it would have escaped. It was interesting that the fire truck used the bucket extension to retrieve the plane instead of gaining roof access through the stairs. They probably never saw any aircraft like it before! :slight_smile:

Cheers!

Hi Greg,
Thank for the answer.
Yes, a VTOL Tri Tilt needs also a “runway” to slow down, but in the air.
QStabilize, helps to shorten, but continue as rocket.
Therefore I tried to slow down as possible in FBWB and the experiment shows the Video with Test 50

The fire truck is the newest technology in this region. The basket ist standard, the water in an extendable tube, the jet is controlled by a joy stick in the basket (jet by wire :wink:) the basket can carry up to 5 persons. An so I was on the roof to prevent an accident by the perhaps rotating props.
This fun cost me 500 CHF (~450 $)

With my VTOL Tri Tilt I have still the issue of right yaw during the Transitions.

These are the newest videos:
Test 49, Test Climbrate increased to 4m/s, Transitions FBWB

Test 50, Where is the min.Speed in FBWB, 2 Stalls


Happy flying, Otto
2 Likes

Hi Otto,

great tests and also great video documentation. I think, stall speed is 42 kmh (26 mph ;22,7 kn; 11,7 m/s). Did you ever tried to slow down in FBWA with Q_ASSIST enabled (eg Q_ASSIST_SPEED 1m/s lower then ARSPD_FBW_MIN) ?

Ouch! :cry:

Although expensive, I am glad that you could retrieve your VTOL.

Hi Rolf,

Can you confirm that the Q_ASSIST_SPEED function still works on a tilt-rotor configuration? I have only tested this on a QuadPlane and was uncertain of the result on a tilt-rotor configuration.

Cheers!

Not yet, will try it later.
As Tailsitter I could fly with 9m/s without stall, then simply the Tiltunits showed a litle upwards.
Similar to Q_ASSIST_SPEED?
By the way. I learned to use Dashware from you, thanks.
I was asked several times what is this for a OSD System.

Hi Greg,

Why should Q_ASSIST stopped working? It works on tiltrotors Plane 3.9.2beta release

1 Like

I’ve had Q_assist working on newer versions than that, it’s not something I routinely test but it crops up every now and then when I fly my heavier VTOL mapping birds in FBWA. The version I use now is 3.9.6, but I see no reason for it to have changed since then.

Thanks for the confirmations, guys. I’ve never tested it on tilt-rotors, perhaps because my only two tilt-rotors (Nimbus and Convergence) were maidened this summer and I have had QuadPlanes for years now.

Some more Test Flights.
Not happy with Transitions, sometime strange behavior.
Test 51, wrong Airspeed, faster than indicated. (Kalibration?)

Test 52, bad Transition, fallen in Downwash?


Log: https://drive.google.com/open?id=1lRaE6Q15hI-xh5SCXIbAqosAxNzf6Pf5

Test 53, low Level approach to see Transitions


Log: https://drive.google.com/open?id=1QBKdakZpDLXG4jb6BJJ1DqKeFmNEvD8K

Bad/wrong Transition QStabilize to FBWA see:

Hello Everyone,

I am a beginner, I wanted to make a VTOL. I made the drone frame with motors seperate and airframe separate. I am using. Pixhawk 2.4.8. Flysky FS-TH9X remote. FS-i10b 10 channel receiver.
I have 3 2300kv EDF 6s it is fixed to Tri plus frame. in the front 2 back 1. The front 2 edfs are connected through the axil and I use one 10kg servo to tilt front and back (throttle). back one also connected to the servo it controls the YAW motion.
i have issues are It wont move or stabilize it only reduce the speed. no work on servos.
My servo output i kept this way.

servo 1 : Motor 1
servo 2 : Motor 2
servo 3 : Motor 4
servo 4 : RCIN 1
Servo 5: RCIN 4

It never stabilize by own. Can you help
Also I am unable to convert it into flight Mode
I wanted to use the front 2 edf for the thrust in the flight mode

Please help me to setup correctly

can you post a picture so we can better understand your setup

Which software is it in the above youtube link? It doesn’t look like MissionPlanner to me. Sorry for such a basic silly question.

Hi,
me and my friend are currently working on a tilt rotor tricopter, but we are having problems with the control of the tilt servos.

Our problem is, that as soon as we define the servos as TiltMotorFrontRight/Left we don’t get any PWM outputs at all. When we define the output port for example as an aileron we get perfectly good PWM output and the tilt mechanism is working just fine.
This is our first time working with ardupilot so the reason why it’s not working may be very simple.
Here is our full parameter List:
https://drive.google.com/file/d/1-Z4UJ4y_ZfehrGzMNVLRpFh2ptDQEOtN/view?usp=sharing

If there is any further information you need please just ask.

Already thanks in advance to everybody who is trying to help us

Hi Jann,

I’ll assume that you are using Flight Mode changes, like from QSTABILIZE to FBWA, to activate the servo change from up to forward and back.

The Tilt Mask setting is very important but often difficult for people to understand due to its binary implementation. So re-check this setting to see that it matches your motor positions based upon the standard ArduCopter motor map.

Welcome to the VTOL Plane forum! :grinning:

Hi Greg,

Thank you so much!!!
That fixed our problem!

We had set up the Tilt_Mask some times before and seemingly forgot to reset it to its appropriate value after a reset we did some time ago… Nice to have someone like you “around” who thinks about such things.

Again, many thanks for your fast help, that luckily was spot-on.

Kind regards

Jann

1 Like

Hi,
I am struggling with the exact same problem and it is driving me nuts for about 2 hours now.

The thing is no matter what I do the servos are not going to the positions they should.

The Setup is a Nimbus 1800 as Tricopter VTOL.

So the basic setup after resetting everything is:
Q_Enabled = 1
Q_Frame_Class = 7
Q_Tilt_Mask = 3 (for the front two motors, from my understanding)
Q_Tilt_Type = 2

AND
SERVO9_FUNCTION = 75
SERVO10_FUNCTION = 76

SERVO_MIN for Both = 1400
SERVO_MAX for Both = 2000

That are my basic test Parameters, everything else is default. When I switch modes from FBWA to QStabilize the servos only move from 1470us to 1500us or when I reverse the servos from 1570 to 1500. I do not understand why it is not using the max and min position from 1400 to 2000. Any hint in the right direction will be appreciated :slight_smile:

Hi Jan,

It seems correct so maybe there is something more basic wrong. On a Pixhawk, SERVO9 and SERVO10 are AUX1 and AUX2 so make sure you have the correct outputs connected. Perhaps the 5v output rail supply is missing. Do other servos work like ailerons and elevator?

Perhaps you can post your .param file.

Cheers!