Throttle % limited on flight modes and raised over time

Today I experienced a wild issue after enabling compass. After arming, throttle was limited to under 30% for FBWA and AUTO Takeoff but it was normal for Manual mode. Holding throttle to the max in FBWA at full throttle it very gradually raised the limit.
RCOUT kept raising but it took almost a minute to raise either using FBWA and AUTO.

Log file :Upload files for free - 00000055-anon.log.zip - ufile.io
Manual vs FBWA throttle video.
Throttle limited for FBWA - YouTube

Parameters before enabling the compass and plane acted normal.
ZOHD Dart V4.2.2 Flying Great 2022-09-23.param (29.8 KB)

Parameters changed before this happened. Comparing the current vs old so “New Value” is the previous value.
Screen Shot 2022-09-23 at 12.03.03 PM

Reverted SCHED_LOOP_RATE to 100 and now it worked without issues

DSF.Dp was growing over time apparently the board cannot cope with logging at that speed.
Also increased LOG_FILE_BUFSIZE

After the new test zero DSF.Dp

the link to the logs does not work

Thank you.

the .log format is not compatible with any developer log analysis tools like MAVExplorer or plot.ardupilot.org please provide the .bin file

This is the bin dataflash Upload files for free - 00000055.BIN.zip - ufile.io
Upload files for free - 00000055.BIN.zip - ufile.io

The previous log was anonymized by Mission Planner but it converts it to plain text log and I think plot site doesn’t understand .log files.

Thank you for looking into it.

Then what is an appropriate means by which to anonymize a log? Frequently, I do not want to upload my exact location to a public site. Mission Planner only outputs .log formatted files when using the anonymize feature.

looks like its a real bug due to using watt_max…also your volt_max is wrong…fix will be investigated

This plane crashed in the ocean, the micro SD card got damaged and computer cannot recognize it, tried multiple card readers and in one of them it gets really hot. I have the monitor video with the OSD which is not perfect and the video from the onboard camera which got corrupted but was able to recover some of it.

The plane just fell out from sky based on the OSD video this is what I see, but it would be great if others take a look and come up with a different analysis:

  • Plane is in Cruise.
  • Alt is 20 Mts.
  • Throttle is about 36%
  • Suddenly there are these message:
    ** EKF3 IMU0 YAW ALIGNMENT
    ** AHRS: EKF3 ACTIVE
  • Alt jumps to 54Mts.
  • Number of Stats apparently remains unchanged.
  • Throttle drops to 30%,28%13%
  • Amps drops from 2+ to 0.70
  • Again message:
    ** AHRS: EKF3 ACTIVE
  • Throttle drops to 0%
  • Amps drops to 0.32

My interpretation is that something glitched and the alt increased 30+ meters and because it was flying in Cruise mode Ardupilot tried to bring down the plane 30 meters but in reality it was only 20 meters above the water which ended up causing the plane to ditch into the water.

Last recovered image: