Servers by jDrones

TeraRanger One - not working in AC 3.6

Hi,
TeraRanger one range finder is not working in AC 3.6-rc2,
However, when I am using ArduCopter 3.5 - it works fine.

Is anyone test the TeraRangerin 3.6?
Thanks,
Doron

They must still update their drivers…, i don’t know when it will be.
You were able to make it work under chibios?
Me i must still

Hai, I am having the same problem. Was anyone able to get Teraraner one working in AC3.6?

Good day, i don’t have any problem with teraranger one on i2c or teraranger one tower…

Good day,
Thanks for your reply !
So now I know Arducopter 3.6 firmware is fine for the sensor.
Are you supplying 12V to the teraranger I2C adapter. Do you know how much current it is drawing.
Im wondering if i have any issue with powersupply !
Also one more question does the Yellow LED behind the rangefinder blink or stay lighted when we connect it to the power supply? Mine blinks once and then stays off

sonar.param (12.9 KB)

2020-01-14 16-05-57 t.log (121.4 KB)

these are the results i am getting!

Teraranger one need 12v and you must wire it with the i2c board adapter. If you need an obstacle avoidance you need the teraranger one hub with multiple sensors…, without the hub the sensor can be use only as altimeter

1 Like

Hello,

Does anyone have firmware for Teraranger one to connect with Pixhawk via I2C port?
seems like my firmware is not correct!

Thanks in Advance!

Which version of arducopter you are running? Me I’ve done some test on i2c port and i can read rhe value… just check how you have wired the main cable.
which flight controller do you have?

I am using ArduCopter 3.6.9
Flight Controller - Holybro Pix32 Pixhawk PX4 2.4.6
image
wiring is Flight controller I2C port to I2c adapter of Teraranger One. Also 12v power supply to the adapter.
just like in

Still no positive result with pixhawk. I tried to connect Teraranger One to Hterm software and checked it is working.

ok… later i will send you a pic of my wiring… did you set the correct parameters in rangefinder section on MP?

Thank you for your reply!
Yes, parameters are set as per the wiki in terabee and arduoilot wiki

Note: its showing RNGFND2, but I also tried it with RNGFND (the first option available)

ok… do you have a pic of the wiring of the cable in the I2C adapter

sure,

I saw you have used standard cable… let me check…

ive done a test and my sensor read the distance… are you power pixhawk and sensor one at the same time?

No. Actually in the user manual of TeraRanger one it is mentioned to power it first then give power to pixhawk, I was doing like that.
Since I had no success I tried to reverse the order too.

try in this way… just wire the cables of the adapter directly to the pdb, connect the battery so .fc and sensor will boot together at the same time

No luck man,
Something small is missing! Oh boy… this is such a spoil sport!
I cant figure out what is wrong,
-all the wiring connection seem to be fine
-the parameters seem to be fine set as per wiki in ardupilot and also referred the one provided by terabee
I will keep trying…

Do you have something else attached on i2c?

Servers by jDrones