Telemetry Radio status not logged in plane

I’m using plane 3.5.2. Telemetry radio is an RFD900. I have LOG_BITMASK set to log everything. However, when I checked the logs to check the telemetry strength and noise, I didn’t find any entry on it. AFAIK, the label RADIO should contain the RSSI and noise levels of the Telemetry radio. I’m unable to find it.

Am I missing something here? Is there some other parameter that I have to enable?

Any help would be much appreciated.

Nihal M

The radio information is a mavlink packet which is picked up by the groundstation allowing you to see the rssi and noise as you fly.

As such it is present in tlogs (telemetry logs) but not in dataflash logs.

At least in my understanding.

I’ve seen the dataflash log of a friend and it contains the RAD label and subsequently RSSI, remrssi, noise, remnoise etc. which i wish to check for my configuration.

Edit -
Also, I checked the tlogs, and they do not contain the RAD data either

Update -

I checked dome of my earlier log files and found that they did contain the RAD data. The only change between my recent flights was that I used the piksi radio and changed the following parameters -
GPS_TYPE2 1 Auto protocol discovery mode
SERIAL4_BAUD 115 Baud rate of 115200
GPS_SBP_LOGMASK -1 All messages logged*
GPS_AUTO_SWITCH 0 Switch to GPS reporting best fix for vehicle control.

My friend also used the piksi in his setup but his logs contain RAD data. The only difference I see was that he used 3.6.

1 Like

Were you able to find a fix? I got the EXACT same problem, I need the RADIO data but it is not logged. I’m using 3.7.1.

@arthursn138 you should be looking for “RAD” as the field name, there can not be any messages with names longer then 4 characters, so RADIO is to long.

1 Like

@WickedShell how do you usually analyze your logs?
Beacause while I was typing a reply, I realized I hadn’t try MATLAB to check rssi (the 4char tip triggered me into checking the log out inside MATLAB). And the RAD param is there!
I was so frustrated that I couldn’t find those parameters in the MP’s tlog analyzer (indeed there’s no RADIO nor RAD there) that I didn’t even remember to check my flight log.

It is still odd that I can’t see the RADIO label on the tlog. Maybe I have to enable something else to record the telem data on my laptop’s tlog?

Nonetheless, thanks very much @WickedShell! That was the insight I needed to go around that brickwall!

@arthursn138 I typically use either MAVExplorer or APMPlanner 2 depending on what I want to do.

MAVExplorer is great in that it allows you to apply pretty much any python math expression to what you are graphing (including adding multiple fields together/doing composite graphs). It has the downsides that you can only have 2 scales for the data and it autoranges so if you have a weird starting value anywhere in the log that can make getting the scale you want difficult. It’s also very memory intensive. MAVExplorer is installed as part of MAVProxy.

APMPlanner 2 is great that it lists all the fields and lets you pick which ones you plot. You can have arbitrary scales (and lock data to the same group), change line colors with it, and it will plot the status text messages on the graph as well if you want. And the mouse value reading with it is great. But it can’t do the math stuff MAVExplorer can, and it’s more likely to reject a log file for random reasons. It’s still the better tool for most people though.

1 Like

@arthursn138, thanks for re-opening this thread, I had completely forgotten about this issue!
I tried converting the .BIN to a matlab file, but data is not present in the matlab file. The RAD label is present, but there are no values recorded. The Tlog showed no luck either.

As a side note, Can you please share your SIK Radio settings?

1 Like

Hi, I’m reopening this again.

I’m also opening a new topic on an appropriate category, as seems that the true villain here is Piksi’s configurations.

Last time I was just looking at the wrong params, so I solved it right away. However, now that I’m using a Piksi as GPS2, the very RAD parameter is not logging anymore (shows empty). And that’s something that has always logged for me.

Piksi’s documentation recommend just changing some GPS settings on the plane. However, it also recommend to change ECC and Mavlink settings on Sik Radio (screenshot).

My logs and param are here.
One odd thing is that when you play the tlog you can see the % of radiolink on the HUD, but it shows the value zero for rssi and remrssi on the status tab (screenshot below).

I’m quite positive that the issue is the RawData setting on Sik Radio (shoutout to @Nihal who raised the flag on sik settings). Any ideas on how to solve it?
I really need both the RTK and telemetry radio log.

@arthursn138 RawData means it is not MAVLink aware, and cannot inject radio status messages into the data stream. The RawData message is not compatible with having telem radio RSSI.

1 Like

The Wiki says to set the telemetry to RawData for RTK over telemetry radios. Does this mean that you cannot have RTK and rssi at the same time?

Which wiki? The MAVLink GPS_RTCM_DATA injection messages are all proper MAVLink stuff, there is no need to go raw data at that point.

My bad; it is the emlid reach documentation, not the Here+/ardupilot. They were mixed up in my mind.

I’m not sure why those are their instructions… ECC cuts your band width in half so I kinda get the concern (but you should have a fair amount of bandwidth left I’d expect), RawData removes a bit of wrapping, but costs you the radio status packets, and makes it harder for the radio to guess when to break/send stuff. They are still using the MAVLINK packets for doing the injection so it’s mostly a bandwidth concern.

1 Like

Are there any ways to work around it? Mavlink seems to take forever (I’m talking over 20min) to connect to the plane.

@Naterater you actually can use rtk inject on mavlink rather than rawdata, if you have pixhawk as a middleman (RTK Inject, under optional hardware on mission planner).
That rawdata requirement is for communicating both gps modules directly, without any autopilot on the loop.