Telemetry RSSI not logged after conecting Piksi

Hi guys,

I just revived @Nihal’s topic and I think it’s worth it to create a new one on this category.

After installing a Piksi GPS, the RAD parameter is not logging anymore (shows empty). And that’s something that has always logged for me.

Piksi’s documentation recommend just changing some GPS parameters on the plane. However, it also recommend to change ECC and Mavlink settings on Sik Radio (screenshot).

My logs and param are here.
One odd thing is that when you play the tlog you can see the % of radiolink on the HUD, but it shows the value zero for rssi and remrssi on the status tab (screenshot below).

I’m quite positive that the issue is the RawData setting on Sik Radio. Any ideas on how to solve it?
I really need both the RTK and telemetry radio log.

1 Like

For what it’s worth, I haven’t had those values working in over a year, and I’m not sure why. I never pursued it further.

1 Like

I returned the Sik Radio parameter to RFD’s default and I could see/log these parameters.
Seems like it is the Mavlink / RawData dropdown that controls this.

However, it takes forever to connect the plane using Mavlink. Any ideas on how to work around this?