Telemetry option for crossfire apart from Mavlink?

I have crossfire micro tx so it doesn’t support mavlink. Is there any other form of telemetry (even minimal) that can be send to taranis?

it supports mavlink! The micro and the nano both support full mavlink telemetry.

Are you sure? I’m talking about transmitter module not receiver.

OH, sorry, I didn’t notice that important detail…
Then you’re correct, it doesn’t support telemetry. I don’t know much about the micro transmitter, so can’t offer other options.
If it does frsky telemetry, you might be able to use one of the mavlink to frsky adapters people make.

I don’t want to crash this thread, but I am unable to get Mavlink or SPORT working on Arducopter 3.6 RC12 (ChiBios). I’ve tried every UART/Serial combonation. I’ve tried using a TBS nano RX with protocol 1 and with and FRSKY R9M Mini using protocol 4 & 10. Am I missing something?


Do you know if your nano is connected properly?
It uses pins 3 and 4 on the nano for mavlink, but I don’t remember which is tx and which is rx.

Then you have to enable mavlink on the crossfire nano pin assignment.
You have to enable mavlink over bluetooth in the general crossfire transmitter setup. (well, I get telemetry to my pc or tablet, so I need bluetooth enabled).

In the arducopter config, you simply set the uart you’re using for mavlink v1 telemetry, which I think is protocol1, as you have it. (Not positive, though)
There are some suggested SR settings for the uart you’re using, but mine worked before adjusting them.

What flight controller are you using?

I’m using the Matek 405 CTR. It’s definitely setup correctly because if I flash it with Arduplane it works fine. It’s only Arducopter that does not work. I even tried the Arducopter 3.7-DEV and it’s the same. Do you know how I can download a previous version of 3.6 RC to try. I can only find RC 12, and am unsure where to find previous version? I thought it could be a bug in RC12 and I’ve heard sometime DEV version like 3.7 will use the latest build of the previous release. Not sure if that is true though.

Oh, interesting. I’m running the 3.7 dev version, but it’s about a month old. Mavlink telemetry through the crossfire is working for me.
I know you can download previous daily builds here:

I don’t know how to find previous beta releases.

w1, would you mind sending me a copy of your arducopter config? I have now tried to download all sorts firmware versions and I cannot get it to work. Yet… Arduplane is fine. I’m stumpped!

This is a little 3" prop copter. Crossfire is working on it.

z3.param (16.1 KB)

Back to my original question, what can I use instead of mavlink?

That might be a better question for a crossfire forum… FPVLab or somewhere…
I don’t think many people use crossfire here. Probably even less w/ the micro transmitter, since that wasn’t really designed for full size, long range craft w/ telemetry.
I wish more people did use crossfire with arducopter, to encourage TBS to develop better support for mavlink.

And, their specs, as usual, are wrong or confusing, depending on where you look.
GetFPV lists it as supporting mavlink telemetry… But last I looked in to it (last year) it did not. So, did they add it, or is GetFPV giving out false info again?

Like I asked in my last response, does it support frsky telemetry? If it supports frsky, you could likely use one of the little adapters people make to convert mavlink to frsky and set it up like a traditional frsky receiver.
If it only supports their crsf protocol, I think you’ll have to wait. PX4 supports CRSF, but arducopter hasn’t added it yet. Not sure if they plan to.

W1, Unbeliveable it works with your paramaters. I moved my rx/tx from Uart 1 to Uart3 (Serial1) to match yours and it works. Then I decided to move it back to UART1 (Serial3) change the paramters and it still works. Either there is somthing else in the paramters besides Serial protocol and Baud or the only other thing that changed is I removed my smartaudio wire from the UART when I moved from UART 1 to UART 3. 5min, I’m going to solder it back on and see…

Nope works fine with the Smartaudio wire attached. I’m baffled, but thank you for posting your paramaters. I’ll compare them 1 by 1 when I have more time. Now I can get on and build my long rang TG!

Great! Maybe it was a physical problem? Tiny solder bridge between tx/rx, cold joint, something like that?
Most of the issues I have w/ my vehicles are physical.

If you think about it, after you fly for a while, make a post about how it’s working.
The one thing that surprised me is that when the transmitter switches from mode 2 (150hz) to mode 1(50hz), telemetry switches to a limited mode. You can no longer update parameters or send it a new mission, etc. It still sends back data, but it’s no longer “full” bidirectional telemetry. The point where it switches to mode 1 for me is very close… 50-100 meters. TBS says I should be getting about two kilometers! I’m curious how its working for other people.

No won’t be a solder issue because I have swapped between the TBS and FRSKY receivers about 100 times trying to get this to work and as mentioned it is always fiine when I flash with Arduplane. Def someting in that config. I guess I will know if I reset to defaults. By the way I use the micro TX, so no sending missions. However when flying with INAV sometimes it switches to mode 1 a few hundered meters away and sometimes 1km away. I think it has to do with the noise floor.

Oh, using the micro tx?

So, for the original poster of this thread, I guess mavlink is working w/ the micro tx, at least to get telemetry back to your transmitter. Maybe the limitation is simply that it cannot pass that data to another device (tablet/pc).

That’s why I crashed the thread, I thought it was directly related! Yes Mavlink does work on a micro TX, but you only receive telemetry in Arducopter, unless you can send the Arducopter commands via a LUA script as you can in Betaflight??

@wicked1 I finally found the issue with Mavlink not working on any of the serial ports. All the stream rates are set to 0 by default so Mavlink cannot get the telmetry.

1 Like

I stopped using it because on the bench i had similar problems to your, no parameters and very slow updating overalll. So you say that when getting far away it starts working good? If it is that than i guess it is not a viable solution for me. I’d like it to works as it should near and far.