Servers by jDrones

[solved] Install-prereqs-ubuntu.sh with many errorrs on fresh upgraded Linux Mint 20.1

Because of continuous problems with Cygwin and nearly no support I decided to switch to Linux - but unfortunately there are new problems.
On my recently upgraded Mint 20.1 and fresh system I cloned my repo and started the recommended script

Tools/environment_install/install-prereqs-ubuntu.sh -y

and that’s the output:
tools-installation-fehlermeldungen.txt (8.3 KB)
(I know that’s in German, but I think an insider should see what happened. If necessary I could give some translation hints)
So how should I proceed?

I’m not a linux pro. But a big problem would be that Mint != Ubuntu. The release codename for your Mint install is “ulyssa” which wont be found in the install script and thus the script uses defaults.

You could edit the script to support Mint. Or just use Ubunutu…

I saw you tried using cygwin which I did as well for a while but found it to be too slow. Currently, I use Windows WSL and Ubuntu which is awesome.

I have a Mint system running with all the little helpers I need. So I thought it will be easy to switch to. And Mint is based on Ubuntu/Debian and is mentioned here as usable system:
https://ardupilot.org/dev/docs/building-setup-linux.html#install-some-required-packages

I’m also not a Linux pro and would need a helping Hand to bring the install-script up to date.

Our community does not have enough ressources to support all flavors of linux, may I suggest that you use UBUNTU so You can get a working system right away ?

Yes, you’re doing a very good job and I understand that supporting all flavors is not possible.
I will try to update the script to ulyssa (based on focal) and my last way out will be using Ubuntu directly.

We got a patch comming that should help : https://github.com/ArduPilot/ardupilot/pull/16410
otherwise it should be the same as the focal config so you can replace manually focal by your distro name on line 74.

I added a logical OR and checked for ulyssa at every check for focal, but I run into an error because of python(2.7) is installed also in the packet python-minimal (as standard?).
I tend to uninstall that packet manually and run again, but that’s not the correct way I guess.
(Edit: could a rename of that symlink »/usr/bin/python« a sufficient solution? or an opening of access-rights?)

Vormals nicht ausgewähltes Paket python-is-python3 wird gewählt.
Vorbereitung zum Entpacken von …/203-python-is-python3_3.8.2-4_all.deb …
Entpacken von python-is-python3 (3.8.2-4) …
dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-VnI3MQ/203-python-is-python3_3.8.2-4_all.deb (–unpack):
Versuch, »/usr/bin/python« zu überschreiben, welches auch in Paket python-minimal 2.7.15~rc1-1 ist

Edit: @khancyr Could you add that logical OR and check for ulyssa in your commit please? (I’m not so experienced to change your code and ask you for a merge based on my broken system).

if [ ${RELEASE_CODENAME} == ‘focal’ ] || [ ${RELEASE_CODENAME} == ‘ulyssa’ ]; then

If you need a tester - just give me a hint.

I tested my possible solutions:

  • renaming of /usr/bin/python had no better result, because the connection is still known to apt
  • deletion of package python-minimal showed that’s not available after deletion - so it should be a leftover of an older OS version. After that, my adapted script finished without further error.
    install-prereqs-ubuntu-mint-ulyssa.sh.txt (8.8 KB)

I ran a build of SITL plane and all looks fine - and it’s three times faster than Cygwin :smiley:
and also autotest.py and sim_vehicle.py is working with no problems.

yes, you probably had upgrade the os as you should have python3 as default now.

Servers by jDrones