[solved] Autotest (Cygwin environment): autotest.py --map ... is not working

For developing an autotest-subtest it would be very helpful to have the --map to see what is happening.

When I use: …/Tools/autotest/sim_vehicle.py --no-rebuild -L CMAC --console --map
all is running as expected.

When I use: ./Tools/autotest/autotest.py --map test.Plane
the test is running, but I can’t see a map.

In the output in the terminal I can find “Failed to load module: No module named ‘map’”
(see last line)

How could I fix that?

Just tested here and it seems to be working OK for me, sorry I know that is not very helpful. Maybe check that MAVProxy is upto date?

check you don’t have install mavproxy in both python2 and python3, I would bet it comes from there …

Thank you @iampete , it’s good to know that’s a local problem on my system.

On python2 and python3 there is a module mavnative “>>> print (help(‘modules’) )”
@khancyr I’m a child of windows, so could you give me a little advice to check/uninstall mavproxy where it doesn’t belong, please.

Maybe that’s interesting (but I’m not aware what I see here in detail and how I can update/deinstall a module in a specific python-version):

In the meantime (to have a clean base) I installed Cygwin from the scratch and only with python3.
But the problem is still the same.

sim_vehicle.py is OK:
2021-02-17 21_07_05-Window

autotest.py isn’t knowing the map:

It seems that there are two different MAVProxy installations working.

  • sim_vehicle.py starts the Windows mavproxy.exe
  • autotest.py starts the linux/python-module mavproxy.py (and that does not find the map-module)

So is it necessary to add the PATH-extention as mentioned here?: https://ardupilot.org/mavproxy/docs/getting_started/download_and_installation.html#linux
But is that correct for Cygwin? And if not, what is the correct Path-extention for Cygwin?
Or do I need any further installations for Cygwin as mentioned in that chapter?

The map-module is here:

and that’s my current PATH:
2021-02-18 16_05_58-WindowPath

Could a developer who is working with Cygwin please test:
./Tools/autotest/autotest.py --map test.Plane
and if all is Ok, post here his $PATH and the path where the directory mavproxy_map is.

Any other hint is very welcome, too.
I tried different things like a path-extention /lib/python3.6/site-packages, but nothing worked.
In the meantime I have no further idea what I made wrong or how to fix that problem.

Solved by switching to Linux Mint :grin:

Btw: If you have no Linux installed and start from scratch, Ubuntu should be your first choice.