Servers by jDrones

SkyRocket and ArduPilot

skyrocket
low-cost-drone
skyviper

(Olivier Brousse) #61

Marco, this is a late response but just in case. With Qgroundcontrol you just need to launch the application and connect, QGC will scan and appropriately connect to UDP port 14550. With Mission planner just connect and pick UDP option, same. Not sure with Tower, haven’t tried.


(Greg Leggett) #62

Forgive me, I’m new here … I just took my 2450gps for a flight, amazingly simple!
How does one fly it autonomously - point to point? remember, I’m new!


(Dave) #63

Configure an Auto Flight mode with one of the button press options via the Web server application. Then connect to a ground control station like Mission Planner, plan your mission and upload it to the craft. Then when you are ready to start the mission select Auto and it will proceed with the mission as planned. There are several things here you have to become familiar with (Arducopter in general, flight modes, Web Server, Mission Planner) but that’s the gist of it.


( .) #64

I think my transmitter got bricked when it got the firmware from the App. after I restarted it following the prompts it now just shows a red light and freezes. Have to remove batteries to get it to turn off. The “Force Pair” method doesn’t work either. Any way to unbrick it? Or should i box it up and take it back to Academy?


(Marco1) #65

Olivier

Anyone out there had any luck with conecting video in tower app to sky viper? The app works awesome with 2450 gps sky viper but cant seem to get the video to work??

Mark


( .) #66

I have not. There was a post somewhere where it was said that functionality will be “coming soon” but it’s not. I think the format that the SV sends out the live video isn’t what Tower (and others) are expecting. Someone correct me if I’m wrong, but I don’t think video is working from the SV for any of the GCS apps.

There are instructions on using VLC, but I’ve never been able to get it working on VLC for Android or Windows. I put in the settings and I get nothing.

Edit: The Wiki still says
live video can be viewed through a SkyRocket app (Mission Planner video support coming soon). at http://ardupilot.org/copter/docs/skyrocket.html#using-other-gcs-software

I’m not sure if that is still being worked on though.


(Marco1) #67

Thanks for the info. Hope to find a fix somewhere.


(Olivier Brousse) #68

It definitely works for Mission Planner. But don’t know as far as tower is concerned as I don’t use it.


( .) #69

k, well then i need to try again, and if so, update the skyrocket.rst wiki to give instructions on doing it. Right now, it still says it doesn’t work.


(Olivier Brousse) #70

Control-F in mission planner, vlc (down second column), enter rtsp://192.168.99.1/media/stream2 (or replace with whatever ip address the web server is at).

Not sure where it says it doesn’t work in wiki, yes, should be fixed.

Note that there was an issue a while back that if you are on 64bit windows, you needed 32 bit version of vlc for it to work. Don’t know if this is still the case, but if you get a dll error im MP that’s probably it.


(rmackay9) #71

I talked with MichaelO about this earlier today and he said it should just work but he said one issue is that you can’t connect with the tablet before MP.

So the best procedure would be:

  1. make sure the tablet is off (or at least don’t connect to the drone from the tablet).
  2. power up the drone
  3. connect PC’s wifi to drone
  4. start MP, set top-right drop-down to UDP, press Connect

I got it to work on one of my PCs but not the other. If more people confirm they can get it working I’ll update the wiki.


(Alan Hatley) #72

I’m new to this forum and what I’ve seen you did a lot of development on this flight controller. What I’m needing to know is there any way to get the motors to arm without the gps plugged in?


(rmackay9) #73

Alan,
Yes, the Alt_hold flight mode doesn’t require a GPS. There’s a button on the transmitter that allow selecting the flight mode.


(Alan Hatley) #74

I know I’ve done a lot with this thing. I meant the motors will not arm
without the satellite receiver physical plugged in. Doesn’t matter if its
in alt hold acro sport. Plug the receiver in and they’ll arm I was wanting
to transplant the flight controller into a smaller frame without using the
gps because of the weight.


( .) #75

Look at the code here, I think you’ll find your answer

I think you’ll need to disable some fail safes for the compass being missing as well?

Recommend looking at the logs for prearm checks. Something should be getting posted to let you know why it is failing pre-arm safety checks.


(Dude) #76

Alan,

Matt was trying to transplant without GPS and ran into the same issue. Read here:

https://www.rcgroups.com/forums/showthread.php?2947267-Sky-Viper-2450GPS-full-FPV-GPS-Arducopter-QUAD-for-about-150/page5

He has not updated since then.


(Harry Mulliken) #77

What version are you running? I just installed the latest version and it is giving me error messages when I go to change the rtsp string under the vlc button. The messages point to a problem with extlibs which have pointers to c:\users\michael …extlibs … (I don’t have any users named michael and extlibs doesn’t exist on my machine in the mission planner directory)
I tested VLC after I installed it and it works correctly showing what my v2450gps sees.