Skid steer help?

Back story I have a skid steer boat with a 3dr pixhawk running 4.0 ardurover. Everything was set up and working correctly. All movement was controlled by the right joystick.

I’m now setting up the pixhawk cube, with 4.0 ardurover firmware. I’m trying to set up skid steer and it’s not working. I have 2 thrusters with 2 escs plugged into 1 and 3. Set up servo output with throttle left and throttle right on 1 and 3 like the skid steer set up says. I also have skid steering parameter set as 1. Servo output 1 is the only receiving movement. Output 3 is full throttle and doesn’t move.

Is there a way to mix the channels to have skid steering off one joystick?

Hi,

is there a reason you do not update to ardurover 4.0?
There should not be a “skid steering parameter”. Skid steering is enabled by setting two servo outputs to throttle_left (73) and throttle_right (74).

Hi sebastian,
I changed it to throttle_left (73) and throttle_right (74) via MP. However, I can’t see any signal output in the servo output.

Ardurover needs to be armed to enable the servo outputs. Arming may be prevented, if certain prearm checks are not passed. You can disable arming and arming checks for bench testing, by setting ARMING_REQUIRE to 0 and ARMING_CHECK to 0. Please remember to enable them again after testing.
There might also be a safety switch enabled. You can disable it by changing BRD_SAFETYENABLE to 0.

I tried the parameters you mentioned. Nothing has changed. The parameter file I applied is attached.rover_param.param (15.6 KB)

I loaded your parameter file and run a simulated rover with it. The vehicle is still set to frame class “rover” instead of “boat”, but other than that the simulated rover was working. Did you try the motor test in Missionplanner? Or you can change the trim value in the servo output screen and see, if the thrusters start to turn.

Sebastian thanks for your interest.
Since I do not have a rover system, I cannot test it. I want to design a vehicle with SKID STEERING, two engines and two drivers.
If you have a vehicle that you can test this, can you send me the parameters of a working system?

You said, you had ESCs and thrusters connected to servo output 1 and 3. This should be enough to test the basic functionality of a boat.
You should just set the frame_class parameter to 2 for boat.

sorry still nothing has changed i command from the remote and the servo output is not responding


But you see movement on the radio calibration screen? Did you do the motor test? Or changing the trim value?

receiving data from the remote on the radio calibration screen. the value is coming but the servo output is still not working

What about motor test and changing servo trim?

I tried what you said but nothing changed

Did the motors run? (Just to get to 20 characters)

Unfortunately it didn’t work.

You got the ESCs/thrusters powered and connected to the Pixhawk and motor test and/or changing the trim does not result in the thrusters running?

Yes. Also, there is no change in the mission planner servo output menu. In the radio calibration menu, I can see the signal is gone from the remote

1 Like

Hello, I have the exact same problem as you. It only works if the servo function is set to RCIN_1 and RCIN_3 instead of throttle left and throttle right.
Did you ever figure out how to fix the problem?

Same problem need help

Hi,

Any resolution to this problem?

Cheers