Servers by jDrones

Skid steer help

(Brice) #1

Back story I have a skid steer boat with a 3dr pixhawk running 3.0.1 ardurover. Everything was set up and working correctly. All movement was controlled by the right joystick.

I’m now setting up the pixhawk cube, with 3.4.2 ardurover firmware. I’m trying to set up skid steer and it’s not working. I have 2 thrusters with 2 escs plugged into 1 and 3. Set up servo output with throttle left and throttle right on 1 and 3 like the skid steer set up says. I also have skid steering parameter set as 1. Servo output 1 is the only receiving movement. Output 3 is full throttle and doesn’t move.

Is there a way to mix the channels to have skid steering off one joystick?

Thanks in advance!

No RC answer for stering mode
(rmackay9) #2

Brice,

I suspect the confusion is coming from a mixup in understanding between inputs and outputs. Older version of the Rover firmware didn’t have the two concepts completely separated so it led to some confusion.

I’m sure you’ve already seen these wiki pages but just in case:

The two things are quite separate. So it is possible to control a skid-steering vehicle with a single stick (one axis controls steering, the other throttle) and conversely it’s possible to control a regular vehicle with a two-paddle input.

Probably the best thing to do is:

  • set PILOT_STEER_TYPE back to the default of 0 (meaning use a single stick to control steering and throttle) and I suspect it will start to work.
  • double check the SERVO1_FUNCTION and SERVO3_FUNCTION parameter values and ensure they match what’s on the wiki here.
  • use MP’s motor test page to test that the left and right wheels are moving forward when the “Test Motor C” and “Test Motor D” buttons are pushed respectively.

Hope that helps and thanks for upgrading. I suspect you’ll hit some other issues including tuning but hopefully the final performance will be better than the older firmware could do.

Steering calibration for six-wheeled skid steer rover (Ardurover 3.5)
(Brice) #3

That was it! I wasn’t seeing the green bar move which was confusing me. Thank you!

1 Like
(Jimmy Oliver) #4

Setting up skid steer on single stick leaves me with forward being diag upper left. Shooting for L1 steering control and fast tight pivot turns is proving difficult. (Like Aion sample on setup page) Is setting PILOT_STEER_TYPE to 1 essential for proper autonomous functions?

(Sebastian Schürmann) #5

This probably means, that there is a mixer enabled in your transmitter.

(Jimmy Oliver) #6

It’s a Taranis Plus.

(Sebastian Schürmann) #7

Did you do any special setup? To use/test the rover without the FC, for example?
Which motor controller do you use?

(Jimmy Oliver) #8

This is a Pixhawk 2 with a Roboclaw 12v motor controller. I am testing to make a larger rover that will go between crop rows. 4 motor skid steer setup. Using dual sonar for correction but am not there yet. I have the transmitter issue (Top left stick is forward) and just trying to tune for reliable pivot turns. Rovers are harder than I thought!

(Sebastian Schürmann) #9

@Jimmy_Oliver
You got a roboclaw, so I guess you activated its integrated skid/differential steering mixer. Ardurover is doing the mixing for skid steering when throttle left (73) and throttle right (74) is set for servo outputs, so the roboclaw must be configured as two independent controllers, no mixing.

(Jimmy Oliver) #10

Let me check that out. I thought I left mixing off.

(Jimmy Oliver) #11

I had the mixing off. Is there a way to blend the channels so that STICK UP is forward and turning is just a slight move left to right? Is that what Ardurover is trying to do? Again, FORWARD is STICK UP LEFT.

(Sebastian Schürmann) #12

Forward should of course be stick forward. If you got two servo outputs set to 73 and 74 and pilot steer option !not! set to 1, it should work, as long as there is no other mixer involved.

(Jimmy Oliver) #13

That worked. Will this affect Auto functions? (Thx, by the way!)

(Sebastian Schürmann) #14

What did you change? You said in your first post “setting up skid steer”, so I assumed you had set two servo outputs to 73 und 74.
Or was Pilot steer type set to two paddle input?

(Jimmy Oliver) #15

I set up skid steer. 73/74 I am running 4 motors. I had to reverse channels to get motors to run in the right direction. I am going to test and film later today with the Soloshot 3 camera (which is crap) but I can then show the execution of the waypoints.

(Jimmy Oliver) #16

Note: I changed it back to 0

(Jimmy Oliver) #17

Getting there. Thanks again!

YouTube Video of testing:
Rover Pivot Turns