Servers by jDrones

No RC answer for stering mode

Good evening,

I am fighting for a moment already with the manual mode of my rover.
I have a pixhawk working with a sabertooth 2x25 and a wild thumper. I use ardurover 3.5.

I have set everything as indicate in this discussion: Skid steer help. The motor tests C and D are working well but the tests A and B does not work. And the RC has no effect. The RCMAP seems good and the green bars are moving during the calibration but nothing happen when i go on the tab for the servo output.

I am have no idea which parameters change to solve the problem, or even what is the source of the problem.

I will appreciate any helps to make work this rover, its frustrating, leds are blinking but nothing move…
Thank you !

@Billy,

If you can provide a dataflash log that would be good… it’s very much guesswork without a log file I’m afraid

Hi,

there is no logfile to download, dixit Mission Planner. I have changed the SDcard but but same results.

I will post a full description of the parameters later this weekend of I do not succeed to get this log file.

Billy

The vehicle is armed of course? it really should produce logs if it’s armed… if that fails then it’s most likely the SD card needs formatting or replacing.

Good evening,

so, I solved my problem. Doing a review of all parameters and spending more time reading the forum helped me a lot.
The problem came from my misunderstanding of the input and output channels. A lot of documentation exist for ardurover before 3.5, apparently it is a little bit different now. Making a sort in all these information was a bit tricky but at the end it works and it is actually quite logical :slight_smile:

So my configuration:
Sabertooth in mixing mode and exponential response.
Then, in mission planner / mandatory hardaware / servo output, positions 1 and 2 are set to the functions RCIN 1 and 2 aka the right joystick of my RC transmitter (mode 2: roll & pitch).
The RCMAP is set as described in the transmitter.
I had troubles with SKID_STEER_IN and SKID_STEER_OUT which does not exist anymore in ardurover 3.5 (or I didn’t find them). Now it is PILOT_STEER_TYPE and when it is set to DEFAULT it works quite well. A part of my misunderstanding came from that I wanted a skid steering but with only one joystick. When the value is set to 1, the rover moves like a tank, with 2 joystick, and my RCMAP was messy for that…

So now, the manual mode is working well. The autonomous mode does not work so I guess something is still messing somewhere but there is some progress, so it is cool…

Cheers,
Billy
ROVER manual.param (13.5 KB)

PS: I have uploaded the parameters file. I am not sure it is the logfile that we were talking about in previous messages. If not, I will take a look at the SD card.

PS 2: I am still learning so probably the explanation and resolution of my problem are not clear. If necessary I will work on that too…

You should change the sabertooth config to independent mode and let ardurover do the mixing. Otherwise you will not be able to use the skid steering/pivot turn abilities of ardurover in flightmodes other than manual.
Just set two servo outputs to throttle_left (73) and throttle_right (74) in Missionplanner, instead of throttle and groundsteering.

1 Like

I am not in THROTTLE and GROUNDSTEERING for the the servo output, but RCIN. I just tried what you said, changing the sabertooth and use throttle left and right but it doesn’t work, the RC controller has no effect. I do not really understand why…

You have to arm the vehicle to get a signal to the motors. RcIn and passthrough work without arming, but those functions are just as if you do not use an autopilot at all. That is why nothing but manual mode works.

Hello,

YES! another misunderstanding : the safety button is not an arm button. I corrected that, and get great results in manual mode. Thank you !

Billy

Servers by jDrones