SJ6 Legend For PIxhawk Autopilot Camera Triggered

Hi, i would like to ask some help please on how to trigger my SJ6 Legend Camera on Autopilot Filght (Mission flight). And how to trigger the camera manually also, using Radio Transmitter.
I am using this cable for my camera:

I already tried setting the Camera gimbal setting on MP but the trigger wont work when i switch CH7: I connected the PWM on the AUX pin on pixhawk on AUX2 (SERVO10):

Already set CH7 to camera_trigger also:

What am i missing? The manual trigger wont work when i tested it, I cant go on to triggering on autopilot if i cant make it work on manual trigger using CH7:

Did you set your transmitter up with a switch for chan 7? Does it show it functioning on the Radio Calibration screen in Mission Planner?

Yes, ch 7 is functioning on the radio calibration screen. I double checked it when i done the troubleshooting to make sure that CH 7 is working.

My connection is:
From SJ6 using FPV cable connected to the Aux2(servo 10)

On mission planner:
Set shutter to servo 10 and CH7 to camera_trigger

But it doesnt seems to work, what am i missing? :pensive:

You have the trigger duration set to 100msec, perhaps its too short? I tested this setup in SITL and Ch10 output toggles from a DO_DIGICAM_CONTROL command so its working.

Do i need to set the do digital something? Sorry i had no idea. I tested this woth 10sec still the same. When toggle nothings happen.

What are the parameters needed to set?

No. That is a Auto Mission command to trigger the camera. I was just saying that with the settings you have it switches the output on Chan10. As a test set the duration to 5 seconds (50 for the parameter) and then look at the Ch10out on the Status Screen while flipping the assigned switch. Does it change from 1100 to 2000 for 5 seconds? It does on my bench test setup showing that functionally the Arducopter configuration and the Pixhawk is working. If you find the same then the problem is with your camera.

Okay sir, i will test this tomorrow and give an update. I will check on the status if the CH7 move from 1000 to 2000. Once i tested the camera trigger manually, i will move forward to Auto Mission using the QGroundControl app.

Also, what are the necessary parameters that needs to be set for camera trigger on manual? And on auto with QGround? Aside from the camera gimbal page? Thank you.

These parameters:
Cam_trigg_type 0 for servo (Pwm)
Chax_opt to 9
Servox_function to 10

Also make sure the Brd_pwm_count is set so the Aux channel you want to use is available for PWM. Default on Pixhawk is 4 which means Aux 1-4 will be.

I can’t help you with Mission planning and execution with QGC, I use Mission Planner.

Hi sir, morning! I will be connecting the FPV cable from my camera to this pin:

So this is, AUX 2(Servo 10) right? So the brd_pwm_count is okay to be set in 4?

Hi Sir, I tested today. The CH7 respond.

But the camera wont trigger. They said, SJ6 Legend will trigger :frowning:

Does ch10out switch to 2000 for 5 sec when chan 7 does? It will only toggle for the duration set that’s why I suggested setting it to 50 (5 sec) to test it so you have time to watch the change.

I set also the parameter to 50 or 5 sec, what am i still missing?

This is the Camera with FPV cable cnnected:

This is the FPV cable connected to pixhawk on AUX 2:

Just answer the question about ch10out. is it working or not?

I dion’t know anything about that camera I’m simply trying to help you determine if the configuration is working. If it is then you figure out why the camera doesn’t trigger.

Yes, CH10out is working sir.

Then it’s configured correctly. I don’t know what you are showing with the photo of the FC and the connection to Aux 10. Connect the gnd lead to the top pin and the white PWM lead to the bottom pin of Aux 10.

Yes, thats the connection. Black as Ground to Top, Brown as Voltage to Middle and White as PWM to Bottom pin.

Disconnect the center pin. You only need gnd and signal.

I disconnected the Voltage charge in the middle, still the same camera wont react but CH10 output hold to 2000 for 5 seconds.

That’s about all I can help you with. Settings in the camera maybe.