SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

we are facing issue with the Siyi A8 mini camera gimbal systems. We have been trying to click pictures with A8 mini during a mission planning through mission planner. The camera and Pixhawk are connected via telemetry and the camera is giving live video feed to MK15 air unit. Also, this problem stays only during the mission, otherwise, the camera can capture images while triggered via remote through telemetry. Please help. It is also through an error sometimes saying Siyi failed to take pictures

1 Like

Hi @Bhaskar_Bhardwaj,

So I think you’re saying that the Siyi A8 camera is, in general, taking pictures during missions but sometimes (1 in 10 times?) it fails. If this is the case then it is probabably not AP related. I suspect the camera just isn’t able to take pictures very rapidly.

If you can provide an onboard log I can look into this further.

Not like that, See I am planning a survey mission and want camera to take picture over the mission and save it, but my camera siyi a8 mini is not able to take images. I have enabled all the parameters and also set the cam_trigg_dist to 0.1m. But it is not happening. I have connected the Siyi A8 mini with telemetry with Pixhawk.

Attaching log file pls check 00000266.BIN

@SIYI Please look into the issue

I setup Mission Planner Simulator with this configuration:
Serial2 Protocol 8 (Gimbal)
Serial2 Speed 115
MNT1_TYPE 8 Siyi Gimbal
CAM1_TYPE 4 Siyi Camera

I can control Gimbal with Payload Control and during Mission by pointing to ROI
and while Manual Trigger it records picture OK

But how to get the Time and Location from Mission Planner ?

Reading the Manual:
2. 3 Interesting Functions and Cautions
SIYI opti cal pod and gimbal camera can save time and location information into
captured pictures in EXIF format. The preconditions that the function will work are:

Time Information: The ground station must connect to internet and run the latest
Location Information: Gimbal must communicate to flight controller through

Location information can only be acquired
from Mavlink protocol at this moment.
The above functions are only available in SIYI optical pods and gimbal cameras which
support capturing pictures and TF card recording.

Getting time and location from ArduPilot is scheduled for updates. Welcome to follow this post for some pre-information

1 Like


Thanks for the information, I will certainly test Beta Release when available

Other question:
What is the recommended minimum time between taking pictures ?
I see some pictures missing during my simulated missions at slow speed (2 m/s)

–update= it works ok if I set speed at 0.5 m/s and capture every 2 M so technically it is 1 Frame every 4 seconds ?
Can we make it faster by lowering picture resolution and how ?

Other question: Can we FTP pictures through Ethernet port ?


1 Like

Im having some trouble getting this A8 to work with my 3dr solo. I followed all the steps and changed all the parameters updated the firmware. I was able to get it to tilt with the controller but it wouldn’t tilt at all until I got the 47% then it at 46 would go all the way down there was no in between. I’m getting no video I have it set to HDMI and they have a good HDMI ribbon cable. I just can’t figure out what I’m doing wrong now for some reason the Gimbal isnt working at all with my controller. It’s stabilizes when I move the Drone around but that is all. Last time the gamble worked at all it made a bunch of ticking noises and hasn’t worked since. I’m stuck and not sure what to do any help is greatly appreciated.

@JonBrotherton Jon is very familiar with using A8 mini on 3DR solo. We will appreciate it very much if he can offer a little help.

1 Like

I tried the steps you suggested and the drone is now capturing the data during mission planning. The image has some GPS data but I am unable to decode it whether it is correct or not. Pls check the attached image.
Link: siyi_pic_1970-01-01_00.10.48.jpg - Google Drive

That’s the guy that helped me get it all set up. I got the install kit from him to. He said he’s never seen one act like this before

They said it can take pictures at 5hz but I doubt it, what have you found on your tests?

It is missing captures if you trig faster than 1 frame per 2 seconds = 0.5hz


Would you mind attach a video of the issue and send to, please?

I have already packaged it up and I’m getting ready to send it to John Brotherton so he can fix it for me and send it back. There’s no use in taking a video of it it does absolutely nothing at all. Just a solid green light on the gimbal and that’s it no video it don’t move when I use the controls on the controller but when I pick up the Drone and move it around it stays stabilized that’s all. The firmware is correct and everything. It did make a whole bunch of ticking noises before it stopped working


@SIYI - i just got new a8 mini and configired with AC 4.4.3 using MavLink mode (proto=2, mnt type = 4, BRD_SER1_RTSCTS = 0) with attitude data 50 hz on serial 1 / sr1

i get the double green blinks, yet the gimbal does not react to control inputs (i tried yaw/pitch/record/zoom)

When i switched the protocol back to gimbal (proto=8, mnt type = 8), yaw and pitch work but record and zoom are still ignored.
Independedntly, the range of motion is incorrect in the gimbal mode, its a separate issue and i will start another thread .


You need ArduCopter 4.5.0 dev for the gimbal to work properly. Try that.

1 Like


thanks, i updated to 4.5-dev - still gettgin the same behviour with mavlink2 proto

(matek f765-se)

Are you using the latest gimbal beta firmware version?


No, i wasnt able to locate it.
Whete can i find it?