SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

Hello Everyone.
I’m facing a strange issue with my SIYI A8 mini as it’s getting very hot during operation, what will be issue in it!?
I’m powering it with 4s battery.


Hi! I acquired a SIYI A8 mini gimbal and connected through Ethernet to Herelink and used QGC modified by SIYI app to control the gimbal with the screen gestures and everything worked fine. However, I then connected Uart also (so that the drone can control the gimbal during missions) and configured the correct ardupilot parameters and then the movement through the screen gestures on the QGC app start to become jerky and don´t work properly.

Does this mean I cannot use both control protocols at the same time?

How does this look like? Interested in seeing a video, thanks

I don´t have a video to send you right now but basically the gimbal should keep moving if you slide the finger to one side of the screen and keep holding.

Instead what happens is that when I slide the finger to one side of the screen and keep holding the gimbal only moves a bit (about 10 or 20 degrees) and stops.

Hello, Did your problem is solved? If yes are you able to geotag the images using mission planner geo tagging feature? Because I am not able to geo tag the images taken from A8 mini and log file of the flight controller using the mission planner.

Hello @rmackay9,
We are able to capture images via flight controller auto mission waypoints, I am trying to geotag it using mission planner, But I have no success in geotagging it, I am attaching the screenshot of the error for your reference. Please check.


Which version of MP are you using? If possible could you re-test with the latest Beta MP? It can be updated from the Help screen’s “Check for BETA Updates” button. The reason I recommend this is that I hit a similar problem with geotagging a few months ago and updating resolved my issue.

If this doesn’t fix it then I think raising an issue in the MP issues list is probably best and if possible include both an image and a dataflash log file.

BTW, I’m not an MP expert but it looks like it is unable to find any CAM messages in the log. You could check yourself using MP’s Data screen’s DataFlash Logs’s tab’s “Review a Log” feature to be sure that CAM messages are in the logs (you can filter by message type by clicking on the column headers).

Hello @joshanne ,

Which arducopter firmware version are you using? Is it AP4.4? During the survey auto mission, the images via A8 mini camera are captured after setting the parameters CAM1_TYPE=4 but I am not able to geotag the images using the .bin file of the flight controller log using geo-reference option on mission planner.

Hi @Keshavkant ,
I’m using a Copter 4-point-something… not sure if it’s 4.4.

I have not used that function of Mission Planner extensively, as such, I cannot say for certain why the geo-tagging is not working.

Are you triggering the capture through the SIYI App or the SIYI Modified QGroundControl? If so, I think your air vehicle log is missing the required entries to be able to geotag an image properly.

If your CAM1_TYPE is configured properly, and you have a serial port configured and connected to the gimbal, then the gimbal itself should be geotagging the images - assuming my tests were accurate, of course.

Hi all!

Is anyone still facing the issue with gimbal where is rolls mid flight and loses orientation? We are using this for a multi-copter and this happens frequently. It stays there till we land.


Yes, we are still having this issue.

It’s unusable right now and I’m about to pull the plug and move to something else.

If anybody could fix it, please let us know.

@ulfbogdawa @thiagolages @samucs

1 Like

We have bought multiple units and there’s no solution to it. Planning the same!

I am surprised that other people are not facing this issue. We are unable to do long distance flights.

For roll angle tilt issue during flight, welcome to follow this post for updates


Any update on the new firmware for A8? @SIYI

1 Like

Yes… Same here. Enough is enough.

A8 mini still going all over the places. There’s always a miraculous FW around the corner but I have no time anymore.


Actually geotagging was not the issue for me, I wanted to record the video and simultaneously capture images at a regular interval of time automatically. I achieved this with the help of lua scripting.
I set a RC button for camera trigger and toggled it at a fixed interval using a lua script.

We just tried the A8 mini FW released yesterday.

We are using IP transmission and SDK commands to the gimbal. There’s no feedback link with the Autopilot - we tried with the feedback, but same behavior. We also tried with an external power source - same. The gimbal is all over the places, unusable. We tried everything, really, every single message on discuss, emails, etc etc etc.

Even with the drone just standing on the ground, the gimbal is losing reference and sometimes it’s shaking weirdly.

I’m not expecting for a perfect follow movement (because we are not using the autopilot feedback anymore), but it should be at least stable with its own IMU.

1 Like

Please tell everyoen if you are trying ArduPilot control and integrating ArduPilot attitude data. If you are not using ArduPilot, we are not discussing the same thing and you need to write to for directly up other than posting here

Ok Frank. We’ll follow by email because indeed we are not using it connected to Ardupilot anymore. Thanks.

hi i have not receiving video in the MK 15 TRANSMITTER (SIYI FPV app) what is the solution