SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

Hi @nacy,

Re the gimbal switching between Lock and Follow during point-to-here and the 200ms timeout, I guess you’re referring to this line in AP’s Siyi driver?

If this is triggering then it means that ArduPilot is not getting regular updates from the camera gimbal. We’ve actually just discovered a bug in AP’s Siyi driver that could lead to a loss of packets so could you try again with 4.4.3-beta1 or latest from within the past few days?

Hi @rmackay9,
Yes, that line is a trick.

I also updated to the latest patch and tested it, but the results did not change much.
The graph below is the result of Loiter test and point-to-here. Since Ardupilot does not log camera readings, we have modified the code to do.

The green line is the camera’s operating mode. 1 means Lock, 2 means Follow. You can see that the gimbal still regularly switches between Lock and Follow modes (sometimes the mode may not be read correctly, because the SIYI library only reads mode at 1Hz)

I also noticed that if I remove the mode switching code at the 200ms timeout, and when the timeout occurs the gimbal will not receive Yaw control commands at all until it is manually switched to Follow mode. So there are definitely some problems in the gimbal’s Firmware. @SIYI

The next picture is the Yaw value read back from the gimbal, you can see some ‘flat-line’, that is when the gimbal is not responding to the read command.

Sorry for some private reasons, I can’t upload the full log here.

1 Like


OK, please make sure that your AP software includes this Siyi driver fix though.

1 Like

I had problems with the A8 mini a few weeks ago, and when I saw the latest update, I tried it immediately but the problem did not go away.
Actually, I tried to control the A8 with a self-made image processing device (AI object tracking). However, A8 often loses Yaw control after about 8-10 seconds. I was surprised because the functionality I wanted to try was almost the same as point-to-here, and point-to-here worked quite well.
After carefully reading the source code, I noticed the 200ms timeout code. I tested more thoroughly and found that the gimbal firmware actually had some problems.

1 Like

My Siyi A8 Mini is getting very hot during operation, what will be issue in it!?
I’m powering it with 4s battery.

The camera trigger option (i.e. RCx_OPTION = 9) is not working for me. I can control the gimbal, start recording, control zoom, etc. from setting the RCx_OPTIONS to different values, But the camera does not takes images when the parameter is set to 9

What about SD cards? Tried to format or compare with another one? Does the SIYI FPV app read your SD card?

Hi @Suyash_Mali,

Maybe CAM1_TYPE hasn’t been set to 4 (Mount)? … this seems unlikely to be the issue though if you can successfully record video. I’m not sure, maybe upload on onboard log?

1 Like

The CAM1_TYPE is set to 4.

Here is a sample log:
(The Autopilot shows the messages ‘CAMERA TRIGGER HIGH/LOW’ but the camera does not captures the images)

The trigger is set on RC9, Zoom on RC13, and MNT_PITCH on RC15

Also I tried updating to the ArduCopter v4.4.3-beta1. Still the same issue.

Hi @Suyash_Mali,

Thanks for the log. The setup on the AP side seems OK. AP thinks it is taking pictures.

I guess you know that you’re not taking pictures because there are no images on the SD card? I think if you connect with MP and trigger the camera little camera icons will appear on the map.

1 Like

Yes, I can see the cam icons on mission planner. Also, yes, there are no images on SD card that were supposed to be there when the trigger was pressed.


OK, I don’t think it is an AP issue then. I’d try replacing the SD card, make sure the gimbal is powered correctly (e.g. using a high enough voltage battery), maybe check that the camera and gimbal firmware (there are two separate firmwares) are up-to-date. … beyond that I don’t have any ideas I’m afraid.


Hi Frank, can you provide an up to date user manual on these new SDK feature. I am interested in configuring bit rate and codec with UDP interface.

Thanks for your attention. I’ll hurry up

But how to find out which model I have?


maybe get the serial number and ask Frank @SIYI,it works o/k on 14.8 volts

In two ways,

  1. Let us know when and where did you get the gimbal?
  2. Show us the PMC number coming with the product QC card

Number on the ticket is PMC-1950.

PMC-1950 is 6S safe.

1 Like

Thanks Frank. Really appreciate your effort on getting this feature through and documented. We really need to be able to adjust the bitrate on the fly and to a more granular level rather than just depending on the resolution setting in the assistant app.

1 Like