SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

Hello @joshanne ,

Which arducopter firmware version are you using? Is it AP4.4? During the survey auto mission, the images via A8 mini camera are captured after setting the parameters CAM1_TYPE=4 but I am not able to geotag the images using the .bin file of the flight controller log using geo-reference option on mission planner.

Hi @Keshavkant ,
I’m using a Copter 4-point-something… not sure if it’s 4.4.

I have not used that function of Mission Planner extensively, as such, I cannot say for certain why the geo-tagging is not working.

Are you triggering the capture through the SIYI App or the SIYI Modified QGroundControl? If so, I think your air vehicle log is missing the required entries to be able to geotag an image properly.

If your CAM1_TYPE is configured properly, and you have a serial port configured and connected to the gimbal, then the gimbal itself should be geotagging the images - assuming my tests were accurate, of course.

Hi all!

Is anyone still facing the issue with gimbal where is rolls mid flight and loses orientation? We are using this for a multi-copter and this happens frequently. It stays there till we land.


Yes, we are still having this issue.

It’s unusable right now and I’m about to pull the plug and move to something else.

If anybody could fix it, please let us know.

@ulfbogdawa @thiagolages @samucs

1 Like

We have bought multiple units and there’s no solution to it. Planning the same!

I am surprised that other people are not facing this issue. We are unable to do long distance flights.

For roll angle tilt issue during flight, welcome to follow this post for updates


Any update on the new firmware for A8? @SIYI

1 Like

Yes… Same here. Enough is enough.

A8 mini still going all over the places. There’s always a miraculous FW around the corner but I have no time anymore.


Actually geotagging was not the issue for me, I wanted to record the video and simultaneously capture images at a regular interval of time automatically. I achieved this with the help of lua scripting.
I set a RC button for camera trigger and toggled it at a fixed interval using a lua script.

We just tried the A8 mini FW released yesterday.

We are using IP transmission and SDK commands to the gimbal. There’s no feedback link with the Autopilot - we tried with the feedback, but same behavior. We also tried with an external power source - same. The gimbal is all over the places, unusable. We tried everything, really, every single message on discuss, emails, etc etc etc.

Even with the drone just standing on the ground, the gimbal is losing reference and sometimes it’s shaking weirdly.

I’m not expecting for a perfect follow movement (because we are not using the autopilot feedback anymore), but it should be at least stable with its own IMU.

1 Like

Please tell everyoen if you are trying ArduPilot control and integrating ArduPilot attitude data. If you are not using ArduPilot, we are not discussing the same thing and you need to write to for directly up other than posting here

Ok Frank. We’ll follow by email because indeed we are not using it connected to Ardupilot anymore. Thanks.

hi i have not receiving video in the MK 15 TRANSMITTER (SIYI FPV app) what is the solution

HOW TO turn on ethernet in mk15 its not receiving the video but the auto pilot data is downloaded succesfully.

  1. What camera is it?
  2. Is IP addresses configured corrected?
1 Like

Im using a8 mini ,with mk15 And the A 8 is working separately USING RTSP SERVER without the MK15.
Here I’m using ethernet port from A8 INTO MK15 AIR MOUDLE. I entered RTSP link in the SIYI FPV .But there is no symptoms for RC is connected but the RC is paired and working good GCS data is also downloaded in SIYI QGCS .

Im using default ip from camera rtps://

Camera ip is and gatway is also (Im not using any HDMI Converter)

All firmware is matcher green led is glowing.(100%data tranfering) but no video in siyi fpv and q gcsa

No data is reciving in the SIYI FPV .I got all data in machine planner but no video feed and SIYI FPV APP shows disconnected .Kindly solve me this issue im trying 1 week to solve it.

Can I make a summary as…

Devices & Software

  • MK15
  • A8 mini
  • SIYI FPV App

MK15 system communication is good.
No video display from A8 mini camera.

If my summary is correct, please show me two screenshots to check:

  1. SIYI FPV IP Addresses Input
  2. SIYI FPV App version
1 Like


After various testing I found that the issue is 2 optional :

1.The communication signal of video between Transmitter and mk15 air unit is the issue.
2. Or the Camera video input to the Air module is having some issue.

camera ip and device rtsp ip