Single Copter 4.0.7-Missing Flight Mode,Range,Description in MP

Single Copter 4.0.7-Missing Flight Mode,Range,Description in MP
Omnibus f4 V2,
Tried Both MP 1.3.75 and Beta with same result
Tried Ctrl F “regen params” in both, no luck.
I can see all paramereters in CONFIG- Full Parameter Tree and List and adjust and save same, but no data (words) in the “Units;Options:Desc” fields for many items. In some fields:“Desc, Option” wording is there for some Prms such as Batt;Compass;GPS;Logs;NTF, but nothing for Flight Mode.
“Current Mode” in SETUP-Flight Modes- shows “Unknown”
Flight mode on HUD screen shows “Unkown”
Have another Omni F4 V2 Board with Quad Copter 4.0.3 and all Parmas display Ok
Upgraded that 2nd board to Quad Copter 4.0.7 and all Params fill and display OK
Guessing not many Single copter uses out there and this is just some missing porting of Units, Range and Desc fields fro Singel Copter?
FC beeps on changing flight Mode in Single Copter, but worried about it showing as “Unkown”. Is that something to worry about?

Thanks, Joe

Sounds like the same issue I’m having using coaxial.

Delete the directory “Mission Planner” in “c:\Program Data” (it is a hidden directory). Then restart Mission Planner with a working internet connection online.

@Eosbandi Thanks for that suggestion. But for my Single Copter it did not work. Same missing data. Was worth a try though. I am only concerened about the Flight modes really, not sure what to expect with this version. I have installed a compass and GPS and hoped that other flight modes work in Single Copter.

Indeed, SINGLECOPTER and COAXCOPTER are not handled correctly in Mission Planner.
I’ll send in a PR to fix it.


Thanks for the assist

hope, Michael will merge it soon.

1 Like

@Eosbandi WOW that was fast- thank you very much. Question if you know, and I am guessing you do, what flight modes are supported in single copter? Same as regular copter?
Thanks Joe

Since singlecopter is just a frame type in AP::Copter, it supports all the modes.

1 Like

@Eosbandi You guys are great. Thanks for the confirmation on the flight mode usability, I thought so, but never used this Frame type before.

I just checked for latest “Beta” MP Updates (updated to build 1.3.7905.18872) and it looks like your work was merged there! Looks good so far, all data fields in CONFIG and the HUD are now populated.
Noticed 2 things:

  1. In the header, next to STATS it shows “COM4-1 COAXIAL”, in that drop box and I have FRAME CLASS set to 8 “Single Copter”.
    Parameter List and Tree show correct “8” in the VALUE fields for Single Copter.

  2. In the CONFIG-FLIGHT MODES screen, it is populated, but if I choose “Circle” for any flight mode the wording next to that field is Grayed out. There are other flight modes that also Gray out the field that I ecpect are due to this frame type, or lack of installed hardware. I do not have telemetry on this beast - yet, but guessed Circle should work as I have Compass and GPS.

Thank you again for all your and others work on this.