Flight modes disappear when I select Coaxial Frame Class


First post here, although I’ve been reading for some time now.

I have built a coaxial copter with 4 servos and 2 motors. Set up following the instructions on the coax copter info page. I’m using a Kakute F7 mini V2 flight controller loaded with the Arducopter firmware.

I got everything loaded and setup. The servos and motors function as intended. AHRS orientation set, Compass with Mag calibrated and working correctly.

However, I’m having an issue where all my flight modes disappear when I select frame class 9, Coaxial. The drop downs just show blank, and “Current Mode” shows “Unknown”. If I switch it back to a traditional frame class, the flight modes reappear and work as intended. Any idea what’s happening? Is this due to the firmware limitations of the Kakute F7 mini? Any suggestions would be greatly appreciated. I have not attempted to fly the copter yet.


Tried a MissionPlanner beta update? Unless you are using commercial/expensive fairly static systems, it’s OK to do the beta updates quite regularly.

I have. I’m on I think that’s the most current beta? I’ve even tried uninstalling MP and reinstalling, then reupdating to latest beta. I’ve also been able to replicate this issue after fulling wiping the flight controller and reloading the firmware.

Might be a bug, since potentially not all flight modes are available with a single/coax - just guessing though. I’ll see if I can try it here.
Everything will still be available in the Full Parameter Tree

Thanks for the help!

Interestingly, I’ve been able to replicate this with heli mode as well.

Back in frame class 9, while I can see the flight modes in the Full Parameter Tree, information is missing in the ‘Range’ column.

I think most concerning is the fact that I cannot select or change a flight mode. It simply says ‘Unknown’ on the Data page


The tuning settings disappear from the Config menu as well…


Hi, did you find a solution to this matter? I have the same issue.

I downloaded the Beta MP from the help screen and it solved miy issue.

It was fixed in 23rd Aug and the fix is in the beta version :slight_smile: