SiK radio problem after upgrading to firmware 2.0

AFAIK 1.9 is the last version for those Sik radios. Maybe the firmware you flashed is not correct for those radios.

They all need to have the same version of firmware to communicate, upgrade them all to 2.0.

@dkemxr: if you try Mission Planner (or QGroundControl for that matter) right now, you will see they fetch version 2.0.

@martyp: Hmm, no. Three points:

1 - all my other radios are currently on 1.9 and working fine with each other. I am not going to risk flashing another radio with a potentially bad version, especially since I cannot figure out how to downgrade (if there is a repository of older firmware versions, I cannot find it).

2 - The MRO Air radio does not have a USB port. I might be able to muck around with FTDI cables, pinout diagrams and breadboards but I am really not going to risk this, especially given point 1.

3 - I am fairly confident I have had radios talk among themselves with different fw versions in the past (though cannot be certain). If indeed, a fw upgrade breaks compatibility with previous versions, this is a gigantic design flaw. I very seriously doubt this is the case.

Maybe 2.0 is only for the RFD radios?

You are right about operating with different versions of firmware. I still have one radio with V1.7 and it works fine with other radios with V1.9.

If 2.0 is for the RFD radios then there is something seriously wrong with both Mission Planner and QGroundControl. I tried both and they both flash 2.0 for the SiK. Feel free to try it if you have some lying around.

Yea so I have a couple of old radios with USB ports both have V1.9 and of course work with a test vehicle. I updated one of them from MP which flashed the same version you have (RFD SiK 2.0) and no matter what I did I could not get this to work with the radio on the vehicle. So I flashed it back to V1.9 and back to working. But because the firmware versions were different between radios this was not definitive. So I then flashed both radios to V2.0 and that did the trick.

So martyp was right. In this case V1.9 does not work with V2.0 even if V1.7&V1.9 were compatible in the past. I would assume if you flash your air radio via FTDI to V2.0 it will work. Or flash your ground radio back to V1.9.

@dkemxr, thanks for confirming my suspicion. Can you tell me where I can get the 1.9 firmware?

I started to hunt around for it and realized I had a copy of the hex file. Attached. (64.9 KB)

1 Like

Thank you very much, I couldn’t find it anywhere :slight_smile:

firmware is here:
Unless the number scheme has changed, v2 is a multipoint firmware. I’m surprised that it’s being sourced by gcs’s by default, as it is definitely incompatible with v1.x

I can now confirm that, after flashing the malfunctioning radio from 2.0 to 1.9 firmware, it can again connect to my other radios running 1.9. I would further suggest not to use MP or QGC to flash SiK radios until this is resolved.

Thanks!!! this solved my problem, you are the best!!! thanks

Martyp and all, I’ve got four SIK radios of unknown origin- they came with my various orders of the pixhawk 1. I upgraded one, and the problem started just the way it’s been described here. So I flashed all four to software Ver. 2.0 using mission planner.I cleared several com ports for them, and am confident that they all have their various ports and are talking on them- just not to each other.
Verified that they all have the same settings as well, by making the changes in the local side, saving them, then loading them again to make sure they were still right.
Yup. No one works now.
Not blaming you, just need some help to get this resolved. Scraping bottom in the idea bag.

Hi James,
I feel like I’ve opened up a can of worms here by offering my advice.
I have a mix of radios too, all 433mhz that I have aquired over the years but recently have been using the more powerful version2 from Hobbyking and Unmannedtech, but I still have some original V1 from 3DR and Rctimer.
The only one that I have had a problem is a V2 radio which appears to communicate, IE the appropriate lights flash and it connects and receives updated fimware using mission planner, but then won’t connect to any other radio.
I have since updated my entire collection of radios to Ver.2.0 firware with no problems
The offending V2 radio has been consigned to the spare parts bin.
It seems very unlikely that you have four radios that all have a similar fault to my faulty one.
Maybe there is something funky in your settings which is causing this to happen.
I’m have great faith in mission planner, maybe try reaching out to Michael Obourne for some help, otherwise maybe try rolling back to V1.9 firmware.
Not much help for you, and it’s a PITA trying to troubleshoot these problems when we should be out flying!

Update, further investigation shows that my failed radio works when in the plane at the remote end, it just doesnt like being at the home end.
Not sure I trust it though.

Not sure if I have the same problem or not, but after updating my ground radio to 2.0 I had comms until I changed some settings. After that I lost link. By setting Serial_Pass2 on FC to 1 I was able to get settings from air radio (1.9). For some reason frequency range there was changed (!). I changed it back to match ground radio and it all started working again.

I experienced the issue of being able to download settings of base and remote radios but not being able to connect. My configuration is Windows 10, MP 1.3.70, Pixhawk 4 and Holybro Telemetry Radios (which MP had upgraded the firmware of to 2.0). I was unsure about how to install the older 1.9 firmware but I came across a reference to how QGroundControl supports upgrading firmware of SIK, PX4, cameras etc via its “Vehicle Setup–>Firmware” menu. I ran this upgrade on both base and plane radios - it installed ‘RFD SK 2.0 on HM-TRIP’ on both radios. When I went back to MP the two devices connected. Not sure why connection now works but thought I’d share.

Off the subject,
Has anyone experienced shorter range when switching to V2.0 from V1.9?

Last days I fly a lot and I had a lot of issue with 2.0 frimware, range was only 5-7m…

Hi everyone, newbie here. I made the mistake of letting QGroundControl update my ground radio (ostensibly to 2.0), and now I can’t figure out how to downgrade it again.

I’ve found what I think is the right firmware image, and I’ve got the updated radio connected in a console interface in linux, but I can’t figure out how I go about flashing the radio’s firmware.

Any help would be greatly appreciated, as I’ll otherwise just have to buy new radios…