Should We Update the Sky Viper Firmware?

Hi Greg-Yes the video works pretty well in the MP HUD. I use my DJI goggles with an HDMI input from a laptop running MP. It’s serviceable. I tried the VLC app also but the lag is terrible.

1 Like

There seems to be another step missing. I thought that all I needed to do was install gstreamer but Mission Planner comes up with a warning and question when booting.

"A video stream has been detected, but gstreamer has not been configured/installed. Do you want to install/config now?

What setup is required to make the SkyViper video stream to the MP HUD?

Ok, I got it. It does work great once you know how to set it up!

  1. Install the 1.0-x86_64-1.9.2.msi package.
  2. In Mission Planner, right mouse click on the HUD and select “Video” then “Set GStreamer Source”.
  3. Change the IP setting and port for the SkyViper video in Sonix board.

Default Setting in MP:
rtspsrc location=rtsp:// ! application/x-rtp ! rtpjpegdepay ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

Setting for SkyViper Video MP
rtspsrc location=rtsp:// ! application/x-rtp ! rtpjpegdepay ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

I was just about to reply to say I used VLC but great you got it going.

I wrote a GitHub issue to update the WiKi. Everything else on the SkyViper v2450 GPS was easy except for the cryptic info to display on the HUD. I have to admit that I am very happy with my $80 SkyViper v2450 GPS. Apparently, my version was originally sold at Toys-R-Us and I picked it up on eBay.

I saw one guy was using a Li-Ion cell that was 3500mAh. I might need to try that next for increased flight time.

Edit: Created a pull request for the Wiki changes. - Update skyrocket-gcs.rst #1628

It looks like this LiPo cell provides a 15 minute flight with good current delivery. You buy a 2-cell pack and split it up.

Venom Fly 30C 2S 2000mAh 7.4V LiPo Battery

Venom Fly 2s 30C Pack at Horizon Hobby

Randy updated the WiKi from my pull request so that is all set. I ordered one of the Venom Fly packs above direct from Horizon Hobby so I can get longer flight times.

Greg , I have an issue with firmware upgrade on a Skyviper Journey, it cannot bind after upgrade. I have opened an issue here ArduPilot/ardupilot#10418, does not affect the v2450 gps as @Satoru_Sasaki has already confirmed , but I want to mention as it is ‘‘in the family’’, I’ll update when resolved.

Thanks, Patrick!

I’m still using the stock firmware and transmitter on my v2450 GPS. It’s working very well and Mission Planner interfaces perfectly with both the telemetry and video.

It seems that Android apps are a bit lacking in general for the SV. You can either connect via MavLink or video but not both. Anyway, the SV is my first APM with a companion computer and I think I’m hooked! :slight_smile:

1 Like

I only had problems with MP when the Windows firewall was enabled. Disabling had everything working perfectly.

I just tested the Venom Fly 30C 2AH cell and I’m very happy with it. The 2s pack from Horizon Hobby makes for two 14 minute flights and it fits right in the battery bay without modification to the SV. No issues with balance or flying.

Note that the assumption here is that you need to disassemble the Venom 2-cell pack and solder JST connectors onto each cell. This requires soldering skills, a voltmeter, and caution.

  • 850mAh cell = 0.75oz
  • 1200mAh cell = 0.95oz
  • 2000mAh cell = 1.50oz

I’m using the latest firmware from SkyViper now.

  • arducopter-2017-11-24.abin
  • sonix-2017-12-20.bin
  • transmitter-2018-01-30.img


Android and Ubuntu QGC work fine for simultaneous video and data at least for my SV Journey.


I am currently trying to find the correct version of gstreamer on the website to display video in the HUD with my SV, the link from the updated wiki is broke and the versions I’ve tried have not worked for me. Am I overlooking it on the website? Anyone have a copy they are willing to share?


Hi Jason,

It appears that version of gtreamer was inadvertently deleted from the host site, hence the broken link in the WiKi. In fact, all the 1.9.x versions may have been deleted around 12/07/2020. Fortunately, you no longer need to download this package manually. According to the Mission Planner developer, @Michael_Oborne, it now gets installed when you install Mission Planner.


Is there any known issue using MP 1.3.74 with the sky viper Journey? I am setting one up for the first time and the params don’t load and telemetry sits at about 40% with about 20 seconds of HUD AHRS latency.
Also cannot get the video working but that isn’t an immediate priority.

I don’t know since I haven’t used it in a year or so. Try posting your question in the Mission Planner forum or in the thread linked to the quote above.

Good luck!

Thank you for the reply, I know this was some a long time ago.

I will make sure I’m on the the most recent version of mission planner and try again.

Has anyone tried ArduCopter stable on a Journey? Every version I’ve tried has GPS issues (Fixtype 0).

Update: versions up to 4.0.3 do have GPS working, I might have messed up something on prior tests.
But I can confirm that 4.1.0 can’t access GPS (there are no 4.0.4 - 4.0.8 builds for Journey).
I believe the culprit might have something to do with this commit from @tridge which changes the order of serial ports from:

I tried changing that line to
but the board becomes unresponsive.

Any clues about how can this be further debugged?
Why did the order change when going from UART_ORDER to SERIAL_ORDER ?

I just built latest Copter-4.0 (4.0.8, fixing some compilation errors with toy_mode) that has the commit above and GPS is working with it. So the problem is not with SERIAL_ORDER but something else added on 4.1.