Should We Update the Sky Viper Firmware?

I am currently trying to find the correct version of gstreamer on the website to display video in the HUD with my SV, the link from the updated wiki is broke and the versions I’ve tried have not worked for me. Am I overlooking it on the website? Anyone have a copy they are willing to share?


Hi Jason,

It appears that version of gtreamer was inadvertently deleted from the host site, hence the broken link in the WiKi. In fact, all the 1.9.x versions may have been deleted around 12/07/2020. Fortunately, you no longer need to download this package manually. According to the Mission Planner developer, @Michael_Oborne, it now gets installed when you install Mission Planner.


Is there any known issue using MP 1.3.74 with the sky viper Journey? I am setting one up for the first time and the params don’t load and telemetry sits at about 40% with about 20 seconds of HUD AHRS latency.
Also cannot get the video working but that isn’t an immediate priority.

I don’t know since I haven’t used it in a year or so. Try posting your question in the Mission Planner forum or in the thread linked to the quote above.

Good luck!

Thank you for the reply, I know this was some a long time ago.

I will make sure I’m on the the most recent version of mission planner and try again.

Has anyone tried ArduCopter stable on a Journey? Every version I’ve tried has GPS issues (Fixtype 0).

Update: versions up to 4.0.3 do have GPS working, I might have messed up something on prior tests.
But I can confirm that 4.1.0 can’t access GPS (there are no 4.0.4 - 4.0.8 builds for Journey).
I believe the culprit might have something to do with this commit from @tridge which changes the order of serial ports from:

I tried changing that line to
but the board becomes unresponsive.

Any clues about how can this be further debugged?
Why did the order change when going from UART_ORDER to SERIAL_ORDER ?

I just built latest Copter-4.0 (4.0.8, fixing some compilation errors with toy_mode) that has the commit above and GPS is working with it. So the problem is not with SERIAL_ORDER but something else added on 4.1.