Servers by jDrones

Settings for multi-vehicle setup with RFD radios

Hello, I am trying to connect three vehicles (quads running Arducopter on Pixhawk Cubes) to QGroundControl using RFD868ux radios. The radios are running standard point to point firmware so I have three pairs. The ground radios are connected to a desktop via USB hub.

So, to begin with, with default settings (only difference is NetIDs which are unique to each pair and the SYSID_THISMAV param, which is unique to each Pixhawk) the performance is horrible. A single vehicle is OK. With two, some commands get dropped and you can tell the difference but it’s kind of OK. With three, forget about it, a command might get through occasionally but by and large, it’s hopeless.

I have searched online but cannot find anything on what settings are best for such a setup. I have fiddled around and got somewhat better results by doing the following but have found nothing really definitive yet:

  • Increasing hopping channels (default is 1, increased to 7).
  • Shortening the duty cycle (default is 100%, shortened it to 10%)

I am also considering:

  • Adding Listen Before Talk (not sure what value).
  • Manually assigning a unique frequency range to each pair.
  • Perhaps flashing with multipoint firmware.

Before I go fumbling blindly, does anyone have any tips on what settings to play with? The RFD radios have astonishing performance when used in a single vehicle and I 'm sure using them in multi-vehicle setups couldn’t be that hard.

I suspect you are getting radio interference by having 3 radios right next to each other on the ground.
Setting each radio to operate in a unique frequency range will help with interference but you will loose a lot of your data bandwidth, so your coms might be slow.
I have not done any multi vehicle setups so I cannot offer any insight into those settings.
Are you getting steady telemetry data from the 3 aircraft?

With the 7 channels and 10% duty cycle I get reasonably steady data but it’s nowhere as good as single vehicle. QGC shows the radio status including an “Rx errors” field. In a single vehicle setup, the errors are typically 0 or 1 and don’t change much. With 3 vehicles, I see them going up at around 4-5 errors per second.

You will definitely need the multipoint firmware

Download the documentation, RFD Tools and firmware:
http://files.rfdesign.com.au/

Thank you Shawn, I will definitely look into that. However, I am puzzled that I have not seen anything about SiK settings on the web. For example, look at Ardupilot’s own documentation here. As far as I can tell, these are three vanilla radios, not running multipoint, ridiculously close to each other, seemingly without any problems. I am guessing that if that setup needed extensive fiddling with the radio params, it would be mentioned somewhere.

Carefully read the RFD doco about multipoint, and you’ll be able to increase the baud rate quite a lot over standard 56k too. Range should still be OK as per:

Baud rate Air rate and Max Window settings something like this:

So, just to close this thread, I tried multipoint and the setup was fairly straightforward. I assigned a unique node id to each radio and then on the master node, did AT&M0= 0, Z, where Z is the number of nodes. It worked fairly painlessly, however, I have reverted to P2P so never got round to testing at range.

Servers by jDrones