"setting new offsets for compass #1 failed"

I have tried repeatedly to successfully calibrate the compass and no luck. I am using an APM 2.6, just ran the wizard, updated firmware, did the gyro calibratiobn, now on compass calibration and stuck for about 3 days trying to find an answer. The compass during calibration seems to work fine, but everytime it stops and says, “settitng new offsets for compass #1 failed” … . . and no other info… What is wrong here?? I cant find any documentation on this error anywhere. Thank you to any suggestion.

I’ve this same problem on APM 2.8. Anybody help ??

I’ve got the same issue after accepting the “update”. There seems to be a conflicting parameter default or something that won’t allow the external compass to calibrate. I’m on APM 2.6 Ardupilot.

It’s been a while since I did an APM compass and not with the latest Mission Planner.

I would suggest that you aim your request a bit better than just dropping it into the general “Arducopter” category.
The Mission Planner sub category would get more relevant interest.

Have you updated to the latest Mission Planner?
Have you tried the Beta Mission Planner, as things are being changed all the time?
What firmware are you working with? I am assuming 3.2.1 as that is the last iteration for APM.
Have you tried APM Planner or QGroundControl?
Have you tried clearing the APM (by loading rover or plane) and reloading Copter?
Are you using USB for the connection ? Not a great idea as you are limited to how far away from metal objects you can get.

Just some thoughts.

I had the same problem with an Arduflyer 2.5.2 and Ublox Neo M8N. I got a new transmitter and receiver so decided to re-run the wizard, and kept getting that compass #1 failure message after running live calibration. After about two days of pullout out my hair I realized it had to be a software glitch. I downloaded Mission Planner 1.3.9 and it calibrated fine, but 1.3.9 is a bit dated. Anyone know how to get the latest software just before the most recent update?

Got the same problem here, so downloading a older version of mission planner could solve? Where to download it? Or should I just wait? Wish this will fix soon to lift off my first drone.

Here: http://firmware.us.ardupilot.org/Tools/MissionPlanner/
Archives. Newest software is at the bottom.

So have learned a few things while troubleshooting thus since I first posted, most importantly though for anyone in a hurry is that the compass calibration is actually working fine as far as I can tell. I have come to this assessment based on the fact that in final pre arm checks, The Co mpass Cal step is shown as complete. If anyone is still having trouble and not passing pre arm, here is a couple things I was told to try, wether these things were a factor in mine working or not i have no idea… 1. Is to disable the auto complete option inside of the calibration I interface. This allows you to take your time and make sure you successfully eliminate all the white targets, and again not sure if it’s of any help but I made sure the error count was at 0 before I clicked ok. Once I did I got audio feedback that calibration was successful while still receiving the same unable to set offset error. So just ignore it in this case. 2nd thing I was told to try was to disable the magnet option in parameters.

Now, the part of this I didn’t like so figured out for myself, Is that I remembered when first doing this, after calibration, it had set a couple offsets for the compass. This time, while the compass was calibrated for accuracy, the offset values weren’t filled in. If you see in the top box though there is a link to the website which will give you these values. They are assigned based on location, not hardware sensor. So you just un tick the box that says set automatically, get your values by entering your local on the site, and then plug them in. Done deal
, Compass in good health!!

please try the latest beta MP.
this should be fixed now.

Will do.
My Workaround (in the last 24 hours) was to load up the latest APM planner and just run the compass cal. in that

What was the problem? What had to be fixed in the latest version?


Thank You.

the settings where saving, even though it displayed an error.

the reason was its trying to set a parameter that doesn’t exist on old apm firmware

1 Like

I had no clue it was actually something like this.
I also had no clue I’d get a response this fast let alone a fix!
Was so worried that I was on old stuff and in ‘unsupported’ or at least ‘un cared for’ territory.
What timing.
My very first APM haha.

I’m new to Ardupilot but have an alright handle on what’s going on.

Fun stuff.
Thank You!

Also, just for the record, APM hardware is VERY VERY OLD and NOT SUPPORTED. Please, everyone, stop buying them when about the same price you can get a pixhawk or a pixracer. I hate to say it but there are plenty of clones of these boards available too.

Get a pixhawk (of some sort) , and you won’t regret it… many cool new features,

pixracer: smaller hardware for smaller airframes with less features and lower cost
pixhawk: well proven mainstream hardware , also called "pixhawk1"
pixhawk2: latest and greatest pixhawk version, used in the solo, and now being sold on their own.
( other hardware’s are also available, but these three are the most popular options)


Good advise. Thanks!!
I bought the 2.8 about 1 year ago not knowing anything for $40 US.
Just figured at the time it would be fun to play with.
My expectations of performance are not very high.
But figured it would work at a minimum and still be a good intro.

But yes advice taken any new or serious projects will be based on newer supported hardware.

For me this 2.8 is just a let’s check things out type project.
And to be flown/tested away from people and property in case it does not work so well.

@DavidBuzz I would agree that APM is getting dated, is now unsupported, and that new users buy pixhawk instead.

On the other hand I would like to point out that there are still thousands out there still working fine.
We have many in the field doing commercial work that just keep keeping on.

So I guess what I am saying is, don’t dismiss the APM out of hand due to it’s age.
They still do a good job.

On the plus side, once an APM is setup with AC 3.2.1 there is no need to keep upgrading it for a new FW version that might have the latest bugs fixed :wink:


Lo que les interesa ustedes es que compremos la pixhawk supongo que tendrán buena comisión ( y me alegro por ello) pero los que estamos usando APM pues nos disgusta que por falta de información,o que no le interese a ustedes que siga funcionando y lo que estan intentando es que nos compremos la dichosa pixhawk seguro que es muy buena,pero en su momento y hasta hace unos meses tambien lo era APM.
Asi que en difinitiva si tengo que cambiar de controladora no será una pixhawk, tan solo por dejar de lado a la gente que estaba a usar APM,saludos y que disfruten de su pixhawk

It’s not that people make money from selling PixHawk’s

The APM is a very limited 8 bit platform, and to keep improving the features available on ArduPilot, a new 32 bit platform was designed a few years ago. This evolved to be the PixHawk, which has evolved, maintaining compatibility, to the PixHawk2.

Even after the PixHawk was released, the support for APM was kept, but at the moment the new features are not possible to port to the APM, and as the team is very small and supporting the APM was extremely time consuming, it was decided to stop supporting the APM.

Nothing to do with financial interests, only technical.

If you choose to buy a APM today, it is a decision that you must be aware of its limitations. Some of us still have APM boards (I don’t), and I still use a MultiWiiPro board with a hacked version of ArduPilot. If I have a problem on the MultiWii, I try to solve it by asking or learning the code.

Do you know someone that still uses a PC-XT machine? It’s the same. Things evolve and older systems stop being supported…

Es mejor escribir in ingles. Perdona por mi castellano :slight_smile:

1 Like

I use APM still successfully in Arduplane. APM 8 bit is still much better than DJI Naza V2. For people who want to deal intensively with the topic is the inexpensive APM ide

So, I keep getting the same failure. It seems to happen when I turn my copter upside down in order to capture the white dots in the lower hemisphere. I am using Mission Planner V 1.3.44 and V4.4.4 quad firmware.

You indicated that one should disable the auto complete option inside of the calibration interface - can you be more specific? I can’t see where I can do that.

Está bien publicar un mensaje en español.