"setting new offsets for compass #1 failed"

@FossilRider there is no V4.4.4 copter firmware.
If you have an APM then the firmware version stops at v3.2.1
If you are loading anything later then that will cause issues.

If you have a Pixhawk then the current release version is v3.4.4
You could try downloading the beta release of Mission Planner which has some fixes in it for compass.

Same, I bought mine actually in 2014! LOL, just barely got around to building it. Now after the first couple of flights I am hooked and already looking in to better systems. Even though the 2.6 that I have is awesome, I am getting all kinds of new ideas for things to integrate if there was a full Linux stack on board. Anybody have any advice or comments on the Navio2? Seems that this would blow a Pixhawk system out of the water… RasPi3 + Navio2…

Well, I will try again - perhaps I wrote down the firmware version incorrectly. At any rate, I have an older version of M.P. loaded on a laptop and I tried to do the compass calibration on it, but goto the same results. I know that the compass/GPS unit is good, so I decided to swap flight controllers. The unit I swapped out is brand new (well, I bought it over a month ago - been waiting all this time for a new GPS module). Anyway, the compass calibration was successful.

So now, I’m suspicious of the F.C. I will reload the firmware and try again. If it fails, I will toss the F.C. and get a new one.

I downloaded the firmware from Mission Planner, 1.3.44.3 build 1.1.6250,35577. I selected APM Copter quad (x-config), which was listed as V3.4.5. The download was successful and I sucessfully completed the accel calibration but the compass calibration remains a problem. Mission Planner says it was completed, but I still get “Bad Ccompass Health” indications.

If I am getting Pixhawk firmware instead of APM (Mission Planner should be able to detect the difference), then I would expect the download to fail as the image should not fit in the APM.

So, I think I’ve run into two problems here:

  1. The “setting new offsets for compass #1 failed” problem that others reported, and seems to be fixed by updating with the latest beta code.

  2. A problem with my flight controller either not retaining the compass offsets or something else.

I can try reloading the firmware from the older version of M.P. I have on my laptop, but I’m beginning to think that it will be an exercise in futility, and I’m getting tired of swapping out flight controllers between my two copters.

I have seen other forum entries where v3.3+ versions have gone onto APM’s and SEEM to work EXCEPT…

So just be sure that if you have an APM you only load v3.2.1

Compass calibration can be affected by a number of things, and most notably the surrounding environment.
Be sure you have no underground cables or pipes, not near metal buildings, etc, etc.

If the compasses vary greatly you may find you can calibrate them but the FW then complains about compass variances. You might have to turn compass use off for those compasses.

Hello Michael - I am running Arducopter V3.3.3 and trying to do a compass calibration with MP1.3.44 build 1.1.6240.11550 and getting the error “setting new offsets for compass #1 (and #2) failed” - Would this be the same issue as you mentioned with MP trying to set a parameter in the pixhawk that isnt in V3.3.3? Thanks and regards

Hello I am having the same problem with my APM 2.8 now could you please tell me where I can download this Beta version? Thank You Bill

in the mission planner go to help,in bottom page u will find check for updates and check for beta,click on beta and downlosd will start and automaticaly will restart tle mission planner,now recalibrate again the compass,this worked for me with APM 2.8