Serial 4/5 on Pix 2

Installing my Pixhawk II and noticed there is no serial 4/5 connector now. Looks like serial 5 is on the 3 pin on top. Is serial 4 on the connector for the edison? I need to hook up my companion computer and have used serial 4 in the past. Telemetry radio into telem1 and flightdeck cable into telem2 so I need another serial port to make my setup work. Also on the usb connector. I run a remote led/usb board. Is the buzzer wire separate from the usb signals? Can I wire that buzzer into the usb cable and still have function on both? Are the pinouts for the Pixhawk II available?


On this page, the specifications are here

Seems like the pinouts are the same but instead of power on the left, its on the right (orders are reversed as far as I can tell). I have not verified this for all the connectors. I currently just have the pixhawk 2 on a piece of cardboard with gps and some other things to test out for now.I also run a remote USB and will be needing a remote micro SD card slot. I am hoping that I can get my companion computer to log a data flash log to a USB thumb drive.

Telem 1 is Serial 1
Telem 2 is serial 2
GPS 1 is serial 3
GPS 2 is Serial 4
Debug is serial 5

1 Like

Can you use serial 5 for companion computer? Was going to use 2 GPS until I get RTK but I guess I can get along with just one if I can’t use serial 5. Wish you could do the companion computer via can bus. I have a can bus adapter hooked up to my TX1 that I use with my motor controllers.


Is there a way to log using the debug USB port to write to a usb thumb drive? My flight controllers micro SD card will not be accessible

Have it all hooked up now same as my old pix1 setup. Thanks. Decided to try an Edison for companion computer. I have a nvidia TK1 as well but the Edison will use so much less power. And it fits right in the carrier. Sbus pass through is awesome. Now I can control my gimbal with just one servo cable instead of 4 . Much cleaner wiring now. Saw a post on how to turn down the internal heater but can’t seem to find it again. Supposed to make the cube run cooler when it’s adjusted properly. I was going to use the pix1 that came off the drone on my rover but I think I’ll get another Pix2 instead. I love how much easier it is to plug and unplug the cables. The pinout on that doc for usb port has a mistake. The led and buzzer pins are reversed.


@proficnc I’m looking to use a Pixhawk 2.1 for my next rover project and I’ve looked through all your documentation, but Serial 5 for general use still looks difficult to use. I know you’re in the process of creating a standard and an Edison carrier board. For a future standard carrier board, would it be worth it to make Serial 5 (Currently a debug on the underside of the board) a full header somewhere on the topside? I wasn’t planning on going the Edison route until support is a little better and it is used a bit more.

Here’s what I would like to do based on what I understand
Serial 1 - Telem 1 (RFD900x)
Serial 2 - Telem 2 (Mavlink to Raspberry Pi for Wi-Fi/4G LTE/RockBLOCK Satellite)
Serial 3 - GPS 1
Serial 4 - GPS 2
Serial 5 - Peripheral Collision Avoidance sensor (Grant says Lidar360 might be a possibility down the road for Rover)

I’d like to have 2 GPS’ out on the water, but with the standard carrier board, I would have to drop down to one GPS. Doable, just trying to get the most out of a great autopilot!

1 Like

Some lidar units can be attached to i2c or the general i/o pins on the pix. I hook a lidar lite up that way and its supported in APM. Scanse’s Lidar lite based unit ships this month. One of the few that work well outdoors in bright sunlight that isn’t an arm and a leg. I’d be real careful using wifi. I use an nvidia TK1 and its wifi does evil things to the control channel.

for the Mavlink to WiFi, why not use the Edison for this? as it fits on the carrier board, it would save you having a whole separate computer for this.It has OTG, so you could run a modem on it.

For the GPS, you can add a zubax CANBUS GPS as a secondary unit…

And yes, what Dan said, if you wish to use WiFi on-board, ensure that you set it up in a way that it doesn’t interfere with other systems.

1 Like

With the release of APSync, I’ll have to try it with an Edison now that I know it works and is fairly easy to set-up. I’ll have to research the things I can connect to the OTG port.

I’ll be working on boat projects, so I can space out components better to minimize Wi-Fi interference. I won’t be packing all these things into a tight quad.

How easily can I utilise Serial #5 for sensors or a GPS.
Currently I have:
Ser#1 Radio + Tx to MavToHOTT board
Ser#2 Ping
Ser#3 Septentrio RTK GPS
Ser#4 Laser Rangefinder
Ser#5 ?

Can a GPS (Ublox M8N) be hooked into Ser#5?
Or would it be better to move the Ping or Laser Rangefinder to Set#5?

I have read in a post elsewhere that Ser#5 is not that straight forward to use.
No details were given.

I have tried a bench test with a bare Pixhawk2.1 with an M8N plugged into Ser#5 and nothing in Ser#3 but I get a ‘No GPS’ message in Mission Planner.

You would need to change both PX4Firmware configuration and ArduPilot code.

Or just Ardupilot in the intree drivers correct?

No, that’s not enough. The console is configured at NuttX level, which files are in PX4Firmware, for example:

At the ArduPilot level should be pretty easy since we already have a 5th UART slot (used in Pixracer only for now).

Seems curious to me that U(S)ART1 to U(S)ART8 but minus U(S)ART5 are configured in the PX4 files.

Why is U(S)ART5 left out of the configuration, and can we get access to U(S)ART6 to U(S)ART8?
With appropriate changes in Ardupilot of course.

Who is the holder of the key to the PX4 files in question?

Or do I need to load the PX4 firmware to get access to the extra U(S)ART’s?

If I’m not mistaken it’s because the SD interface is in the same pins as UART5.

What do you mean? We already use them.

Holder as in who owns that repository? ArduPilot does, it’s a fork.

1 Like

I have the same Q…programmers docs say the protocols were added to UART5 as well.
MP does have the config resources…but nothing wants to come out/in. I’ve tried gps and lidar…nada zip zilch.
so whay have the configuration setting is it’s not avail? If changing any of the dault settings in SERIAL5, what are we messing up??

ZD850 (converted to 1050) Hexcopter
x6 Hobbywing 30ESC
Tarot Martin 330KV MT4008 motors
Pixhawk2 & Here GPS
Odroid XU4 Companion computer (about to be swapped with a Jetson TX1)
tall retracting landing gear
x4 cameras with 3x picture in picture OSD etc


Hi is there anything further on this subject?

I have a Pixhawk 2.1 in a DJI550 with

Telem 1: Telemetry radios
Telem 2: Micro minim OSD
GPS 2: Storm32 gimbal

I would now like to add a Lidar but apparently Serial 5 (Debug) will not work. Can I maybe combine my telem radios and OSD into the same telemetry port to free up another one of the UARTs?

I’m pretty sure the serial ports were liberated in a recent firmware.It may be the current stable or the latest beta.Have a check of the release notes.

Serial 5 was the one freed up by the looks.

latest firmware supposedly turned on full uart5 support (3.5x?)

yes…telem and osd should?can run on one telem

my own (on a Tarot Peeper)

Telem 1: 915Mhz telem and minimosd (plenty of wiring drawings out there
for Y cable)
Telem 2: FRsky recvr telemtry

on my custom ZD850 Hex (now a 1050) same as above but soon to move
FRsky to Com5 and use telem 2 for companion computer

Paul Tegler