RTL during LANDING on Quadplane Triggered by Low Battery

Hi Guys,

I thought the issue with VTOL platforms going to RTL on battery failsafe was fixed in the latest firmware version but sadly, it doesn’t seem to be and almost cost me the platform. I am flying a very modified Nimbus setup with the CUBE and latest stable firmware (3.9.8). I was flying an automatic mission (from start to finish with VTOL_LAND as the last command), the battery was at 22.3V right before the transition to copter mode and then due to the high amp draw, got sucked down to below 21.7V (where I have my Low Battery Failsafe set). At approximately 4 meters from the ground during the landing phase, the platform decided to initiate RTL and proceeded to transition to Fixed Wing and fly home (actually, I have RTL_AUTOLAND setup so that it repeats the landing approach). I switched out of Auto and back into it to over-ride the RTL and it proceeded to return to the landing zone where I took over manual control and landed in Q_LOITER.

This is VERY DANGEROUS!!! I was a few seconds away from watching the platform fly into a power-line and tree when I grabbed the remote and took over control. Please please please can we do something about this? The logs for this flight can be found here: https://we.tl/t-2JTR46H80Z

The Telemetry Log can be found here: https://we.tl/t-iUdAvnvGGI

If someone can get back to me on this asap that would be fantastic. This issue causes major concerns for operations where you do not want to land where you took off from (ie, home) and removes the viability of low battery failsafe as with it enabled, this issue happens, and with is disabled, well, you dont have that security.

looks like it is fixed on master

although I think if it was a land mission item in auto rather than being in land mode it would be missed

Hi Peter, the last command was “VTOL_LAND” in the automatic waypoint mission. Why would that be excluded from the protocol you have listed above?

Do my logs show anything different?

VTOL_LAND is a mission command within auto mode, so it is in auto mode rather than land mode. It looks like we would need a few changes to the flight_stage code so that a auto mode landing in vtol would stop a RTL

That would be ideal. So at this point in time, there is no way to safely include a VTOL landing in an automatic waypoint mission is there?

I reported this and opened an issue about it back in April

For now DO NOT use RTL_Autoland = 2. Just set to zero.

I’m not sure, but would setting a rally point at the desired Land position mean any RTL during the last phases of flight just send the craft to the rally point anyway?

1 Like

@iampete

Dear Peter,

I have just made and update with a very simple solution in the issue that I reported on github (see my last post in that topic). Can you please take a look and see what you think? If this was implemented, then all but the most extreme cases will be able to operate safely.

Cheers
Alex

Please developers, this issue is really important. We urgently need a solution that allows for VTOL_LAND during an autoland to ignore RTL on failsafe event (no rc, battery etc). This is a safety issue

Last fall we were testing BVLOS landings in the Black Rock Desert.

Lost radio connection as the plane touched down. I think there is a 10 second wait before the failsafe initiates the RTL so the the plane was on the ground but had not disarmed it’s self.

As I walked up it leaped up and immediately initiated a transition.

This is a 3 meter quadplane that weighs around 35 lbs…

I’m reasonably quick on my feet so I got out of the way in time and we were in the middle of a salt flat so there wasn’t anything to hit.

Regardless I can attest it’s a very dangerous behavior.

-Shane

Hi Guys, I am worried about this Fail safe problem, but fortunately I never got this problem during my Vtol flight auto mission. So, before we have permanent solution, what do you think “temporary” solution to avoid this FS problem??
In think I will not set low batt. FS (since this issue may happen anytime). Also I wish can set the delay disarm (after landing) to Zeo (So ardupilot will Disarm immediately after landing), but unfortunately can not do that now. Based on current firmware, the minimum value is 1 second. I agree that this FS problem is very very Serious issue to be solved as soon as possible. I suggest The logic as follows:
1). FS (and RTL) can not be triggered during landing process.
2). Landing mode can override RTL or FS mode.
3). Disarm delay value (after landing) can be set to zero (autopilot disarmed immediately after landing).
I hope developers consider Safety as number 1 priority to be solved.
Regards

Was this issue ever resolved in newer Arduplane?