Servers by jDrones

RPLIDAR A2M8 360º Object Avoidance problems

object-avoidance
lidar
(Rafael Roldán) #1

Hi!
We have installed a RPLIDAR A2M8 3601 scanner but we are having an issue of detecting false positives and leading the copter to a stop where there is no obstacle at all.
This hexacopter mounts the Pix Cube with latest stable ArduCopter. Here is a video of the sudden stops.

Thanks for your help!
Rafael Roldán

(Andres) #2

Maybe the rplidar is close to the propeller plane. I don’t know if the laser could detect the tip of the propeller with the arm deflection. Could you test the lidar placing it some higher?

(ppoirier) #3

Check on the log file for glitches in the proximity signal

(Rafael Roldán) #4

Yes, we have tried at different heights with the same results. According to specs, Lidar beam flatness is between +1,5º and -1,5º so we should have plenty free space. We are going to make a taller mounting (about 15 cm above props plane) and try again. Thanks!

(Rafael Roldán) #5

Thanks! Do you know the exact parameters to look for these glitches?

(JY Lee) #7

Did you solve this problem?
I am having the same problem.
But it only happens in Loiter mode.
Works perfectly in Althold.

(Rafael Roldán) #8

No luck here… Same problem.
In LOITER we have sudden stops with nothing in front. In ALT-HOLD, no stops but the copter does not stop into a real obstacle. Very disappointed with this…

1 Like
(Muhammad Hamed Fawzy Abdelraziq) #9

@rafaroldan

Hello, my friend!

I am about to start a project similar to yours and I plan to use the RPLIDAR A2. My goal is to build a hexacopter that can perform object avoidance. I kind of got discouraged reading this discussion and I want to be as cautious as possible before I actually order the RPLIDAR A2 and start assembling the drone.

If you would be generous and share with me some details about your code, assembly, and different aspects you had to deal with will building your drone, I would be very grateful for you!

My email address is: mabdelraziq@murraystate.edu

We can also have further discussions in the future and benefit from each other!

Thank you!

(vosair ) #10

I had this same issue with the A2 on our build. Not as extreme as in the video but it definitely had false detection. It is high enough that it isn’t detecting any part of the frame of props.

(Rafael Roldán) #11

No luck for now, I’ve been trying many things (power supply, props or body reflections, direct sunlight interference, defective LIDAR…etc) but I always get the same result…
I don’t know how to continue with this.
Any help or test suggestion from the community is greatly appreciated.
Thanks!

1 Like