Servers by jDrones

RPi 3 again: Connections seems to work in one direction only (Dropix issue), SOLVED

Hello Ardupilot community,

I know, there are already two threads with the topic:


But both are not listing my problem.

So lets do the setup process again:

Pixhawk 1:

  • flash different Firmware
  • flash Copter 3.5.2

Connect with MissionPlanner:
Telem1:

  • Set BRD_SER1_RTSCTS to 0
  • Set SERIAL1_BAUD to 115
  • Set SERIAL1_PROTOCOL to 1 (default)

Telem2:

  • Set BRD_SER2_RTSCTS to 0

  • Set SERIAL2_BAUD to 115

  • Set SERIAL2_PROTOCOL to 1 (default)

  • Set LOG_BACKEND_TYPE to 3

Power off Pixhawk

RPi:
Dowload image and flash to SD-Card.
I tried:

raspian and APSync beta are behaving in the same way…

After installation:
sudo raspi-config >> Interfacing options >> Serial >> disable login shell and serial hardware

sudo nano /boot/config.txt

Add the lines:

enable_uart=1
dtoverlay=pi3-disable-bt

Update mavlink installation on RPi:

sudo apt-get update #Update the list of packages in the software center
sudo apt-get install screen python-wxgtk2.8 python-matplotlib python-opencv python-pip python-numpy
python-dev libxml2-dev libxslt-dev
sudo pip install future
sudo pip install pymavlink
sudo pip install mavproxy

Connect RPi with Pixhawk through Telemetry Port. Do not connect +5V
(switch TX/RX as you like, one works a little bit, the other direction does not…)

Provide power through 5V USB Powerbank to both devices.

  • RPi through normal Micro USB connector
  • Pixhawk over Servo Rail, specifically NOT over USB
  • Startup both

Connect via mavlink:

sudo mavproxy.py --master=/dev/ttyAMA0,115200 --mav10

Try to change arming checks:

arm check all

Result:

There is some kind of communication between RPi and Pixhawk. But it seems to be one direction only. Swapping TX and RX will not solve the problem.

Any suggestions are very appreciated!

I suggest to remove the --mav10 option and to try baud rate 57600

I’m not sure if you can provide mavlink commands from BOTH ports at the same time. So maybe try to swap the connections around.

Thanks Ruben,

I tested both:
Removing --mav10 has no effect at all.
Choosing a different baud rate results in that:

I set the baud rate specifically to 115 on the Pixhawk, so connections on this rate are most likely I think…
I configured both ports exactly the same. I tried switching between them without getting different results.

Ok, so the baud rate is ok :slight_smile:

Have you tried just connecting one device to telem1 ?
I do think you can only send mavlink commands on one port.

You can have mavlink on up to 4 ports.

1 Like

Iirc APSync defaults to 921000 baud by the way.

I changed the following:

Telem1:

  • Set SERIAL1_BAUD to 921

Telem2:

  • Set SERIAL2_PROTOCOL to 10 (just something different not “1”)

Baud change was successful, I am getting the same messages as provided in screenshot nr. 1 with 921600 baud.
Changing the protocol setting for Telem Port 2 away from “1” does not change the result.

Have you tried just connecting one device to telem1 ?

The RPi is the only connected telemetry device. Nothing else (433Mhz Radio, BT-Module etc…) is connected to the Pixhawk.

Okay guys, here is the solution:

Pixhawk was a Dropix V2.1.
I printed the PDF manual for Version 1 long time ago.

Version 1 Pin Layout:

Version 2 Pin Layout:

Drotek changed the layout…

:joy:

Ah, that would explain things!!!

Hi,
Which are the commands you used to get the gps and imu ral time data. Can you tell me what msgs are used??

Servers by jDrones