RNGFND_GAIN not working for Missions

I understand from @rmackay9 here that RNGFND_GAIN does not apply to auto (mission) modes. I have verified this through testing.

I am trying to mitigate the effect of ground features such as hedges in transit during a mission, but be able to have lidar accuracy at specific events during the mission, such as hovering closer to the ground (below 20m).

Does anyone have advice, or indeed suggestions to change the code involved here please?

To follow, because I am in the same situation I need to lower the reactivity of detection of my lidar what I did with the parameter RNGFND_Gain and I would like that this is also applied in AUTO mode ?