Rangefinders (I2C) won't work with Cube Orange but do work with Cube Black

Hey, I’m having trouble with the Cube Orange.
Everything works fine with the Cube Black, but nothing works when I connect the rangefinders to Cube Orange. (I use the same params file).
I tried installing an older version of Arducopter to the Orange (Arducopter V4.0.6) and still, it didn’t change anything.
I also tried changing the params manually, (RNGFND1,2,3,4), still didn’t make a difference.

I use 4 (forward, back, right, left) Terabee EVO 15M rangefinders (forward, back, right, left) and an Orange cube (Arducopter V4.1.5) Mission Planner latest version.
I also use the Hterm software which Terabee suggests.

The connections I use in order to change the I2C address are FTDI232 (TX, RX, GND) to the TX, RX, GND of the rangefinder. (TX, RX are crossed). The rangefinder gets its power from an external 5V BEC.

They should work in Cube Orange also.

It is better to post your parameter lists in order to evaluate something.

Also, your Cube Black could be in an older ardupilot version, and this could be making some kind of difference in the parameters you set up.

Hey, thanks for the reply.
The same firmware is installed on both of the cubes.
I installed an older version on the orange (V4.0.6) in order to check if there’s a bug with the newer versions. It didn’t make a difference.

I went out of my way and checked the rangefinders on a DIFFERENT Orange cube (V4.1.5) and still, nothing worked. (same RNGFNDR params)
I also tried again to install (V4.0.6) and it didn’t work either.

The param files are below.
P.S, the original drone is a Hexacopter. The airframe on the cubeBlack is not the same (Quadcopter).

Let me know if you can’t spot something out that I couldn’t :slight_smile:


Unrelated, but you could set INS_HNTCH_REF,0.147 for the Harmonic Notch Filter to work.

Is the rangefinder issue related to a connector and correct pins?

How will the Harmonic notch filter affect my flight?

The rangefinder issue isn’t related to the connection because the rangefinders work when I plug the same configuration into the Cube Black.

I have a similar problem and I opened an Issue

1 Like

No, this is not the same problem.
You got bad readings.
I got no reading at all.
The cube doesn’t even detect the rangefinders.

Oh, maybe it is similar issue as your device cannot initialise properly.
Anyway, just to let you know that there might be is an issue with I2C devices on H7 architecture.


Any update on this issue? I have ordered and EVO 60m for my Cube orange. Has anyone found a solution?

Do you know if the issues with I2C on H7 architecture has been resolved? I was thinking since there has been a few updates to firmware since this post orginiated maybe a fix has been implemented?

Thanks in advandce

It is working OK now

1 Like

hey, I have the same setup. Did your issue got resolved? If yes then do let me know . I am having trouble with the same. Cube is not detecting 4 sensor at a time.

With ArduCopter version 4.3.6 ?

No version its 4.3.5. I hope this firmware version has no issue. I just need to know the process to integrate it.

Mine worked just fine, ArduPlane V4.3.3 . Make sure you follow the guide below and most important of all you need to power the Terrabee with a 5V supply seperate from the Pixhawk. It can at times draw 300mAh so just connecting to Pixhawks 5v won’t be good as it can harm the FC.

A cautionary tale, make sure you use a dedicated DC-DC converter to step down your battery voltage within the range of 4.75 to 5.25 V that only powers the terrabee. The sensor is very sensitive to voltage spikes, I fried one the was connected to the same DC step down as my servos, the servos caused a voltage spike and ruined the sensor
Alternatively you can implement some sort of Surge protection, but using a separate DC-DC converter should do the trick


1 Like

Thank you. But my sensor is tfmini plus. And I am not able to connect 4 sensors. I used telem 2 , gps 1, gps 2 port of cube orange for 3 sensors but I am not able to configure I2C port for the 4th sensor. I have set telem 2 sensor as rngfnd1.

Hi, i’m having the exact same problem with my orange cube i’ve tried all settings and I2C port and a serial connection and i still can’t get any reading from my Lidar(lighware sf20), any thoughts?

Are you using ArduCopter 4.4.0beta4?
You should.

thanks for replying amilcarlucas, I was using v4.3.7 and i did update it to v4.4.0beta4 but unfortunately still can’t get any readings from my RNGFND2 and btw i’m using hereflow sensor as RNGFND1 does that affect my lidar readings?

Only usin rgn2 without having a rng1 is asking for trouble. Do not do that. Fix and use rgn1