Radio Control Problem

Curious, but are there any reason why my RC signal gets messy?

I’ve done multiple tries and runs on my rover and it does work. However, sometimes the RC signal gets messy. Even though the joysticks are in the middle (joystick in the middle has no movement in my case), it implements a movement. I don’t know if the remote control gets crazy as the signal is fluctuating.
The calibration of the RC signal changed. The middle signal is slightly changed a little bit upwards or sometimes downwards from the joystick. But after testing again after a few hours, it goes back to being normal.
I tried looking it up on mission planner, but the calibration is correct. I’m using FrSky Taranis with X8R receiver.

What kind of radio is it? Has the radio been gone through a big temperature swing? Ie, from inside at 20c to outside at 0c?

I tried looking it up and I found this very similar problem.

My problem happens most of the time when I test my rover outdoor, but I don’t think there is a big temperature swing since I don’t directly put it under the sun.

I’m using FrSky Taranis with X8R receiver, too.

Well, I’ll just refer you to the advice in that post. :slight_smile:

1 Like