QuadPlane VTOL loses altitude during transition from VTOL to Fixed Wing

Hi All,

I am flying my 3m 20kg quadplane VTOL (Long Endurance VTOL Drone | 23KG MTOW | 2.5Hours Endurance) in AUTO mode, and every single time when in AUTO mode the plane pitches down after the transition from VTOL to fixed-wing has been completed, dropping up to 80m in altitude (from 120m to 40m, which is the Q_ASSIST_ALT).

I tried changing Q_ASSIST_ALT to 70m, but then the pitch down and altitude drop happens anyway.

I am almost certain that this is not a ‘physical’ / hardware issue, because the transition works perfect when not in AUTO mode! For example, when I am hovering in QLOITER and then switch to Guided mode, or when I am hovering in QLOITER and switch to RTL mode, the transition from VTOL to fixed-wing works perfect,and there is barely any altitude loss or pitching down after the transition (max. 2m).

Secondly, I am almost sure this is something to do with AUTO mode. Firstly, because this issue only occurs in AUTO mode, but secondly this is because when I change the altitude of waypoint 2 to be above (100m) the VTOL_TAKEOFF altitude (85m) , the altitude drop does not happen between the VTOL_TAKEOFF and waypoint 2. Instead, it happens between waypoint 2 and waypoint 3 unfortunately. But again, this shows this is not a physical issue (e.g. the plane cannot maintain altitude) and that this is something to do with how the plane navigates in AUTO mode.

I am attaching my parameters here, along with the logs from the flights.

We are working on a medical drone project for healthcare, so any urgent help for debugging this would be much appreciated! Thank you!

Link to the logs: Altitude loss during VTOL to fixed wing transition logs.zip - Google Drive
Full parameter list is attached!
params_while_alt_loss_during_transition_2.param (21.9 KB)

1 Like


We’ve flown for 2 days to try and debug this issue further. Unfortunately, we have still not yet been able to solve it. Here are the solutions we have tried that have not worked:

  1. Disabling THROTTLE_NUDGE parameter (THROTTLE_NUDGE = 0)
  2. Changing STICK_MIXING = 1 to STICK_MIXING = 3
  3. Making ARSPD_FBW_MIN and Cruise speed (TRIM_ARSPD_CM) closer (from 24m/s and 26m/s to 25m/s and 26 m/s)
  4. Reducing TECS_SINK_MAX from 4.5 m/s to 3 m/s
  5. Doing the VTOL to fixed-wing transition into different directions (upwind, downwind, wind from the side).
  6. Changing TECS_PITCH_MIN from 0 degrees to -8 degrees
  7. Changing Q_ASSIST_ALT from 40m to 70m
  8. Changing Q_TRANSITION_MS from 8000ms to 5000ms

More logs and the mission file that we used for the flights: Altitude loss logs - Google Drive

Hello Jan

so I just realised from your parameters and the log files the reason your aircraft doesnt get to the 120m is because;

  1. Tho you change your mode to auto, the aircraft, triggers a failsafe

  2. And your “Q_RTL_ALT = 90” which means your return to home altitude is 90m

  3. Thats why it gets to 90m and doesnt move to waypoint 2 but rather transitions and head back home

Were you ever able to figure out this issue? Or any updates?

@slacker Yes! This was a bug in the ArduPlane TECS controller code that caused the TECS state to reset after the DO_VTOL_TRANSITION mission item. Please reflash to v 4.4.x or newer firmware and this problem will not be there anymore, thanks to @tridge who fixed this issue.