Plane 4.1.0 beta

Hi. I am running 4.2.0 Dev version on a Matek F765WING. I have recently upgraded to this version from 4.1.something. I have a breakwire function that changes flight mode using one of the button inputs but it seems to have stopped functioning in the later firmware. I read somewhere that the BRD_PWM_COUNT parameter has been eliminated and the functionality defined through other means in the firmware. I suspect the pullup resistors on these outputs are not being enabled. In my case it is for button2.

ButtonNotWorking.param (20.6 KB)

The button press is monitored by a LUA script to change the flight mode when the input goes high. This was working on the earlier version of the firmware. I have measured the voltage on the relevant pin and it is zero.

Anyone have anything similar or knowledge of what might be wrong here please?

If you can tell me a better place to post for Plane 4.2.0 Dev please feel free to do so.

Thanks :slightly_smiling_face:

I will take a another flight and try to get a replay log tomorrow.Then can I change it back to use EKF2 by setting the following parameters:

Do that will make the system more stable?


that depends on what the problem is. Once I have the replay log I should be able to find the issue

I can’t help but notice that this seems quite similar to the pitch control issue and crash I had back on beta4.

As an aside, I had an odd bug on beta5 today; the aircraft entered RTL and then QRTL immediately after auto takeoff. The same mission/parameters were flown several times before the problem flight and once after it, all today. The logged reason is 39, which (from what I can tell from ModeReason.h) is RTL_COMPLETE_SWITCHING_TO_VTOL_LAND_RTL. I’m not sure how to see the current waypoint in the binary logs, but this was a cold boot, so the mission should have proceeded normally.


Just before the reason 39 happened there was a reason 2, which is GCS_COMMAND.

2021-09-18 03:21:49.479 MODE {TimeUS : 432292263, Mode : 10, ModeNum : 10, Rsn : 2}
2021-09-18 03:21:51.900 MODE {TimeUS : 434712872, Mode : 11, ModeNum : 11, Rsn : 2}
2021-09-18 03:21:51.900 MODE {TimeUS : 434713042, Mode : 21, ModeNum : 21, Rsn : 39}
2021-09-18 03:21:51.900 MODE {TimeUS : 434713227, Mode : 21, ModeNum : 21, Rsn : 39}
2021-09-18 03:21:51.900 MODE {TimeUS : 434713246, Mode : 21, ModeNum : 21, Rsn : 2}

So the sequence was:

  • auto takeoff
  • GCS command which triggers RTL mode change
  • RTL converts to QRTL due to Q_RTL_MODE=1

Do you have the tlog? That would tell us exactly what the GCS command was.

yes, you need to set SERVOn_FUNCTION to -1 (which means GPIO) for the AUX channel you are using as a button. Have you done that?

1 Like

@tridge thanks very much. I have not done that yet and will give it a go later in the day. I must have missed that in my reading of the documentation.

{EDIT} That did indeed cure the problem. Thanks! I also found I wasn’t as delinquent as I thought since I couldn’t find any mention of having to do that in the docs for Ardupilot. Works now :slightly_smiling_face:

I have set the log parameter and do several flight today,the first of the two flight is using EKF3,.Then I reset the FC using EKF2.

I download the log in sd card,but I found the log file size is very small ,even smaller as usual.
please download the replay log

Please also check that firmware 4.1 support rally point ,because I can’t find out where to set a rally point in mission planner,I have try several version of mission planner.I can find out where to set rally point in mission planner before connect to FC,but it disappear after connect to FC.


Try this:

Thanks! Log 000000003.bin reproduces the issue nice, and replay works. I’ve opened an issue for Paul Riseborough to look at here:

The dataflash log should also have that information in MAVC

Is the implication that you can interleave PWMs and GPIOs now? Previously all GPs had to be at the end.

Thanks,what is the version of mission planner do you used,

Latest beta version.

Good catch; I didn’t see that. Here’s the tlog. this takeoff is at about 90.17%.

yes, that was the main reason for the change

1 Like

Fantastic! Glad I found out about this! I was seeing the RC 1-10 printouts but couldn’t understand the significance.

@tridge, I still have one issue with beta. Yaapu telemetry is incorrectly reporting flight modes on the RadioMaster. E.g: FBWA is displaying RAttitude. AutoTakeoff is displaying Loiter.
Also when I turn off my transmitter the mode does not change to RTL. This is a red flag!

I am using Crossfire Nanao Rx and fully feature Crossfire module.
FC = F765-Wing.

Any suggestions?

From the picture you posted,it seems it doesn’t connect to FC now。yes i also can see rally point setting by right click mouse before connect to Fc,but I can’t see the rally point setting when it’s connect to FC.
I ALSO use latest beta firmware.

I just tested with yaapu telem on my TX16S and it is fine. So possibly a CRSF issue?
@andyp1per can you comment?