Servers by jDrones

PIxhawk wont Disarm after Landing

What did you do? What are your remedies?

no! Not at all but I ask to view a log outside that potential interference. It’s also an unsafe and bad place to test.

Didnt solve yet the not disarming issue :frowning:

https://drive.google.com/open?id=1ZImlGisTCzh51l8eXjqaBF4JllUS_aMD

try to set GND_ALT_OFFSET to 0.1

I will try this tomorrow.

Stabilize mode it disarms i tried a while ago, but in althold, loiter i dont know with RTL. It wont, i just encountered the disarming issues in the past few days. Before this does not happen.

But i wont be using stabilize mode, im inti althold loiter and RTL. Thats why i really needed to fixed the NOT DISARMING issue. This was okay before though. And even on the documentation in ardupilot supposedly the radio stick can disarm in althold mode.

This is a super basic thing to try, but it’s happened to me, so here goes. If using stick arming, you may be sending less than the necessary yaw pulse width limit to arm and/or disarm the FC. If you set in some trim or otherwise changed the endpoints, this could cause the problem. If you haven’t already, center your trims and re-calibrate the FC to the radio. Then on the servo indicator in Mission Planner, make sure you’re getting close to 1000 microseconds on the low end and 2000 microseconds on the high end of the yaw channel

Yes, the radio calibration is at least 2000 and 1000. It disarms in stabilized mode. Also, it disarms in AltHold also if the copter didnt take off yet. But if it does take off then land, it wont disarm anymore.

Still the same issues, I tried downgrading to copter 3.6.6, still the same :frowning:
Current log:

Im having error whe performing motor test in misison planner:

Error pos vert variance / BAD AHRS

How to fixed this?

So the underlying issue is that the landing detector is not able to detect the landing. The landing detector relies on a few things to work but one of the requirements is that the average motor output be quite low. We run into a chicken-and-egg problem though because the position and attitude controllers may lead to higher motor output to correct a position or attitude error. This means that if the vehicle lands off it’s target (in Loiter or Auto) it may fail to land. In AltHold this can happen if the vehicle’s heading is off it’s target and this is what appears to be happening here. See how high the motor outputs are?

… and here is the desired heading vs actual heading. See how the desired yaw is rotating around? Although it also appears the vehicle is rotating around on the ground which is odd. In any case, in similar landings later in the log the vehicle does not rotate.

This change is desired yaw is actually coming from the pilot’s input.

So the problem is the pilot is adjusting the yaw (probably in an attempt to disarm the vehicle) before the landing has been detected. This leads to a change in desired yaw, the attitude controller then increases the motors to try and correct the vehicle’s yaw but this leads to higher motor output which stops the landing detector from working.

I think the solution may be to wait a bit longer after the vehicle has touched down before attempting to disarm. Try waiting until you hear that the motors have slowed down before disarming. Alternatively you may wish to setup an auxiliary switch to be arm/disarm.

Hi sir, thanks for your response. I tried Yaw in the air while the vehicle is flying but in the middle of the throttle. Because i rotate the copter back to pointing front.

Then, on landing I disarmed it fully 0% throttle and fully landed. But it seems that, its not disarming. At 0% its like moving to yaw at 0%. While performing Disarming using stick.

I’ve seen this disarm problem a couple of times, usually following a GPS Glitch and you’d find the craft (GPS) thinks it is still moving around. Also in some cases it may be related to traveling, particularly via car, and the associated vibrations. Re-seating connectors has worked in the past - but then again that also implies a power-cycle too…

I’ll try to find a log where this happened.

If you have poor GPS signal and high HDOP, sometimes on a groundstation you’ll see the HUD going crazy (tilting and pitching) as the reported position on ground wanders all around the area, sometimes hundreds of meters. This is before arming and flying!
We usually joke and put it down to another North Korea missile launch, because usually we have really good GPS reception and an open sky without buildings or interference.

@banjing,

It’s best not to adjust the vehicle’s yaw just before landing. Also avoid trying to disarm with the rudder before it has detected the landing. Please wait for the motors to slow down before attempting to disarm with the rudder.

Taking a quick look at that log, the GPS altitude is drifting away from the Baro altitude, GPS number of Sats is low and HDOP is a bit too high for me.
You need to get away from that tower and buildings and see if there’s any difference - leave the craft sit on the ground for a few minutes to see if HDOP will come down below 1.0 before even thinking about arming.

Also battery voltage drops quickly, current rises and flat-lines at 50amps assuming the current sensor is calbrated ok. But either way that battery voltage is definitely dropping quickly.Those are some power-hungry motors or you’ve got a very high take off weight.

Im arming in AltHold Mode, so lets skip the GPS part although im using the external compass of it. Currently im struggling on disarming once landed. I think HDOP and stas counts matters if im flying in Loiter mode. Thanks

Also, will this matter? I tried changing the values as whats instructed.

I did set this, can you explain to me please whats the use of this?

Its for copters with tall landing gear

But lets try what @rmackay9 said
So do these steps

  1. Take off with althold mode
    2 . Wait a little bit for ex. 1 minute
    3 . Try to land with althold mode
  2. Dont move throttle stick to left corner till motor slow down
  3. After motor slowed down move throttle stick to left corner to disarm motors
1 Like

I tried a while ago sir, motor slows down. But still i was not able to disarm, then i move the throttle to disarm motor tends to spin more.

its really got hart to find the reason and you have multiple problem with this board
so take a look at all your config and remember them also your PID values then format SD card as fat 32 and try to reinstall firmware and this time when mission planner asked you to install chibios hit the yes button

Servers by jDrones