Pixhawk 2.4.8 wrong Orientation

It has been a week since i am trying to solve this issues: i have a pixhawk 2.4.8. ( no gps) using the internal compas. I am having bad orientation to the left ( it goes at right) to the right ( it goes at left).

Once i tired to set it at : pitch 180. And roll 180, yaw 180, yaw45… all the rotation but still i couldn’t get it right. I bought 2 more pixhawk boards but it all have the same problems. Is it my lap top bad??

I would start by doing the accel calibration and compass calibration again.
Also carefully redo the RC calibration - make sure your transmitter does not have any trims or mixing set.
Most transmitters need the pitch channel reversed in the transmitter.

Wait let me explain you good. I made my first drone( working fine) and then after a week i crashed it. And then when i plugged in the mission planner i realised the left and right changed between them
( if i turn the board to the left (facing forward)it shows turning to the right).

(If i turn the board to the right( facing forward) it shows turning left)

. I tried yaw 180, pitch 180, roll180…, every rotation i tried but still not working. And then since every other board i am buying it have the same problem.
please help me

Sounds like compass interference, are you near any large magnetic fields?
What if you move outside away from everything?

What version of firmware are you using?
Got a .bin log file to share?

.Not i am not near any large magneticfile ,
.Yes i did the calibration in a good place.
Outside too and…

I am using arducopter v4.3.7 (pixhawk 1m)
I don’t have any
Bin log. Bcs i have erased everything

I tried cuav V5, crossflight v1. All are having the same problem (left and right rotation )

I thought it was my pixhawk boards problem but. I bought cuav v5, crossflight v1. All its seems to have the same problems i really don’t know what to do

You can set LOG_DISARMED = 1 and run the flight controller for a while, doing some movements. That will generate a .bin log file.
Remember to change that back to 0 afterwards so log files are not generated unnecessarily.

Even a crash should still generate a log file - the copter only has to be armed to start logging data.

1 Like

Do you have an SD Card in the flight controller?
Is it a real usable SD Card? There’s lots of fakes around that report many times the amount of storage they really have. Test it in a laptop by formatting and copying lot of files to it - if files are disappearing or becoming unreadable then the card is bad.

When you do the accel calibration, do you use the arrow facing forward (near the LED) as a reference?

maba.log (806.3 KB)

Yes i fo use the arrow facing forward as you can see on the picture above

I cant see anything wrong yet. I could be missing something…
It still seems like you are near major power lines or something like that.

You could try uninstalling MissionPlanner and download a new copy, and install that. There is also a driver clean utility to run before you do the new install.
I’m not sure how that would help, but best to rule it out I suppose.

You could download QGC and try that too. It works fine with Ardupilot and only lacks the log analysis and simulator features.

I tried using qgroundcontrol too. I have been trying to fix this problem for 2 weeks . I em bought multiple board still having the issue. .(But before it use to work fine.)
I even bought a premade drone on amazon but once i plugged it into mission planner the bad orientation happens
Now planing to shift into bêta flight

Are you able to try a different computer? and at a different location?
All the flight controllers cant be bad, and I know of nothing in MissionPlanner to reverse all that attitude and yaw.

Have you done “Reset to defaults” in the Full Parameter list? Then run through all the mandatory calibrations again?

I thought the same . But unfortunately i only have one laptop :confused:

What shows in the picture above is correct in the HUD for a Roll left with default orientation. What else are you saying is wrong?

Its the only thing that it showing the reste parameter are correct. I only have left rolling problem and the right rolling ( in which those 2 orientations changed place between them)

That photo shows no problem.

So you think my quad’s Roll is backwards too?

1 Like

Picture yourself sitting in an imaginary cockpit on the copter. How would the horizon appear if you looked forward? While the screen appears to rotate right, the horizon is being displayed with respect to the pilot’s “view.”

Like this: