Pixhawk 2.4.8 Channel Issue

Hi everyone!
Thanks for reading this.
I’m creating a product for my school, and I’m using the Pixhawk 2.4.8 flight controller board. I have Mission Planner and I have used it to calibrate the accelerometer and a few other things.
My problem is that all the channels, such as pitch, yaw, etc are working properly and I’m getting feedback from Mission Planner showing the inputs from my transmitter. However only channel 1 is not working. I am using a FlySky 10 channel Rx and the PPM encoder that came in the HobbyPower S550 kit.
One thing I noticed is that channel 1 shares a plug with the positive and ground pins. Not sure if that means anything, but it’s an observation.
Does anyone know about this issue?
Thanks everyone for your time!
-Lucas C

Doesn’t that reciever output CPPM or similar? It’s probably easier to buy one that does than mess around with those converters - saves weight and complexity too.

You may not have to use the encoder. Does the Rx you have have iBus out?

Yes I believe it does have Ibus out. I have the fly sky IA10B.

Ardupilot is compatible with iBus. I don’t know this 1st hand having Frsky gear but the documentation says so.

Okay, thank you. When you say it’s compatible do you mean with or without a PPM encoder?

Thank you, however I would like to use a specific transmitter. I don’t know if I would be able to use this transmitter with a receiver that doesn’t output the same format. Thank you for your answer though! It’s much appreciated.

No encoder, just connect the Rx iBus out to Pixhawk RCIN.

Awesome, I will try that. Thanks

Okay, I just took a look at it and I’m a little confused by what you mean. There are 10 total iBus out channels on the receiver, but there’s only one RC in Port on the flight controller. Could I have a little bit of clarification? How would I connect the 10 channels to the 1 rc in port? Thanks in advance

iBus carries all channels on one wire like Sbus. It looks like it supports Sbus as well. Either should work Sbus is much more common.


Thank you for your help, but I’m still a little confused. I’m still a bit of a beginner in this and this is my first drone build. This link brings you too a doc with a picture of the wiring I have setup currently. How would I connect the 10 iBus or sBus ports to the one RC in port without using the encoder I have connected?



I don’t know how else to say it. ONE cable from the Receiver iBus out port to the Pixhawk RCin port and get rid of the converter. Then set the RC protocol in the Transmitter for iBus.

Okay, but which one port are you talking about? I thought that most of the pins were iBus out. Which one port is it? Also, I set the output mode to iBus on the transmitter, but do I select PWM or PPM? Here’s the picture for what I mean.


Also, I had tried setting it to iBus before, and none of the channels were working. Is that because the receiver was not wired right? Or is there something else that I have to do?


PPM>iBus then connect a 3 conductor servo lead from the PPM/Ch1 port of the receiver to the RCIN port on the Flight controller.

Edit: Apparently the iBus output is from this set of pins. PPM is on the PPM/Ch1 output as I suggested above. Credit to poster @Vabe for the photo.

Flsysky ibus

I think mine is set to sbus/pwm on a flysky fs-i6
But by now I’ve changed to a jumper so it might not work anymore, but I don’t recall changing anything…
So in theory it should still work

Okay thank you guys, that is very helpful. I’ll try it and get back to you guys in the morning.

Thank you guys all for your help, it works!!! It’s so relieving, this has been an issue for a very long time and I’m glad I posted it on here. You guys have been so helpful, thank you! I’m getting all the channels’ feedback now.

Hi, i did like you did, the only thing i did different is the landing gear i connected on the ch6, but i being having problems with, like when i retract the landing gear all good but when i extended back the copter crashes, i think it turns the safety switch on, and all motors stops. any ideia to solve it? Thanks