Pitch or roll = oscillation

Hello everyone yesterday I’m trying in new frame like this

Problem is when my copter is take off some time is stable and some time oscillation , video show that

What’s wrong in my frame or configuration.

When I’m realize auto tune then some time my copter stable and many time oscillation , what can I do ???

Motor 2700kv
DYS ESC 30A blheli_s
4s 1500mah lipo

Thank you :slightly_smiling_face:

Those props looks small for that frame size, and potentially the allo-up-weight. What are they?
Flat arms like that are usually bit of a problem too, they suffer from a lot of vibration from the prop-wash.
Get you .bin log file from that flight and share it with Dropbox, Google Drive or similar, and post a link here.

https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

5inch because last project not success on 5inch frame
220mm autotune = battery die yo can check that

What I don’t understand plz tell me some more information :grin:

This is a log file

Thank you :slightly_smiling_face:

You can’t expect that craft to perform well on default parameters and running Auto Tune in that condition is futile. All-Up-Weight=What does the craft weigh with the battery.

Nearly 850gms

And sir when oscillating then motor is too high , why? Any problem in my motor ?

Thank you :slightly_smiling_face:

I don’t know, what 2700kv motors do you have?

Sir it’s solved with custome qgroung control with this feature nearly 2 hours ago and after 3minutes :arrow_down:


And also my copter is destroyed :yum: today i was learned something new :sunglasses: ,

I’m not sad (copter crashed) :roll_eyes:
I’m happy because I have some new things attached with me :smiley:

Thank you :slightly_smiling_face:

It’s solved, you crashed and it’s destroyed and you are happy. OK…

1 Like

Yes , because I was learned like never blind to operate your copter (all switches defined to know this switch mode is this and this switch mode is this and I was mistake like I switched to break fm but it’s full acro mode and … Drop down my copter nearly 30m :yum:)

Also my throttle curve not save (accidentally unsaved this point :sweat_smile:)

And never never never run your copter without autotune :grin:

Thank you :slightly_smiling_face:

OK, I see. Yes, Acro mode can be challenge. Using one of the trainer functions can help.

What do you mean by throttle curve not saved?

Yes, Autotune works well for the majority of craft. After setting the pre-tune parameters it’s a good place to start for sure.

Ok sir I will try it tomorrow :grin:

I’m used 2700kv on 4s , 5s and 6s battery so I need throttle limits and yesterday I’m on 6s and no limits :grin: thank god I’m save my copter during crash , it’s running on 6s it will be fry my last 4pcs motor

How it’s possible I’m not capable for pre understanding this larger or mini copter like nearly this pid value :roll_eyes: and also I want to make new frame

Same problem here when copter goes up and 5 to 10sec it’s going on oscillation mode = motor hot = motor “RIP”

What can I do , plz suggest me :disappointed: already 2 motors are buren on oscillating time also 1 battery die during oscillating.

Any advice for this opportunity ?

Thank you :slightly_smiling_face:

I was suggesting you follow the pre-tuning guidelines here. All you need to know is prop size and battery power (3S, 4S, 6S, etc.).
https://ardupilot.org/copter/docs/tuning-process-instructions.html

Sir there is no longer for 5inch setup

There is only gyro filters on 80hz and recently i use accls filter on 220hz but no help with me

Yes , there can only accls filter when he rise up my copter oscillation calm down going to smoothness side but not exactly :sweat:

Thank you :slightly_smiling_face:

Of course there is pre-tuning info for a 5" setup that’s what the graphs are for. Accel filter at 220Hz? Why would you do that?

Wait a sec

And sir this is a quick note is it right ?

Thank you :slightly_smiling_face:

Use @xfacta Tuning Spreadsheet.

Sorry sir recenly memorised I’m change this ins_gyro_filter function in this frame

This is a martian 220mm freestyle frame and pixhawk is not center and I’m change some function like this ins_gyro_filter finally I show that when I set to 220hz then my copter is little bit stable (less oscillation also no more twitchy)

And ins_accle_filters for, like smooth roll and pitch , I’m right ?

Thank you :slightly_smiling_face:

So you don’t have Excel?

Sir this is for 9inch props

Sir there is some new problem please help me ,
Stabilize mode = work fine
Loiter mode = motor hot + no altitude control

This is a log file https://www.dropbox.com/s/0gfsrll8pyprqku/5%20on%20out%20of%20loiter%20mode%20%2B%20motor%20hot.zip?dl=0

Also this is a video about what I’m talking about

I’m on this frame

Thank you :slightly_smiling_face:

So input the prop size and battery power you have into the Excel sheet and it will re-calculate. Do you really need help to do this?