Pitch moves up and down when flying into wind

Hi guys,

We are operating a few large hexa copters, T1500, which is being sold by T-drone.

Please refer to her specs underneath but they can vary a bit (motor, ESC) depending on versions.

motor: MN8017 KV120

prop: NS30*10

ESC: Flame 80A HV

size: 1600x1600x950mm

AUW: 23kg

Currently, we are facing an issue that one of the drones is getting unstable whenever she is flying INTO wind. She starts to move its head up and down and the vibration sometimes gets worse unless we slow her down. No harmonic notch filter was applied. (Is harmonic notch filter helpful to large copters like ours too?) Autotune done with aggresiveness as of 0.1 and FC(cube orange) is dampered.

Here is the current parameter.

Someone adviced me to modify PSC_VELXY_D down to 0.07 and it seemed to have worked at that time but the symptom is back again. ( or it was always there but I haven’t noticed it)

She flies quite smoothly on Althold mode.

Any advice will be appreciated.

Post a link to a .bin flight log.

Hi Dave,

Please find attached two log files.

One is from our actual mission flight and the other one is from the test flight afterward.

Thank you

mission flight

test flight

A hover flight would be interesting to see as it looks like the outputs are oscillating. You do want to configure the Notch filter and a couple other parameters:
INS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,4
PSC_ACCZ_I,0.44
PSC_ACCZ_P,0.22

I would set this back to default PSC_VELXY_D. and then come back to it possibly.
Was this determined from Setting the Motor Ranges? Setting Motor Ranges
MOT_SPIN_MIN,0.15

OK. I set PSC_VELXY_D to default value 0.5. Also, these values are adjusted as you suggest.
PSC_ACCZ_I,0.44
PSC_ACCZ_P,0.22

MOT_SPIN_MIN,0.15
Yes, It was 0.15 is default value for our drone. Is that what you’re asking?

Setting up a notch filter didn’t look easy (I actually tried to go ahead with it a couple of times before) but I will give it a try once again if it is going to improve the performance a lot.

That’s the default value for Arducopter, I’m asking if you determined it by following the Setting the Motor Ranges guide in the link.

I found mot_spin_min value in the parameter uploaded is set as 0.04 and it was given from manufacturer.

I didn’t follow that Setting Motor Ranges guide. Btw, our drones’ mot_spin_arm and _spin_min are same as of 0.04. According to the guide, spin_min is to be 0.03 higher than spin_arm value. That means, for our case, spin_min needs to be 0.07 at least. (let’s assume that spin_arm value is correct one) Am I right?

I couldn’t make time to test drone today but let you updated when I do. Thank you.

Arm and Spin are determined experimentally using Motor Test as per the guide not given by a manufacturer. Just follow the procedure.

And if it’s T-Motor hardware then for sure don’t believe what they say as it’s not consistent.

Thanks for your suggestion regarding T-Motor hardware. I will keep it in mind.

I went for a test flight just before and wind was not high at around 2~3m/s.

NS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,4
PSC_ACCZ_I,0.44
PSC_ACCZ_P,0.22

These parameters were fixed beforehand but I forgot to fix PSC_VELXY_D back to default value, 0.5. I might give it another try with that D value fixed if needed.

The flight seemed OK this time to me.

BTW, MOT_SPIN_MIN was 0.15. I was too tired last night and probably had things mixed up. Mot_spin_arm 0.03 and _spin_min 0.15. I might have to make some time to do the proper motor range setting ASAP.

Please find today’s flight log in HERE.

Thank you.

OK, set these notch parameters:
Notch filter

And this ATC_THR_MIX_MAN,0.5
You might want to try another Auto Tune as the notch filter should have been configured before running it.

We made two flights this morning.

It was a bit windy at around 4m/s constantly.

First one, with all those HNTCH parameters and ATC_THR_MIX_Man adjusted as suggested. There was no notable shaking in pitch and roll axis.

Second one, I modified PSC_VELXY_D from 0.07 to 0.2. When we pushed her up to max loiter speed and put pitch stick in to middle she stopped but became unstable a lot. After that, we landed her immediately.

Few weeks ago, we had a bad crush breaking arms and legs when I modified PSC_velxy_P,I,D back to default value. At that time, when she took off, she was moving like a falling leaf in the wind and I couldn’t get a control of her at all. After that crush, parameters were returned back to how it is now.

Autotune is going to be done when the wind subsides a bit.

How is the notch filter working? I am (have been several times actually) looking into the manual again in the ardupilot but it might take some time for me to understand properly.

Thank you.

Looks good.

Thank you so much Dave.

I am trying to make our drones fly stable as much as possible and there seems to be no end to it.

Your advices are so helpful and I always share them with all my colleagues.

Today, there were two delivery flight.

There was little wind about 2m/s.

Both flight went quite smoothly but we found drone occassionally twisted in the middle of Auto flight or RTL. What could be the cause of it?

First flight

Second flight

I also noticed in the log that drone location while on the ground before launch was keep changing. Could it indicate any fault in any sensors like GPS or IMU?

While I was downloading Logs from drone after flight in the office, I heard EKF something (I can’t remember clearly) Kept changing. Is it normal?

FC is quite old, over 1.5 year, and so are GPSs. I’m worried they could have deteriorated not functioning as it is supposed to be.

Sorry for all these noob questions. If it’s not appropriate asking here, I will make another thread.

Thank you.

Looks like there is some compass interference. I see you have not run Magfit for compass calibration and motor compensation. This should be considered a mandatory process in my opinion and it’s easy to accomplish Magfit Don’t worry about the “Python environment” use MAVExplorer as per the guide. Make a flight with a few figure 8’s and some throttle changes and then use that log.

There are also GPS switching messages. This is normal when using “use best”.
I think the Flight Controller in fine. Update to current Stable.

Our hexa is flying beautiful after we applied all your suggestions.

I also modified ‘ATC_THR_MIX_MAN’ parameter to 0.5 in our other drones (same model) and they also stabilized a lot.

MAVExplorer program was not easy to start with but I am going to keep trying and setting up notch filter on other drones might be my first goal for now.

Thank you so much for helping us out.

Glad to hear it!! For the Notch Filter use the Filter Review Tool, its very comprehensive.
Filter Review Tool

1 Like

Dave,

I’ve been reviewing your advices to get the gist of setting up notch filter properly.

How did you get INS_HNTCH_ATT = 40

and INS_HNTCH_FM_RAT = 0.75 ?

I couldn’t find any clue around FFT graphs.

Also, I found HNTCH_HMNCS = 3 means 4th harmonic. Can I ask why you put 3 in there and what exactly 4th harmonic means?

Thank you.

The filter attenuation of 40 dB has been found to be the best maximum to use in most cases. The Ratio drops the low side of the notch by that multiplier. It can be used to broaden the notch. A harmonic value of 3 is not the 4th harmonic it’s a bitmask value that means 1st and 2nd harmonic.

Thanks Dave.

How did you get the Ratio as of 0.75?

I’m trying to set up another copter myself now and wanting to know how those values came out.

HNTCH_HMNCS 3 ← is this recommended for most copters? or is there any specific condition for that?

By using the Estimated Post Filter function in the Filter Review Tool and seeing it’s effectiveness on the actual data.

No, each case will be different.

1 Like