Passthrough telemetry over CRSF (crossfire)

Hi not sure what might be wrong, I’m testing EdgeTX 2.8.0 + same yaapu script as yours

Ok so I re-flashed EdgeTX 2.8, restarted with a clean SD card, reinstalled Yaapu 2.0.0 dev and now it’s working!
Very mysterious bug indeed

1 Like

I am having trouble getting Yaapu LUA telemetry widget working with ExpressLRS and ArduPlane v4.2.0 or later, whereas it works fine with earlier ArduPlanes, such as v4.1.7 and v4.1.6, on the same hardware.

I use Yaapu Debug CRSF v1.9.5 to see which passthrough messages are being received.
With ArduPlane v4.1.6 and v4.1.7 flashed, I see 0x5000 to 0x5007 being sent and the telemetry LUA widget is happy, whereas starting with ArduPlane v4.2.0, only 0x5000 gets sent and telemetry LUA lists no telemetry.

Equipment used:

Settings on ArduPlane:

  • SERIAL4_BAUD 420 (tested also with 115, no change)
  • RC_OPTIONS 768 (512/Suppress CRSF mdoe/rate message+256/CRSF telemetry passthrough)

CRSF support is enabled for the LUA widget using Yaapu Config.

The ELRS internal module in TX16S mkII as well as RP3 are flashed with ExpressLRS 3.1.1.
ELRS is configured using 333 Hz Full in 8ch mode with 1:2 telemetry.

By looking at ArduPlane release notes, I can see only one related change introduced with 4.2.0 - the CRSF v3. Any tips what I am doing wrong or need to change to get ELRS/CRSF passthrough working with ArduPlane v4.2.0 and newer?

Check your wiring if this is not a type error.

No typo. The ExpressLRS receiver (RadioMaster RP3) is connected to USART3 / SERIAL4 in my case (most interesting is that it works fine with AP 4.1.6 and 4.1.7, but not with any newer ArduPlane fw that I tested (4.2.0, 4.2.3, 4.3.1, 4.3.2)):

From: (EOL)Flight Controller H743-WING – Matek Systems

And also with ArduPlanes v4.2.0 and newer, the radio controls still function, 0x5000 packets also arrive, but just not the CRSF passthrough messages from 0x5001 and above. Thus, I cannot imagine this to stem from a wrong wiring.

Can anyone confirm that ExpressLRS CRSF passthrough works fine (together with Yaapu LUA telemetry widget) with any fw later than ArduPlane 4.1.7? That would give me already a feedback that the issue either lies on the Matek H743-WING support or my configuration or smth. else on my side.

I just finished updating my RM MK one, running EdgeTX 2.8, external Happy Model ELRS on 3.0.1. Using Yaapu 1.9.6 dev I installed last summer. Matek F765 Arduplane 4.3.2. DJI on MSP. All is good. All Yaapu functions working as expected. I put the plane out in my driveway and tested GPS. I looked at the Yaapu Beta 2 but ran away when I saw all the file moves I would need to make.

Hi @Risto,

I can confirm that the Yaapu script runs with ArduPlane 4.3.2 on a H743-Wing (v3). However, I currently have a transmitter here with Ethos. I would have to install EdgeTX first, but it may take some time.

How does the configuration of ELRS look like? Here is currently a Packet Rate of 100 Hz Full and Telem Ratio of 1:2 set.

Thank you for the feedback @Don_Gilles & @Target0815 !

333 Hz Full in 8ch mode with 1:2 telemetry.

Would anyone have ideas/tips how to best further debug where the issue lies in my case with AP fw >= v4.2.0. I see with Yaapu CRSF LUA debug script that with <v4.2.0 I get 0x5000 and higher passthrough data, but with >=v4.2.0 I only get 0x5000 and nothing above.

If it runs in your case with the same configuration under ArduPlane 4.1x, it can only be due to the configuration of AP 4.3.x.

Can you please upload your .param file from 4.3.x?

@Risto, I now have the same configuration as you except for an external ELRS module in a TX16S and EP1 receiver. The Yaapu script works fine with AP 4.3.2 right away.

In debug I get all the data.

Thank you Reinhard for the tests. This motivated me to play around further by flashing the H743-WING back and forth between AP 4.1.7 and 4.3.2 and I managed to finally get Yaapu LUA telemetry running also with AP 4.3.2. By doing the diff of the parameters, I cannot unfortunately still see a reason of why it did not work previously.

H743-WING_AP417_working.param (20.8 KB)
H743-WING_AP431_not_working.param (20.7 KB)

Anyhow works now with AP 4.3.2. Thank you again!

I have imported your not working parameters here on AP 4.3.2 and restarted. Works without problems with the Yaapu script (2.0.0 beta2).

To the parameters still remarks:
On the H743-Wing SERIAL7 (TX6/RX6) is the default port for RCin. It makes sense to leave it like this, especially since you can run an ELRS-RX directly on the 4 adjacent ports.

You don’t have to change the baud rate at the SERIALx for the ELRS-RX, it is set automatically. If 420 kBaud should be used, set the corresponding bit in RC_OPTIONS (last option).

ARMING_CHECK = 1 is elementary. If there are problems with it, fix the problems, don’t switch off the checks.

1 Like

Im using yaapu script (2.0.0beta2 dev)with tx16s on Edge Tx 2.8.0. I ve experinced that the script sometines stuck in the initialization. I had to go into widget setup to start it loading.
FW arduplane 4.4 dev
Found this post about similar issue here: Yaapu telemetry repeat initialization

Yaapu stuck in initializing - YouTube

Hi,please download latest version from master branch here

1 Like

I ve got the information (TBS group) that crossfire/tracer module not support higher baud than 400k, so CRSF v3 not available currently only CrsfShot/v2.
BUT i ve realised tha

t my 405 wing FC running 4.4 custom built fw,reports back CRSF v3…see picture below…what does it mean…maybe i ve enabled it during setup firmware builde and shows that ardupilot is able to handling crsf v3?

I have a KakuteF7 and I can’t get this to work.
CRSF passthrough is working with a custom -dev- build firmware (custom -stable- build is working with CRSF and OSD selection but I have errors on QGC).
I can see some sensors on the yaapu widget so CRSF passthrough is working but there is always the “No Telemetry” red banner on my NV-14 (I have CRSF enabled and I tried many values with RC_Option).
I don’t know where the problem is.