Orange Cube - FrSky Passthrough and MOT_PWM_TYPE issues

Hi. Great times ahead :smiley: !!!

I’m having this issue on an Orange Cube. Tried setting FrSky Passthrough protocol (10) on Serials 1, 2 and 4 (Telem1, 2 and GPS2). With SERIAL_OPTIONS set to 7 and using a straight wire to X8R, it won’t work, no matter what I do. I tried both TX and RX pins on all three ports.
Using a regular serial port MAX3232 cable, with _OPTIONS set to 0, works only with a certain mix of BEC/USB power. It always works if USB power is applied first. It never works if BEC power comes first. If BEC power is applied, then USB, it starts working when BEC power is interrupted, and will keep working if supplied again and USB disconnected.

Now to MOT_PWM_TYPE… I have an APD ESC, which won’t take anything below DShot300 as input, unlike BlHeli_32 that run with classic PWM, as well. I’ve tried both 5(DShot300) and 6 (DShot600), and the APD esc wasn’t happy with the signal - on AUX 1-4, with reconfigured outputs, obviously - then analyzing two short flights with BLH32 yelded PWM values on C9-12 while protocol was set to DShot600

are you using a telem s port conversion cable ?


Any chance you can provide a log? It’s really hard to investigate without a log.

With a log file we can check your parameters to see if there are any obvious configuration issues.


Log disarmed is set. I power by LiPo, then USB, remove and replug the LiPo - passthrough starts - and then a short flight.

I’ve since tried -rc2 and the latest master at the time of writing and both issues persist.
I only get passthrough telemetry on my Taranis when booting on USB power, and my BlHeli_32 ESCs get fed with PWM signal, no matter what type of DShot protocol is selected: 150, 300, 600 or 1200.


I’ve added this to our issues list so it won’t be forgotten…

1 Like

@rmackay9 I can confirm that I have the same issue with the FrSky Passthrough not working when using the soft serial options. I get the issue on CUAV 5 using either X8R or R9 receivers. The issue is a bit over my head to fix, but happy to help out with tests.

I saw @tridge making some Chibios changes - for the Pix4 dim led - and decided to load master.
The passthrough issue is still there. Start on LiPo, no cookie, add USB, still no cookie, disconnect LiPo, passthru starts flowing.

do you get the same behavior as @ThePara where it works if you power on USB only?
Does it work for you with older firmwares, such as copter 3.6 on a board that supports it?

I opened a topic about what may be a related discussion, at least with regard to the SERIAL_OPTIONS=7 variant not working. (Cube Orange UART Inversion & Half Duplex Problems)

At first I thought this was due to the pin output mode being set to push-pull in the hardware definition header where the reference manual wants open drain for half duplex (At least on the H7s). However, changing that during the option parsing in the UART Driver didn’t seem to make any difference.

Both the CUAV v5 and the CubeOrange have a TXS0108E over the UART lines, I assume for some form of protection. This has internal pullups which may be the source of this particular problem. Though that said the RX lines work so there may still be a software fix. One option could be to set the RX/TX swap bit in the UART register, similar to how the half-duplex mode is switched after transmission.

In the meantime an additional pulldown resistor on the line gets the telemetry working albeit somewhat precariously.

1 Like