Orange Cube 4.0 and BLH passthrough

I’m setting up my first Orange Cube build and trying to get BLH passthrough working. I’ve never had any issue with the black cubes I’ve set up. I have SERVO_BLH_AUTO = 1. When I try to connect with the BLheli32 config program, it connects to the serial port, but when I try to read the settings from the ESC it fails. Motor test in MP works just fine, so I know the cube and ESC are communicating.
Does anyone have passthrough working on their orange cube? Any help is appreciated.

I have a CUAV cube and mine does not work either. I have a build an interface using an arduino.

Which app are you guys using I ask because I had that same issue and then found I was using the wrong application and when I changed it it worked fine.
I was using this one and not the web one. Your probably using the same but thought I would put it out there.

Are you able to connect and read the ESCs?

you need to be using the AUX outputs (9 - 14) on the Cube to get BLHeli

Hey Dave. Yes read them and program them. Peter is right however you have to be using the aux pins for cube. For Pixracer or similar they have a direct tie to the cpu and so your good on them.

Ahh. That’s what I was doing wrong on my octo. I use the main pins and use oneshot 125.

On my hex I used the aux pins as I run dshot600

I will give it a try in my hex

I’m not sure what you mean by the web one? I’m using the latest blheli32 suite. It’s worked fine on my black cubes.

To be clear I’m using the aux outs and motor test in MP works just fine. I just need to change direction of some of the motors.

Sorry I am far from an expert I just know there was two different Blheli configurators. I thought one was browser based and the other a standalone app like the screen grab I showed earlier.

@rmackay9 I’ve been wrestling with this issue for more than a week now without success. I was hoping that 4.0.2 would resolve the issue. I tried installing it and still am not having any luck getting passthrough to work. Here are my BLH related settings.

blh settings

Here’s the error I get when trying to use the latest BLheli32 suite. It seems to connect successfully on the com port, but then throws this error when I try to read the ESC settings.

I’m open to any suggestions or advice. I’m stumped!

If you switch on debug in blheli suite what does the output look like?

I’ll try that now. I just tried an older version of suite to see if it would help as I had that issue in the past, but now it throws a different error.

Here’s what I get from the log. To be clear there is good communication between the cube and esc as I can run the motor tests without any issue in Mission Planner.

suite log

You could also try turning on SERVO_BLH_DEBUG and setting SERVO_BLH_TEST to 1 and see if it passes (look in the messages tab)

Can you expand the ‘+’'s it’ll show how far it got?

I built an arduino interface for my BLHeli ESCs because I can NOT get pass through working on my cube, so I gave up.

Stupid question, but you are using DSHOT right? Passthrough won’t work unless you are using DSHOT (which means you need to use outputs not on the IOMCU)

Yup I’m using DSHOT. I’ve done this setup with black cubes many times and haven’t ever had a problem like this.

Absolutely. I have a couple of copters with cubes and I can’t get any working. I am using the CUAV V5+ cube. Some use the pwm outs and some the aux outs.

At this point it doesn’t matter for me as I have a method to do what I need

I use a old Naze32 FC as a BLHeli programmer for occasions when passthrough doesn’t work. They are ~$13 for the Acro version.

1 Like