Servers by jDrones

Nimbus Tricopter VTOL

Thank you, sir! My first subject will be about unreliable Vtail servos.

I got my Nimbus VTOL V2 from Foxtech 3 or 4 months ago. It’s the T12 version, because I liked the compactness of the Skydroid T12 radio that comes with it. After two successful flights, and while preparing for a third, I noticed a Vtail servo twitching like crazy. I sent a video of this to Foxtech, and they sent me an entire Vtail assembly, with servos installed. It came with no instructions, so I installed it, made sure the tail surfaces moved in the proper directions, and launched.

This resulted in a crash wherein the Nimbus just tracked straight toward the ground, without any response to my inputs. Foxtech analyzed my logs, and told me that the servos were not properly calibrated. I’m new to airplanes, so I was unaware they needed that. Anyway, one vtail surface moving up too far created a tail stall, and the plane went nose down.

For those of you who haven’t experienced this, be prepared for Foxtech’s cheapo servos to fail. And when you replace them (hopefully with better ones), be sure to adjust them in the Parameters settings (Servo Min, Max, and Trim). Foxtech says they put theirs at 30 degrees up and 30 degrees down. And, if you’re concerned about your CoG being too far forward, and can’t get it to move back, add 3 to 5 degrees up to the trim, so the tail will be pushed down in forward flight.

I imagine that me teaching any of you guys about how a Nimbus works is like teaching water how to flow downhill, but perhaps someone will find this information useful.

I hope you guys are doing well. Sorry for the long post; I’ll try to make them shorter in the future.

1 Like


More posts on an issue is better than no posts as it creates a consensus. If you search for “EMAX” in this thread, you’ll find several complaints about the tail servos quitting. In Post #434, I show my replacement of the EMAX ES3054 servo in the tail…which has worked fine since.

MyFlyDream designed the v-tail structure around the EMAX ES3054 servo so it was difficult to substitute a higher quality servo. I tried to fit several different servos but the sizes were always just off a bit so I found an exact replacement (and testing) to be easier.

As you have found out, the new servo needs the max, min, and trim recalibrated after installation.


Fair enough, I’m happy to contribute what I know.

To Foxtech’s credit, they shared the responsibility for the crash and have sent me some replacement parts for 50% off. Meanwhile, while growing impatient with the abnormally long shipping times, I repaired my Nimbus by making a new nose cone from EPP foam that came out of a car bumper. I also used EPP to replace crushed portions of the fuselage. New servos and props, and I was able to launch it again last week.

It crashed again. At 30 meters altitude, I switched to FBWA, it got unstable, and headed straight for the ground. Remarkably, my EPP nose cone was totally undamaged, but the EPO fuselage is a mess.

I’m not very good at interpreting logs, but I suspect an in-flight reboot due to excessive power draw. When I downloaded the Flash logs, two KMZ files appeared: One in Qhover as it climbed, and one in FBWA as it descended. Could this be that the Pixhawk Cube re-booted in flight?

Anyway, I really appreciate your inputs about the tail servos, and I hope my contributions are helpful.


I’m not sure why this happened but next time do the initial transition higher (say 100 meters) and use QSTABILIZE or QHOVER as your emergency go-to mode when something looks wrong.

If you can host the .bin file somewhere and post a link, we can help interpret them.

I have not seen this before. I have never used a Cube so perhaps someone else can help.

David: mine did the same thing.

Hey David, sorry to hear about your problems, but I suspect there is more to this behavior, although I can only speculate right now.
I fly a vtail tiltrotor as well and although not a Nimbus, it is a similar arrangement. I had my share of unexplained nose down dives this year and on my last flight I discovered something strange. My rcin channel 2 was maxed out by me trying to bring the nose up/climb. Looking at the vtail servo output I can’t find the proper response. What I could find is the yaw pids wanting to correct the yaw error from the transition. What I mean is at the moment of me switching to FBWA, the plane yawed to the left like 45 degrees and thus introducing a big error in the yaw pids. This error was carried out in FBWA mode and while I wanted to move the servos up and gain altitude, somehow the yaw error prevented that. At least this is what I get from my logs.
I’ll investigate further upon repairs.

1 Like

Hi Guys!

I appreciate your prompt responses and input.

Romeo: My first crash was caused by the right Vtail servo moving too far, which created a yaw and a tail stall. On my second crash, the Vtail surfaces were properly adjusted, so now my focus is on why the Nimbus made two separate logs for the same flight.

Mr. Covey: When my Nimbus faltered on transition, I immediately switched to Qhover mode to recover it, but it was unresponsive. This suggests to me that it was in the middle of its reboot sequence, and was ignoring all commands. CG was dead-on centered, the airspeed sensor was responsive, etc.

I’ll try to figure out how to post my two logs (they’re very short), and I appreciate the input of anyone who cares to look at them.

Meanwhile, I’m designing a new fuselage made entirely of EPP foam. My intent is to make this plane as crashable as possible, so I can minimize bench time between crashes while I sort this issue out. I’ll keep you guys posted on that project.

Here are my two logs. I hope this works, this is my first time posting a link to file on a forum. Thanks for your help, guys!

Yeah, yours is clearly a reboot. I had one of those too but much lower and without too much damage.
In your case I would keep an eye on your battery, it is going pretty low pretty quick.

Hello Romeo:

Yeah, that was the impression I got. Why else would it have two separate logs? This Nimbus has a battery switcher; the small-capacity, high-output battery is for VTOL, and the large-capacity, low-output battery is for forward cruise flight. To date, I’ve never depleted the VTOL battery to the point it wouldn’t hover the aircraft. One concern I have is that the recommended forward-flight battery is only a 6C discharge. Does this seem a bit weak to you? I’ve had successful flights in the past with a 12C output battery. I wonder if this would lead to a reboot. It shouldn’t, because this is the exact battery Foxtech sells for this aircraft. Also, this crash occurred since I updated my firmware to 4.00. Are there any issues with that version that you guys know of?

Anyway, I really appreciate your input. I’m sorry to be dominatiing this thread with my situation. I hope I can be as helpful to someone as you guys are to me.

1 Like

I only brought up the battery because it went down to 3.25 / cell during the climb. For a lipo going lower than 3.3/cell is not very good.
For the large battery, it is plenty enough a 6c since you draw much less current in plane mode. Or at least you should, depends on you flying style. You should be at 10A or less during plane cruise, that is 1C for a 10000mAh battery.
In my case when it rebooted I was coming in for landing, pretty low since it transitions very well and it rebooted 1s before I switched to Qstab so it landed a little rougher from the momentum it had. I still don’t have a reason for the reboot and I have only one battery. I also have 4 voltage regulators, each tilt servo has it’s own, plane servos a different one and one for the Pixhawk. The plane flew many more times after that so my wiring / voltage regulation is fine, must be firmware issue, maybe the i2c storm. Plane 3.9.8 on mine.

In your second log you can clearly see it initializing, the firmware knew it rebooted, but unfortunately the way it works is you have full servo control but no throttle, so you can only save it by landing in plane mode dead stick or by arming so you have throttle control.

Hello Romeo:

Assuming I can figure out the cause of this reboot, I’m considering gettting rid of the battery switch and running just one battery, like you. That would simplify things, and CoG would be easier to achieve if two batteries aren’t crammed in there. To that end, what flavor of battery are you running? Would a 6S, 12C be sufficient for VTOL?

Well it depends on the battery capacity, I run a 12000mAh 10C lipo battery, that means about 120A current discharge and I draw about 60-70A when climbing and 30-40 when descending.
In your case I see 80-90A during climb so choose a battery according to that. And at the end of the flight remember to not do any climbing because at the end of the flight the battery might not be able to provide the advertised current. All these numbers are for Q modes, in plane should be much lower numbers.

1 Like


I looked at your logs and agree that the second log is from the Cube re-booting. I don’t see anything wrong with your take-off except perhaps for excessive current draw while hovering. Is this a Nimbus VTOL purchased from FoxTech FPV? Was it altered in any way?

Your battery voltage and Vcc to the Cube look fine. You are well above the battery failsafe setting. If I had to guess, I would say that it looks like your main large battery did not connect properly after the mode change to FBWA and the Main Output 7 commanded the switchover. After the re-boot, you were back on the smaller battery.

I don’t use the dual battery setup but I would look into testing this area on the ground using the information on the Foxtech PG20 V1.1 Dual Battery Swapping Board page.

Good luck!

1 Like

For David’s firs log, I would also want to know why there is no message with Transition airspeed wait, Reset alt target and Transition airspeed reached. The log ends 2 seconds after the mode changed to FBWA.

Hi guys!

Thanks for your input. Romeo, good copy on the battery math. I have a 12000mah, 12-24C, 6S lipo that I’ll try for single-battery ops. By putting an XT90 connector on it, I bet it’ll have plenty of power for hovering and significant cruise flight. 1 takeoff and 1 landing depletes a 2200mah battery to 35%, so I’ll do the math to figure out max cruise flight time.

Mr. Covey: Thanks for looking at my logs. Yes, it’s a FoxtechFPV Nimbus VTOL V2. The only mods I’ve done to it are an EPP nose cone, which is maybe 10% heavier than the EPO cone; 70 grams of weight on the tail for better CG; and a pair of APC 13x8 propellers on the front. Also, my elevation here is 3500 feet MSL, so the thinner air, combined with some added weight, and possibly less efficient props than the original Gemfan woodies, may explain my 80-90 amp draw in hover.

I believe I’ll get rid of the battery switch and run one battery. I think that Foxtech installed these and pushed them on the V2 Nimbus, and perhaps didn’t do as much research on reliability as they could have. I think it adds a complication to the process of VTOL flight, and if it reboots my Pixhawk, it does me no good.

As far as the small battery being connected after reboot, that may be because the instant I saw the Nimbus flounder in transition, I popped it back into Qhover mode, which would have re-connected the smaller battery.

Anyway, I have all the parts I need to reassemble this feller, so I’ll put it together tonight and launch it again tomorrow. I’ll let you guys know how it goes!

Thanks again for all your help and input; we’ll get this thing off the ground eventually.


1 Like

Hi Greg: when you get time I’m trying again to up load my Log for my nimbus crash let me know if this worked thanks B.K

Hey Ronald: That link didn’t work for me. Have you tried the little “sharable link” button on Google Drive? That’s how I posted my logs.

1 Like David: Thanks for the reply i’m not good doing this file sharing and computer stuff i’ve tried several times since i crashed the nimbus about the same time you had your mishap so i saw how you put your logs on here and i tried doing the same but i must not be doing it the right way so here i go again let me know if it goes thru Thanks B.K

Ronald: Here is what worked for me:

  1. Go to Google Drive, and log in.
  2. Click the oval “NEW” button, then “File Upload”
  3. Browse to the file you want, and it gets put in your Google Drive.
  4. Single-click your file in Google Drive to highlight it, then click the “Get Sharable Link” icon (looks like a broken oval racetrack with a horizontal line in the middle).
  5. Move the slider to the right so it turns green, and says “Link Sharing On”.
  6. Double-click the URL that appears in the box, copy it, then paste it here in the forum.
  7. Go outside and crash your Nimbus, so we can have some logs to look at. Then do steps 1 through 6. :slight_smile:

I hope this helps! David i’m trying it again

Servers by jDrones