Nimbus Tricopter VTOL

Greg,
I am new in this - the AS is quite important to use.
If the Nimbus stalls at 11m/s and you have set GPS speed at 15m/s
as soon as you get a tail wind of more than 4m/s the plane will stall.

There is some where a setting that tilt rotors will come on in a stall situation
to assist keeping the plane in the air.

Of the track (SORRY) - i do not know how to post something please help
I had a few issues on my first flight which i would like to ask/share
My .bin file is 17Mb can it be posted?

Hi Greg,
From your graphic can be seen, that the airspeed sensor measures too low. You probably know that too.
But the following causes are possible:

  • faulty preflight calibration (electronics not warmed up, uncovered airspeedsensor while doing preflight calibration , sensor not shielded from sunlight, wrong automatic detection of dynamic/static input)
  • clogged dynamic pitot tube
  • wrong ARSPD_RATIO
  • Sensor broken

Why not use the SDP33 - without need of preflight calibration.

Rolf

Hi Rolf,

Thanks for the suggestions. I guess that I will be stuck to upgrade my AS sensor since you cannot rely on using the Speed gauge in Mission Planner as a sanity check. In previous applications, these analog sensors have worked fine so this would be my first bad one. The only other change is in using newer Plane v3.9.8 firmware. My tests have been repeated with the same results so why does the Speed gauge in Mission Planner work? Perhaps it is a false positive.

Marcel,

Welcome to the forum! Look at the Q_ASSIST_SPEED parameter. Most users have this set to 11 m/s.

To post a .BIN file, you need to host it somewhere and then add the link to it in your post.

Cheers!

To clarify: the Speed gauge in Mission Planner does seem to work properly in my setup. It bounces from 0-2 without air and I can blow into the pitot tube and watch the needle go up to 30 or 40 m/s.

Is there another way to ground test the AS sensor operation?

I read something wrote by tridge about testing aspeed with temp readings, if I can find or someone remember please post link for you.


Looks if Tridge comment is usefull, page 3

1 Like

Greg uses an analog sensor that is not connected via I2C. Tridge describes a test to determine if the I2C transmission is working properly

1 Like

Ok, thanks, guys. I have several other complete analog AS sensor sets so I can try swapping out the current one. My point is that even after I swap it out, it seems the Speed gauge on the HUD may not be a foolproof way to test it…but I can look for differences between the two sensors. I’ll then fly it and look at the logs since it gets logged even if you don’t use it.

Eventually, I would like to get the SPD33 sensor kit but it still says “Pre-order” on the Drotek site.

Cheers!

Greg, this seems to be the same problem I am having, that the transition doesn’t seem to complete with the motors tilted partially up. I thought it was solved by going from 11m/s to 9m/s for ARSPD_FBW_MIN but I still had an intermittent issue since then, although Musa reported that it was fixed with his aircraft after that change. Wish @tridge would come past to comment.

It’s also possible that Q_ASSIST_SPEED must be lower than ARSPD_FBW_MIN otherwise one gets too much ‘assistance’ at the lower airspeeds.

BTW, [quote=“Oubie, post:480, topic:31042”]
If the Nimbus stalls at 11m/s and you have set GPS speed at 15m/s
as soon as you get a tail wind of more than 4m/s the plane will stall.
[/quote]

This is not quite true as whether or not one uses an airspeed sensor, Arduplane calculates the wind speed and direction and will increase the plane’s airspeed to try to always fly at, at least ARSPD_FBW_MIN. (To quote: This is referred to in the aviation business as PFM, Pure F’ing Magic.
The magicians (Tridge and Paul) use accelerometers to calculate the approximate wind velocity.)

There’s more about that here: https://diydrones.com/forum/topics/without-airspeed-sensor-how-does-apm-2-6-use-airspeed?xg_source=activity

Hi Graham,

I agree. I just have the added confusion that the airspeed logs graph to crap while the GPS ground speed seems fine. The cure for me is to disable ARSPD_USE. The Nimbus transitions and forward flying are then superb. I’m using stable Plane v3.9.8 on a Pixhawk 2.4.8 (Pixhawk 1) pulled in from Mission Planner.

Is your setup using an analog AS sensor? Pixhawk 1? Is there any other commonality between our setups that might suggest an area to look? Doesn’t the code have a transition time-out on reaching ARSPD_FBW_MIN or revert to GPS speed if the airspeed data is garbage?

I’ll connect another AS sensor this afternoon and look for differences.

Cheers!

The second analog AS sensor behaved the same when blowing into the pitot tube. You can see the Airspeed gauge below behave properly. This was true on both setups. Perhaps if a bug exists, a workaround may be to install a digital AS sensor…for now.

After using a multi-meter, I figured out that the connector between the nose and body was not fully mating. There was no artwork or alignment issue…it was simply a depth problem. I fixed my nose connector problem by replacing the three stock screws in the nose board with slightly longer ones and added some spacers in the back to move the board outward. The spacers were held in place with tiny pieces of paper. Now, my AS sensor and gimbal power/control is back to being cable-free.


Greg, Thank you
Graham, These guys are magicians
My problem - hopefully you experts can get it from the log
I took off in QLOITER then change to CRUISE and after a circuit changed to AUTO
The plane pitched up, climb for a few metres , stopped and transitioned to VTOL ( hanging in the air)
I changed to QLOITER and tried to bring the plane back
All went fine but i had no rudder control.
My questions: Why did it not fly the mission and secondly why did the rudder died on me?

Can you post your mission file?

2019-07-10 09-49-23.log0wp.txt (668 Bytes)

Hope this worked

It comes out a bit odd when I open it in MP but I can see it. I think you need to take out the Take-off command from the mission as the plane will try initiate a take-off by going back to hover mode. If flying already then just put a waypoint in as your first mission item.

Not sure about the rudder, is this in 'copter mode? Because the rudder doesn’t work anyway on my Nimbus in plane mode.

Graham,

Did you mean to say the rudder doesn’t work in copter mode? Or is this in plane mode in an autonomous mission?

Cheers!

Rudder surfaces don’t move in plane mode, yaw in copter mode works fine.

Thanks - will change my flight planning procedure and try again
The rudder movement might be that it went from CRUISE to VTOL
without a command (or a none standard command) and switching to QLOITER
over another CRUISE command ( very quickly) did not register properly.

Will check and report back in a week or so.

Hello guys, we just tested the Nimbus V1 with 12000mah 6s, flew 40mins with still nominal values on each cell. AUW was 5kg`